LINUX.ORG.RU

startx - пропал звук в GNOME!


0

0

Юзаю Ubuntu 9.04 на Acer Aspire 5520.

Когда я захожу в систему при помощи gdm - то звук слышен (т.е. проигрываются музыкальные файлы вполне нормально). А если в консоли сделать так:

sudo /etc/init.d/gdm stop

startx

- то звук куда-то исчезает!

Причем в текстовом режиме (при помощи mplayer) мои музыкальные файлы вполне нормально проигрываются - а в гноме - нет.

Еще несколько особенностей насчет pulseaudio:

Если удалить pulseaudio из системы, то звук "входа в сеанс из gdm" воспроизводится грязно - но в остальном все нормально. Если же при удаленном pulseaudio войти в гном через startx, то на значок регулятора громкости показывает, что звук отключен, если на нем кликнуть то он выдает сообщение:

"Регулятору громкости не удается найти ни одного управляемого элемента и/или устройства. Это означает, что либо не установлен правильный модуль GStreamer, либо не настроена звуковая карта.

Вы можете удалить регулятор громкости с панели, нажав правую кнопку на значке динамика и выбрав «Удалить с панели» из меню."

или вот это сообщение:

"Модули GStreamer и/или устройства регулировки громкости не найдены."

Re: startx - пропал звук в GNOME!

Забыл добавить, что если не трогать pulseaudio, то никаких сообщений не выводится, файлы вроде-как проигрываются - но звука НЕТ.

ironperson ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

Всегда вместо startx делай:
$sudo /etc/init.d/gdm start
И какие тут еще проблемы ?
зы:
регулярно раз в неделю это кто-то обнаруживает ...:))

elipse ★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от elipse

Re: startx - пропал звук в GNOME!

>И какие тут еще проблемы ?

Просто чисто из любопытства... Предположим, что на рабочей станции работают несколько пользователей (простых). Следовательно, у них нет прав запускать gdm (sudo /etc/init.d/gdm start). И что ж им теперь без музыки сидеть? :)

ironperson ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

> что на рабочей станции работают несколько пользователей (простых). ... И что ж им теперь без музыки сидеть? :)

так работают же! :)

fhh ()

Re: startx - пропал звук в GNOME!

выбрать alsa в gnome-sound-properties после удаления pulseaudio?

cobold ★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

> Просто чисто из любопытства..
;))
ну попробуй тогда так:
$sudo /usr/bin/pulseaudio -D --log-target=syslog &

elipse ★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

> Почему ж в Дебиане все со стартиксом работает???

Либо в дебиане по умолчанию pulseaudio не используется вообще, либо он запускается общесистемным демоном (что не рекомендуется разработчиками), а не при старте сессии конкретного юзера.

mironov_ivan ★★★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от mironov_ivan

Re: startx - пропал звук в GNOME!

>Либо в дебиане по умолчанию pulseaudio не используется вообще, либо он запускается общесистемным демоном (что не рекомендуется разработчиками), а не при старте сессии конкретного юзера.

так я удалял pulseaudio - не помогает. Потом по умолчаню в gnome-sound-properties ставил Alsa - без толку.

А почему не рекомендуется??

ironperson ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

> так я удалял pulseaudio - не помогает. Потом по умолчаню в gnome-sound-properties ставил Alsa - без толку.

А звук пропал только в gnome? Попробуй что-то вроде aplay -vD plughw:0,0 /path/to/file.wav, если звук есть, то ALSA работает. Если звука нет - пости то, что вывел aplay. Если только в gnome - попробуй ещё запустить gstreamer-properties и поменять настройки там.

mironov_ivan ★★★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

> А почему не рекомендуется??

http://www.pulseaudio.org/wiki/SystemWideInstance

Running PulseAudio in system-wide mode has some limitations:

    * All users with access to the sound server cann kill/modify all sinks/sources and streams of all other connected clients
    * There is only a single namespace for cached sound samples, i.e. there can be only a single Gnome event sound profile active at the same time 

It has some advantages over the per-user setup:

    * Multiple local users can share the same instance
    * Better security, because the daemon runs under its own user/group, seperate from normal users 

It has some disadvantages:

    * Worse security, because the user can now command a server app running under another user name. He could even load/unload modules from that sound server
    * Settings like the stored volume levels managed by module-volume-restore are no longer per-user but system-wide 

mironov_ivan ★★★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от mironov_ivan

Re: startx - пропал звук в GNOME!

Звук пропал только в Gnome. Если сделать Alt+Ctrl+F1, и воспользоваться mplayer - то все работает!

ironperson ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

gstreamer-properties пробовал? Если запустить гномопрограмму (например totem) из терминала и попробовать проиграть что-нибудь - на терминал выводятся какие-нибудь сообщения об ошибках?

mironov_ivan ★★★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от mironov_ivan

Re: startx - пропал звук в GNOME!

>gstreamer-properties пробовал? Если запустить гномопрограмму (например totem) из терминала и попробовать проиграть что-нибудь - на терминал выводятся какие-нибудь сообщения об ошибках?

Запустил Totem:

/var/lib/python-support/python2.6/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead import sha

ironperson ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

>Почему ж в Дебиане все со стартиксом работает???
по умолчанию пульса нет

amorpher ★★★★★ ()
Ответ на: Re: startx - пропал звук в GNOME! от ironperson

Re: startx - пропал звук в GNOME!

sudo aptitude remove pulseaudio && sudo aptitude purge pulseaudio

скрипт на всякий пожарный (обычно для спящего режима), по крайней мере в 8.10 (не знаю, может в зайце починили):
#!/bin/bash
/etc/init.d/alsa-utils stop
alsa force-reload
/etc/init.d/alsa-utils start

amorpher ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.