LINUX.ORG.RU

openSUSE 42.1 + KDE5 + ? = полная русификация

 , ,


0

1

В openSUSE с KDE5 установлены всяческие *-lang файлы, а также kde-l10n-ru, -//--data, -//--doc. Приложения KDE4 (Amarok, Okular, …) русифицированы полностью, а в KDE5 (Dolphin, Kate, …), похоже, переведены только специфичные для приложений пункты. Что ещё надо доустановить? Или русская локализация пока не готова?


Русификация и правда неполная. Но собственно она и не нужна. Использую US.

ilinsky ★★★★ ()

А что там не так? У меня, вроде, русифицировано всё. Можешь скрин показать?

IceWindDale ()
Ответ на: комментарий от ilinsky

Не нужна?

Да-да. Большие игры не нужны, драйверы не нужны, теперь и русификация не нужна. Вендекапец не за горами.

Pepsi ()
Ответ на: Не нужна? от Pepsi

Не ну может конечно и нужна, но зато ШГ.

ilinsky ★★★★ ()
Ответ на: комментарий от IceWindDale

Вроде настроено. С украинским то же самое, кстати.

Можешь скопировать список всех установленных у тебя языковых пакетов?

Pepsi ()

В /etc/profile.d/lang.sh и /usr/share/locale/locale.alias соответствующая русскоязычная кодировка (ru_RU.UTF-8 или что вы используете) указана?

Hasek ★★ ()
Ответ на: комментарий от Hasek

lang.sh: «ru» не встречается;

locale.alias:

russian         ru_RU.ISO-8859-5

(Всё — как было по умолчанию).

Pepsi ()
Ответ на: комментарий от Pepsi
# rpm -qa|egrep 'kde|plasma'|egrep 'lang|l10n'
kded-lang-5.16.0-3.1.noarch
kdeconnect-kde-lang-0.9f-1.1.noarch
kdelibs4support-lang-5.16.0-3.6.noarch
kdevelop4-lang-4.7.2-41.1.noarch
kde-cli-tools5-lang-5.4.3-3.2.noarch
kde-l10n-ru-data-15.08.1-1.3.noarch
plasma-nm5-lang-5.4.3-3.2.noarch
kde-gtk-config5-lang-5.4.3-3.2.noarch
plasma5-pa-lang-5.4.3-3.1.noarch
plasma-framework-lang-5.16.0-3.1.noarch
kde-l10n-ru-15.08.1-1.3.noarch
plasma5-workspace-lang-5.4.3-6.1.noarch
plasma5-desktop-lang-5.4.3-6.2.noarch
polkit-kde-agent-5-lang-5.4.3-3.1.noarch
kdevplatform-lang-1.7.2-24.1.noarch
kdebase4-openSUSE-lang-42.1-1.10.noarch
kde-l10n-ru-doc-15.08.1-1.3.noarch
plasma5-addons-lang-5.4.3-3.1.noarch
IceWindDale ()
Ответ на: комментарий от Hasek

Не было sdk. Доустановила и… ничего не изменилось.

Pepsi ()
Ответ на: комментарий от Pepsi

SDK и не нужен, по крайней мере вам. Нужно просто доустановить -lang пакеты для всего, что вы используете. В том числе и для плазмы.

nexfwall ★★★★ ()

Запустить yast Управление программный обеспечением, он зам доустановит

artb1sh ()
Ответ на: комментарий от IceWindDale

По итогам сравнения:

kdeconnect-kde-lang — не найден (как и kdeconnect-kde).

kdevelop4-lang и kdevplatform-lang — явно лишние для меня. kde-gtk-config5-lang и kde-cli-tools5-lang — скорее всего тоже.

kded-lang, kdelibs4support-lang, polkit-kde-agent-5-lang и kdebase4-openSUSE-lang я доустановила (последний притянул за собой и kdebase4-openSUSE), остальные пакеты из списка и так стояли. Результат тот же.

Какие у тебя репозитории подключены?

Pepsi ()
Ответ на: комментарий от nexfwall

Так вроде стоЯт:

zypper search -i *-lang
С | Имя                         | Заключение                                   | Тип    
--+-----------------------------+----------------------------------------------+--------
i | amarok-lang                 | Languages for package amarok                 | package
i | apper-lang                  | Languages for package apper                  | package
i | glib-networking-lang        | Languages for package glib-networking        | package
i | gstreamer-lang              | Languages for package gstreamer              | package
i | gstreamer-plugins-base-lang | Languages for package gstreamer-plugins-base | package
i | gstreamer-plugins-good-lang | Languages for package gstreamer-plugins-good | package
i | kcm_sddm-lang               | Languages for package kcm_sddm               | package
i | kdebase4-openSUSE-lang      | Languages for package kdebase4-openSUSE      | package
i | kded-lang                   | Languages for package kded                   | package
i | kdelibs4support-lang        | Languages for package kdelibs4support        | package
i | kio-lang                    | Languages for package kio                    | package
i | ktorrent-lang               | Languages for package ktorrent               | package
i | kwalletd5-lang              | Languages for package kwallet                | package
i | kwin5-lang                  | Languages for package kwin5                  | package
i | libKF5KCMUtils5-lang        | Languages for package kcmutils               | package
i | libktorrent5-lang           | Languages for package libktorrent            | package
i | nano-lang                   | Languages for package nano                   | package
i | plasma-framework-lang       | Languages for package plasma-framework       | package
i | plasma-nm5-lang             | Languages for package plasma-nm5             | package
i | plasma5-addons-lang         | Languages for package plasma5-addons         | package
i | plasma5-desktop-lang        | Languages for package plasma5-desktop        | package
i | plasma5-mediacenter-lang    | Languages for package plasma5-mediacenter    | package
i | plasma5-pa-lang             | Languages for package plasma5-pa             | package
i | plasma5-sdk-lang            | Languages for package plasma5-sdk            | package
i | plasma5-workspace-lang      | Languages for package plasma5-workspace      | package
i | polkit-kde-agent-5-lang     | Languages for package polkit-kde-agent-5     | package
i | powerdevil5-lang            | Languages for package powerdevil5            | package
i | upower-lang                 | Languages for package upower                 | package
i | xdg-user-dirs-lang          | Languages for package xdg-user-dirs          | package

Pepsi ()
Ответ на: комментарий от artb1sh

Не предлагает. Вообще он обычно начинает доустанавливать кучу всего, о чём его не просили. GIMP и т. п.

Pepsi ()

А настройки от KDE4 в папке пользователя не могут мешать?

Pepsi ()
Ответ на: комментарий от Pepsi

Вообще он обычно начинает доустанавливать кучу всего

Зависимости -> Устанавливать рекомендованные пакеты

nexfwall ★★★★ ()
Ответ на: комментарий от Pepsi

Тогда, как посоветовал товарищ ниже, смени язык в YaST. Либо жди обновления KDE5.

Я сижу на Tumbleweed, и у меня лишь часть локализованных пунктов отсутствует.

nexfwall ★★★★ ()

В YaST выставлен русский язык как основной, вот так. Что-то надо менять?

Pepsi ()
Ответ на: Не нужна? от Pepsi

не ну это конечно же важнее всего чтоб было написано «файл», «вид» и «правка», а иначе же просто непонятно что за пункты меню и зачем они нужны

q11q11 ★★★★★ ()
Ответ на: комментарий от q11q11

То, что тебя устраивает читать помесь французского с нижегородским или пропускать знаки препинания, не означает, что это должно устраивать всех.

Pepsi ()
Ответ на: комментарий от Pepsi

помесь французского с нижегородским

ну если таким для тебя выглядит английский - тебя жаль

q11q11 ★★★★★ ()
Ответ на: комментарий от q11q11

Well, kiddy, as I can see you have problems with typing and comprehension in Russian; are your English skills the same or worse?

Pepsi ()
Ответ на: комментарий от Pepsi

@)>------ Мадемуазель, зачем Вам русификация? :)

anonymous ()
Ответ на: комментарий от Pepsi

диванный ты наш аналитик, каникулы-то когда заканчиваются?

q11q11 ★★★★★ ()
Ответ на: комментарий от anonymous

[curtsey]

Привычка. + пингвина русскоязычные домашние и друзья гоняют.

Pepsi ()
Ответ на: комментарий от q11q11

мне не надо

Санитары за твоей спиной считают иначе. :)

Pepsi ()

Проблема решилась доустановкой пакетов libKF5*-lang и translation-update-ru.

Pepsi ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.