LINUX.ORG.RU

Re: glibc-2.2.4-14.i386.rpm поможите

Кто ж так апгрейдит? Надо rpm -Uhv (hint: i - установка, U - обновление).

abramoff ()

Re: glibc-2.2.4-14.i386.rpm поможите

Ещё бы на RH4.0 ставил... Апгрейдить ВСЁ придётся, одним glibc обойтись никак не получится.

Antichrist ()

Re: glibc-2.2.4-14.i386.rpm поможите

2abramoff: Мля. Если это совет, то огромное сиба я энто прекрасно знаю. Но -Uvh дает еще более худшие результаты чем -ivh/
2Antichrist: А что ты имеешь против RH6.2 мне так кажется что по мессагам из и-нета из RH это наиболее удачный дистр.

GAlex ()
Ответ на: Re: glibc-2.2.4-14.i386.rpm поможите от GAlex

Re: Re: glibc-2.2.4-14.i386.rpm поможите

Ничего против RH6.2 не имею, он действительно самый стабильный из всех красных шапок. Только вот если в нём glibc заменить, то работать он вовсе перестанет, ибо практически всё с ним слинковано, кроме того немногого, что линковано статически, и никто не гарантирует совместимости 2.2.x с 2.1.3. Для того RPM и матюгается на зависимости, чтоб библиотеки, кем-то заюзанные, не менялись. Так что одно из двух - или glibc оставить, или весь дистрибутив менять. Всё от конечной цели зависит. А вообще - если хочется с 2.2.x поиграть, и дистрибутив не ломать - то делается всё очень просто: ставим новый glibc в другое место, и линкуем с ним. Возможно потребуется скриптики для ld малость подправить на предмет статической части glibc, как, к примеру, Oracle советует.

Antichrist ()

Re: glibc-2.2.4-14.i386.rpm поможите

Что-то я не совсем понял или-или. Что значит весь дистр менять или glibc осьавить. Я так понял что есть третья альтернатива это из исходников собирать. Я не очень большой проффи. И у меня собрать из исходников glibc не получается, хотя я с этого и начинал. RPMы мне не нравятся изначально, надо до всего самому допирать.

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

Но не получается :-(

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

2Antichrist: А почему все upgradить надо. Ведь я только glibы хочу. Ведь все новые RPMы на него завязаны? Если не трудно прошу ответить.

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

Ну не совместимы эти глибцы! (конкретно 2.1.3 и 2.2.х) Пакеты с 6.2 хотят старый глибц (и активно не хотят новый), новые пакеты хотят новый глибц (и активно не хотят старый). Скажи спасибо, что rpm тебя об этом предупреждает! А собирая glibc из исходников и ставя его в дефолтное место, ты бы привел систему в нерабочее состояние.

Антихрист дело говорит. Можно собрать себе новый glibc с prefix=/opt/test/glibc (например), и новые пакеты _собирать из исходников_, линкуя с ним. Но граблев там не оберешься.

Я понимаю, что "надо до всего самому допирать". Но начинать с _ТАКОГО_ _ГЕМОРРОЯ_ не советую. ИМХО, обновить все пакеты - лучший вариант.

ЗЫ если будешь экспериментировать с glibc, не послушав советов - хотя бы перепиши себе rpm старого глибца в home directory. А то вдруг mount работать перестанет...

LeninGad ()

Re: glibc-2.2.4-14.i386.rpm поможите

2LeninGad and 2Antichrist: Тогда подскажите как это сделать "обновить все пакеты"? Купить RH71 что-ли? Не хочу слишком просто, я люблю трудности ;-)

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

2LeninGad and 2Antichrist: Выкачать все пакеты и их разом ставить что-ли?

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

А еще по своему опыту скажу что если таки поставишь (а сделать это можно с ключами --nodeps --force) то будешь иметь оччччч большой геморй с русским языком.

kapitan ()

Re: glibc-2.2.4-14.i386.rpm поможите

Полностью согласен с отвечавшими У меня например RH 6.2 стоит больше года - все ОК, проблем нет Причем от первоначального вида осталось не так много - много пакетов обновлено - в частности стоит ядро 2.4. кде 2 и т.д. Но вот проблема такая - все больше новых программ требуют glibc >=2.2 (напомню в RH 6.2 - glibc 2.1) Если все-таки удасться обновить glibc то многие программы перестанут работать (первым делом Х - window) Таким образом, придется обновлять многие пакеты, что займет много времени (одни только иксы чего стоят) Поэтому проще поставить более современный дистрибутив (что я собираюсь сделать) P.S. на самом деле я бы тоже пошел по более сложному пути - просто нет времени :-(

Ray ()

Re: glibc-2.2.4-14.i386.rpm поможите

Я тут попробовал поставить их с флагом --nodeps. И все как ни странно работает. Во всяком случае из того что мне пока надо. Даже с руссифиракией нет никаких проблемм. Я ща пишу из под linux, mozilla-0.9.4, kernel-2.2.14 пока не обновил. и Все вроде-бы как Ok. Поживем увидим что и как выплывет. Всем спасибо.

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

я пытался слаку 7.0(РХ6.2 примерно тоже самое по году выпуска) обновить то glibc 2.2.4 - геМОРОООООООООООООООООЙЙ

gcc/gmake/binutils/texinfo короче все надо переставлять, все глючит, толку 0 - проще реально обновить весь дистрибутив.

anonymous ()

Re: glibc-2.2.4-14.i386.rpm поможите

Похоже. Да. Каменный цветок не вышел. Да ха с ним. Буду 71 ставить.

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

Пагади дарагой :) Учти что в 7.1 гсс стоит версии той которой нет в природе, а именно его написала сама компания редхат, отличительной чертой этого гсс является то что он при компиляции в исходниках пропускает весь ММХ код и про мультимедию можно забыть, так что либо сразу бубуч гсс 3.0 или не ставь 7.1

kapitan ()

Re: glibc-2.2.4-14.i386.rpm поможите

Что за бред я тут слышу???? У меня стоит РХ6.2 (от него правда мало что осталось :) ) Все новое собирал сам и ставил включая glibc 2.2.3

buddha ()

Re: glibc-2.2.4-14.i386.rpm поможите

2buddha : А ты все из исходников ставил или как?

GAlex ()

Re: glibc-2.2.4-14.i386.rpm поможите

2 GAlex napisal ved' chto iz isxodnikov :))

buddha ()
27 августа 2003 г.

Re: glibc-2.2.4-14.i386.rpm поможите

Я скачал драйвера для X86R6 с Nvidia а они не хотят ставиться, говорят что надо glibc обновить, а где его можно взять?, у меня стоит caldera7, и все махинации без драйверов с kernel-frame buffer не дали эффекта на geforce 2 mx 400 (как впринципе и сказано на сайте нвидии)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.