LINUX.ORG.RU

Обновление glibc на centos 5.11

 , , , ,


0

1

При установке пакета получаю:

[root@srv tmp]# rpm -i lightagent-4.0.46-8153.x86_64.rpm
ошибка: Неудовлетворенные зависимости:
        libc.so.6(GLIBC_2.11) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.11)(64bit) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.6) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.6)(64bit) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.7) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.7)(64bit) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.8)(64bit) нужен для lightagent-4.0.46-8153.x86_64
        libc.so.6(GLIBC_2.9)(64bit) нужен для lightagent-4.0.46-8153.x86_64
        libklcsnagt.so нужен для lightagent-4.0.46-8153.x86_64
        rpmlib(PayloadIsLzma) <= 4.4.6-1 нужен для lightagent-4.0.46-8153.x86_64

[root@srv tmp]# rpm -qa | grep libc
glibc-headers-2.5-123.el5_11.3
glibc-2.5-123.el5_11.3
libcap-1.10-26
glibc-2.5-123.el5_11.3
libcap-1.10-26
glibc-common-2.5-123.el5_11.3
glibc-devel-2.5-123.el5_11.3
[root@srv tmp]# yum install glibc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: ftp-stud.hs-esslingen.de
Setting up Install Process
Package glibc-2.5-123.el5_11.3.x86_64 already installed and latest version
Package glibc-2.5-123.el5_11.3.i686 already installed and latest version
Nothing to do

Скачал glibc-2.12-1.209.el6.i686.rpm

Устанавливаю:

[root@srv tmp]# rpm -i glibc-2.12-1.209.el6.i686.rpm
предупреждение: glibc-2.12-1.209.el6.i686.rpm: Заголовок V3 RSA/SHA1 signature: NOKEY, key ID c105b9de
ошибка: Неудовлетворенные зависимости:
        glibc-common = 2.12-1.209.el6 нужен для glibc-2.12-1.209.el6.i686
        rpmlib(FileDigests) <= 4.6.0-1 нужен для glibc-2.12-1.209.el6.i686
        rpmlib(PayloadIsXz) <= 5.2-1 нужен для glibc-2.12-1.209.el6.i686
        binutils < 2.19.51.0.10 конфликтует с glibc-2.12-1.209.el6.i686
        prelink < 0.4.2 конфликтует с glibc-2.12-1.209.el6.i686
        glibc > 2.5 конфликтует с glibc-common-2.5-123.el5_11.3.x86_64

Подскажите, как обновить glibc? Обновление ОС или переход на другую машину не предлагать.

libc-2.12-1.209.el6.i686.rpm

как минимум надо пересобрать src.rpm а не тащить бинарный пакет, но это в любом случае путь в бездну

обновление ОС или переход на другую машину не предлагать.

бекап-то у тебя есть?

alpha ★★★★★ ()

Устанавливаю: [root@srv tmp]# rpm -i glibc-2.12-1.209.el6.i686.rpm на 5.11

*facepalm.jpg*

когда народ уже поймет простую вещь, что по простому не бывает.

По теме обновить до CentOS7, потому что это основная библиотека и при её обновлении всё остальное пойдет в пешее эротическое. Хорошо хоть бэкапы есть.

Ах да и на вкусненькое. Системные требования Легкий агент CentOS 6.8 (64-разрядная), CentOS 7.2 (64-разрядная).

sniper21 ★★★★★ ()
Последнее исправление: sniper21 (всего исправлений: 3)
Ответ на: комментарий от sniper21

rpm -i glibc-2.12-1.209.el6.i686.rpm на 5.11 *facepalm.jpg* Понял.

Ах да и на вкусненькое. Системные требования Легкий агент CentOS 6.8 (64-разрядная), CentOS 7.2 (64-разрядная). Уяснил, был невнимателен.

yellowboy ()

как обновить glibc

Обновить свой дистр, где репы с новым glibc, иначе пересобирай пол системы вручную.

BceM_IIpuBeT ★★☆☆☆ ()

Подскажите, как обновить glibc? Обновление ОС .. не предлагать.

Поддержка CentOS 5.x прекращена в марте 2017 г., поэтому официальны пакетов, если нужной версии не было, уже не будет.

grem ★★★★★ ()

Вот RPM-ки с версией 2.17 для 32-битного CentOS 5: https://yadi.sk/d/u5bobQSfsrzUG Вот некоторая информация, которую нужно знать, если ты собираешься устанавливать мои пакеты:

* Это порт из CentOS 7. Собирал больше года назад, поэтому в моей сборке полно уязвимостей.

* Я не смог портировать post-install скрипты, поэтому после установки выполняй:

localedef -v -c -i en_US -f UTF-8 en_US.UTF-8
localedef -v -c -i ru_RU -f UTF-8 ru_RU.UTF-8

* Также в моих пакетах нет файла /etc/ld.so.conf - не знаю, критично ли это.

* Если ты захочешь скомпилировать новый модуль ядра, то с моим Glibc это перестаёт работать. Устанавливаю Glibc 2.5 обратно - и всё устанавливается. Странно.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 3)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.