LINUX.ORG.RU

Компиляция memscanner

 , , ,


0

1

memscanner http://code.google.com/p/memscanner/
cd memscanner && cmake .
выдает

CMake Error at CMakeLists.txt:22 (QT4_WRAP_UI):
Unknown CMake command «QT4_WRAP_UI».


добавил в CMakeLists.txt find_package(Qt4):


$ cmake .
qmake: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory
-- Found unsuitable Qt version «» from NOTFOUND
Qt QTGUI library not found.
Qt QTCORE library not found.
CMake Error at CMakeLists.txt:22 (QT4_WRAP_UI):
Unknown CMake command «QT4_WRAP_UI».


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run «cmake --help-policy CMP0000».
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!


$ apt-cache policy libqtgui4

libqtgui4:
Установлен: 4:4.8.5+git192-g085f851+dfsg-2


$ apt-cache policy libqtcore4

libqtcore4:
Установлен: 4:4.8.5+git192-g085f851+dfsg-2


usr/lib/i386-linux-gnu/qt4/bin/qmake

i386-linux-gnu

i386

Почему-то хочет 32-х битную версию. Проверь под какую архитектуру стоит qt4

Jurik_Phys ★★★★★ ()
Последнее исправление: Jurik_Phys (всего исправлений: 1)

Тебе нужно поставить соответствующие -dev пакеты.

i-rinat ★★★★★ ()
Ответ на: комментарий от Jurik_Phys

i386 у меня все.

i-rinat
Поставил libqt4-dev qt4-dev-tools:
$ cmake .

-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is GNU 4.8.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc — works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ — works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at CMakeLists.txt:1 (include):
include called with wrong number of arguments. Include only takes one
file.


CMake Error at CMakeLists.txt:21 (QT4_WRAP_UI):
Unknown CMake command «QT4_WRAP_UI».


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run «cmake --help-policy CMP0000».
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Salko ()
Ответ на: комментарий от Salko

No cmake_minimum_required command is present.

Ты явно делаешь неправильно, так как в корневом CMakeLists.txt есть cmake_minimum_required. Ты случайно не в src собирать пытаешься?

i-rinat ★★★★★ ()
Ответ на: комментарий от Salko
rinat@dlaptop:/tmp/1$ hg clone https://code.google.com/p/memscanner/
каталог назначения: memscanner
запрашиваем все изменения
добавляем наборы изменений
добавляем манифесты
добавляем изменения в файлы
добавлено 8 наборов изменений с 72 изменениями в 66 файлах
обновляемся на ветку default
34 файлов обновлено, 0 слито, 0 удалено, 0 c конфликтами
rinat@dlaptop:/tmp/1$ cd memscanner/
rinat@dlaptop:/tmp/1/memscanner$ cmake .
-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is GNU 4.8.2
-- Check for working C compiler: /usr/lib/ccache/cc
-- Check for working C compiler: /usr/lib/ccache/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/c++
-- Check for working CXX compiler: /usr/lib/ccache/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake (found version "4.8.6") 
-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/1/memscanner
rinat@dlaptop:/tmp/1/memscanner$ make
Scanning dependencies of target pList
[  6%] Building CXX object memscanner/pList/CMakeFiles/pList.dir/pList.cpp.o
Linking CXX static library libpList.a
[  6%] Built target pList
[ 12%] Generating qrc_resources.cxx
[ 18%] Generating ui_mainwindow.h
[ 25%] Generating ui_themes.h
[ 31%] Generating moc_mainwindow.cxx
[ 37%] Generating moc_themes.cxx
[ 43%] Generating moc_scan.cxx
Scanning dependencies of target memscanner
[ 50%] Building CXX object memscanner/CMakeFiles/memscanner.dir/main.cpp.o
[ 56%] Building CXX object memscanner/CMakeFiles/memscanner.dir/mainwindow.cpp.o
[ 62%] Building CXX object memscanner/CMakeFiles/memscanner.dir/ranges.cpp.o
[ 68%] Building CXX object memscanner/CMakeFiles/memscanner.dir/themes.cpp.o
[ 75%] Building CXX object memscanner/CMakeFiles/memscanner.dir/scan.cpp.o
[ 81%] Building CXX object memscanner/CMakeFiles/memscanner.dir/moc_mainwindow.cxx.o
[ 87%] Building CXX object memscanner/CMakeFiles/memscanner.dir/moc_themes.cxx.o
[ 93%] Building CXX object memscanner/CMakeFiles/memscanner.dir/moc_scan.cxx.o
[100%] Building CXX object memscanner/CMakeFiles/memscanner.dir/qrc_resources.cxx.o
Linking CXX executable memscanner
[100%] Built target memscanner
rinat@dlaptop:/tmp/1/memscanner$ 
i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

~/Tools/Sources/memscanner$ make
Scanning dependencies of target pList
[ 6%] Building CXX object memscanner/pList/CMakeFiles/pList.dir/pList.cpp.o
/home/user/Tools/Sources/memscanner/memscanner/pList/pList.cpp:1:27: fatal error: boost/regex.hpp: Нет такого файла или каталога
#include <boost/regex.hpp>
^
compilation terminated.
make[2]: *** [memscanner/pList/CMakeFiles/pList.dir/pList.cpp.o] Ошибка 1
make[1]: *** [memscanner/pList/CMakeFiles/pList.dir/all] Ошибка 2
make: *** [all] Ошибка 2

Salko ()
Ответ на: комментарий от Salko
apt-get install libboost-dev libboost-regex-dev

А вообще такие вещи можно искать так:

$ apt-file search boost/regex.hpp
libboost1.49-dev: /usr/include/boost/regex.hpp
libboost1.53-dev: /usr/include/boost/regex.hpp
libboost1.54-dev: /usr/include/boost/regex.hpp

i-rinat ★★★★★ ()
Последнее исправление: i-rinat (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.