LINUX.ORG.RU

При сборке пакета неправильно определяется версия CMake

 , ,


0

1

korganizer-4.14.10

CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.4)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/kde-base/korganizer-4.14.10/work/korganizer-4.14.10_build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/portage/kde-base/korganizer-4.14.10/work/korganizer-4.14.10_build/CMakeFiles/CMakeError.log".
 * ERROR: kde-base/korganizer-4.14.10::gentoo failed (configure phase):
 *   cmake failed
 * 
 * Call stack:
 *     ebuild.sh, line  133:  Called src_configure
cmake --version
cmake version 3.4.1

В чем может быть причина данной проблемы?

★★★★★

Это не определение версии cmake. Это даже не ошибка. Это просто ворнинг для девелоперов. Ошибка в чём-то другом.

devsdc ★★ ()
Ответ на: комментарий от devsdc

Это ошибка для portage, он не нашел почему-то нужной версии CMake, а вернее определил неправильно...

deterok ★★★★★ ()
Последнее исправление: deterok (всего исправлений: 1)
Ответ на: комментарий от deterok

Кто где что определил? Я в логе ничего подобного не вижу.

Полный лог давай.

devsdc ★★ ()
Ответ на: комментарий от devsdc

Я все дал, этого достаточно. Наверное проше багрепорт накатать, и самому зафиксить...

deterok ★★★★★ ()
Ответ на: комментарий от deterok

This warning is for project developers. Use -Wno-dev to suppress it.

Написано же прямым текстом: кто-то вначале CMakeLists.txt забыл добавить cmake_minimum_required(). Это может быть причиной ошибки, если твоя версия cmake старее той, для которой писали. Но CMake 3.4.1 — это свежая версия на данный момент. (Или ты подозреваешь, что у тебя в системе где-то запрятался CMake 2.8?)

devsdc +1

Смотри/показывай логи

See also "/var/tmp/portage/kde-base/korganizer-4.14.10/work/korganizer-4.14.10_build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/portage/kde-base/korganizer-4.14.10/work/korganizer-4.14.10_build/CMakeFiles/CMakeError.log".

KennyMinigun ★★★★★ ()
Последнее исправление: KennyMinigun (всего исправлений: 1)
Ответ на: комментарий от deterok

Если ты все дал, то и отвечать в этом треде лучше самому себе.

a1batross ★★★★★ ()
Ответ на: комментарий от KennyMinigun

Извините 2 сутки на на ногах,был уверен,что уж в нужных логах ошибиться не мог...

deterok ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.