LINUX.ORG.RU
ФорумGames

Terraria на ATI Radeon Xpress 1100 (не видит видеокарту) (ноутбук)

 , , , ,


0

2

Устанавливал по инструкции Тома Гейгера (http://tom-geiger.de/?p=163). Установка прошла успешно, пишу

westing@localhost ~/.w/d/P/Terraria> wine Terraria
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:module:GetModuleHandleExW should pin refcount for 0x79000000
fixme:mscoree:CreateConfigStream (L"C:\\windows\\Microsoft.NET\\Framework\\v4.0.30319\\config\\machine.config", 0x33f788): stub
fixme:mscoree:CreateConfigStream (L"C:\\Program Files\\Terraria\\Terraria.exe.config", 0x33f788): stub
fixme:sync:CreateMemoryResourceNotification (0) stub
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Game"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Configuration"
fixme:shell:URL_ParseUrl failed to parse L"System.Xml"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Graphics"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Xact"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Input.Touch"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"Accessibility"
fixme:advapi:RegisterTraceGuidsW (0xb1c65a, (nil), {8e9f5090-2d75-4d03-8a81-e5afbf85daf1}, 1, 0x33e21c, (null), (null), 0xfe6878,): stub
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 0x4 and card vendor 0000 (using GL_RENDERER "Gallium 0.4 on llvmpipe (LLVM 0x300)").
fixme:win:EnumDisplayDevicesW ((null),0,0x33cb58,0x00000000), stub!
fixme:d3d9:D3DPERF_SetOptions (0x2) : stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:gdiplus:GdipCreateHalftonePalette stub

перед последней строкой вылезает такое окно: скриншот
В маздае все работает.
Посоветуйте драйвера
ATI Radeon Xpress 1100 (чипсет RC410) (128M ram)
Ubuntu 12.04 Precise Pangolin (собирал из ubuntu-core, ядро пересобирал)
wine-1.4-0ubuntu4
Xorg 1.11.3
алсо 896 MB RAM и Intel Core Duo T2250 @1.73 Ghz
Asus F5R

Я меня есть ещё машина, только с видеокартой NVIDIA GT 220 - на нее ставится так же (кроме ошибки) и работает на ура.

Скриншот не посмотреть, но и так понятно что раз

"Gallium 0.4 on llvmpipe (LLVM 0x300)"
Значит дрова на видяху не стоят. Вперед в мануалы к своей убунте - как там правильно поставить xf86-video-radeon.

Алсо, не надо засорять русский язык всяким говном.

morse ★★★★★ ()

Поставь нормальные драйвера, fglx или как там ваш кактус называется.

ядро пересобирал

Нафейхоа, небыло в launchpad'е нужной версии? Надеюсь в deb свою сборку установил и завернул.

Ygor ★★★★★ ()
Ответ на: комментарий от psh

Можно установить ядро 2.6.28 и X-Server 1.5. Например, старый дистрибутив Linux.

Странно что не работает. Работают ли другие игры? Они работают быстро? Софтовый ли OpenGL, или аппаратно ускоряемый?

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Ford_Focus

надеюсь еще не поставил, ибо

NOTE: If you enter your card information on AMD/ATI's driver page, it will offer you the Catalyst 9-3 driver to download. However, the Catalyst 9-3 driver doesn't support X servers past 1.5, and it will not work with Precise (or anything later than Lucid/10,04)! !!!SO BE CAREFUL!!! If you tried to install Catalyst on a system with one of these cards, see the 'Removing the Driver' section to restore the default/pre-installed drivers.

так что видимо только открытый xserver-xorg-video-ati

Ford_Focus ★★★★★ ()
Ответ на: комментарий от Ygor

ну невидео тоже больше не поддерживает карты серии FX5xxx и ниже (а х1100 примерно из той же эпохи), так что спасения нет =)

Ford_Focus ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Там сейчас все совсем плохо. Всё что лучше опенарены, работает с жуткими тормозами или не работает вообще. Откатить иксы скорее всего не получится. После 8.10 драйвер убунтой не поддерживался. Для 9.04 в интернетах была куча мануалов по откату, для 9.10 тоже.Начиная с 10.04 халява кончилась, для нее ни одного рабочего мана не нашел.

psh ★★ ()

Исправленный скрин. Жалуется на видеокарту - XNA Framework говорит что не знает такую.

В консоли какая-то очень интересная строка висит, закрытая окошком. Полный лог не помешал бы.

Когда сам пробовал запустить под вайном (у меня лицензия в Steam), жаловался на .net framework, хотя я его ставил. Так что если запустится - сообщите.

Dukat863 ()
Ответ на: комментарий от Dukat863

Все, что в консоли, выложил в спойлер. .NET 4.0 ставил как обычно - с 1 раза Client-часть, со 2 раза Extended-часть, на 3 раз предложил восстановить/удалить. Также стоят mono28 и mono210 для Wine.

ALTracer ()
Ответ на: комментарий от Ford_Focus

на 12.04LTS 173ии дрова не встают. то ли временно, то ли похоронили, но на данный момент решения нет

Что значит решения нет? Дрова не компиляться что ли?

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

делал те же махинации на коробочной ubuntu 11.10 плюс поставил эти самые дрова 9.3 (они же 8.593). Пишу sudo sh ati-...(не помню) и через минуту выдает, что такой версии дистрибутива, как у меня, в драйвере нет. Результат - без ATIшного драйвера выползает та же самая ошибка (http://imageshack.us/photo/my-images/407/201205041417381280x800s.png)

ALTracer ()

Теперь эта же ошибка и у меня. Пошёл разбираться.

Мой драйвер:

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 8.0.2
OpenGL shading language version string: 1.20
Хорошо, что хоть запустилось.

Dukat863 ()
Ответ на: комментарий от Ygor

да, завернул при помощи make-kpkg. Версия ядра получилась 3.2.14-mykernel.

Что надо было ставить из launchpad'а? Ядро? Дело не в этом - коробочная 11.10 выдает ту же ошибку.

ALTracer ()

рендеринг

А как узнать, аппаратный рендеринг или программный? У меня вроде бы программный Gallium.
glxinfo:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
GLX version: 1.4
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.2
OpenGL shading language version string: 1.20

glxgears выдают около 180 FPS, предлагайте 3D игры для теста

ALTracer ()
Ответ на: комментарий от ALTracer

Что надо было ставить из launchpad'а? Ядро? Дело не в этом - коробочная 11.10 выдает ту же ошибку.

Это ati, и ничего с этим не поделаешь.

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

например

поставил на ноут вчистую Lubuntu12.04 (KDE тормозит на 512 Мб памяти), дрова nvidia-173 на FX5200 не стают (по зависимостям ругаясь на xorg-video-abi-10 Пакет недоступен), nvidia-current ставится, но разрешения больше 800*600 нет. Уменьшил шрифты с 11 до 9, вот так и живу пока

вообще гугель выдает довольно весомую пачку ссылок.

Ford_Focus ★★★★★ ()

Первый пост комом. Через 10 минут после создания тема умерла - это закон ЛОРа? Для себя уяснил, что тему надо писать максимально правильно и подробно и следить за ней первые десять минут. Ставил Debian Lenny и собирал для него из сырцов wine1.3 - были артефакты

ALTracer ()

Попробуй поставить режим Windows 7. У меня медленно наращивает память. Учитывая, что в венде так и происходит, это вроде нормально.

Dukat863 ()
Ответ на: комментарий от ALTracer

О, супер, могу поделиться deb-ами для Lenny! Я собрал в i386 последний Wine.

ZenitharChampion ★★★★★ ()

Ford_Focus, Ygor, для ветки драйверов NVIDIA 173.xx.xx есть бета-версия с поддержкой нового X-Server, насколько я знаю.

ZenitharChampion ★★★★★ ()
Ответ на: рендеринг от ALTracer

OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)

Это софтварный llvmpipe. У тебя видюха вообще не используется, все считается на процессоре.

Ставь свободный амдешный r300g.

Behem0th ★★★★★ ()

Драйверы конкретно под это видяху или протухшие, или их нет. Можешь не заморачиваться.

Quasar ★★★★★ ()
Ответ на: комментарий от Ygor

Что значит решения нет?

Это значит nVidia забили на 96 и 173 серии драйверов.

RussianNeuroMancer ★★★★★ ()

При загрузке LiveCD версии 12.04 с оригинальным ядром такая же проблема? (Имею ввиду программный рендеринг llvmpipe вместо аппаратного.) Вы точно уверены?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Смогу проверить не скоро... Короче, к железу пока доступа нет.

ALTracer ()
Ответ на: комментарий от Ygor

Поставь нормальные драйвера, fglx или как там ваш кактус называется.

ATI Radeon Xpress 1100 - уже давненько не поддерживаются AMD. К этой карточке есть только открытые дроа.

nihil ★★★★★ ()
Ответ на: комментарий от ALTracer

Как они называются?

radeon

(пруф)

???

Как их поставить?

В бубунте, очевидно, выбирается при установке системы.

3D ускорение поддерживается?

Да. Игрухи типа UT 2004 не тормозят.

nihil ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

При загрузке с Ubuntu 12.04 LiveCD glxinfo выдаёт

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
GLX version: 1.4
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RC410
OpenGL version string: 2.1 Mesa 8.0.2
OpenGL shading language version string: 1.20

а glxgears синхронизируется с частотй обновления экрана и рисует со скоростью ~60 FPS.

ALTracer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.