LINUX.ORG.RU

Bumblebee + Wine + Skyrim

 , ,


0

1
$ cat ~/Apps/link/TESV.desktop 
[Desktop Entry]
Name=The Elder Scrolls V - Skyrim
Exec=env WINEPREFIX="/home/archmage/.wine" wine /mnt/Aeroblink/DISK_D/Games/R.G.\ Catalyst/The\ Elder\ Scrolls\ V\ -\ Skyrim/TESV.exe
Type=Application
StartupNotify=true
Icon=DE0C_game.0

Если запускать

$ ~/Apps/link/Skyrim.desktop
То всё ок, за исключением того, что видеокарта используется интел, и иже. Но при запуске
$ optirun ~/Apps/link/Skyrim.desktop
получаю:
$ optirun ~/Apps/link/TESV.desktop 
/home/archmage/Apps/link/TESV.desktop: line 1: [Desktop: команда не найдена
/home/archmage/Apps/link/TESV.desktop: line 2: Elder: команда не найдена
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
Xlib:  extension "NV-GLX" missing on display ":0".
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "Mesa DRI Intel(R) Ivybridge Mobile ", version "1.4 (3.0 Mesa 9.1.2)").
Xlib:  extension "NV-GLX" missing on display ":0".
fixme:win:EnumDisplayDevicesW ((null),0,0x32f398,0x00000000), stub!
Xlib:  extension "NV-GLX" missing on display ":0".
fixme:win:EnumDisplayDevicesW ((null),0,0x32f3d8,0x00000000), stub!
Xlib:  extension "NV-GLX" missing on display ":0".
X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  1140
  Current serial number in output stream:  1141
Bumblebee ставил из реп MRC. Если что, optirun вроде рабочий — firefox запускается, glxspheres выдаёт порядка 127 FPS

Как исправить запуск Skyrim через optirun?

А ты попробуй запускать не Desktop файл, а вайн со скуримом.

NeverLoved ★★★★★ ()

Распространённая проблема. Даже на вики Bumblebee описана. Дело в том, что VirtualGL иногда «не поспевает» за запускаемой программой. Рекомендуется сначала сделать optirun sh, а затем уже запустить нужный софт. Primus таких граблей лишён ;)

https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting

carasin ★★★★★ ()
Последнее исправление: carasin (всего исправлений: 1)
Ответ на: комментарий от carasin
[archmage@WizardValley ~]$ optirun bash  
[archmage@WizardValley ~]$ ~/Apps/link/TESV.desktop 
/home/archmage/Apps/link/TESV.desktop: line 1: [Desktop: команда не найдена
/home/archmage/Apps/link/TESV.desktop: line 2: Elder: команда не найдена
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                                      
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.                                                                                  
fixme:heap:HeapSetInformation (nil) 1 (nil) 0                                                                                                                                                           
fixme:process:SetProcessDEPPolicy (1): stub                                                                                                                                                             
fixme:heap:HeapSetInformation (nil) 1 (nil) 0                                                                                                                                                           
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                                      
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                                      
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                                      
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                                      
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.                                                                                  
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.                                                                                  
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.                                                                                  
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded                                                                                    
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded                                                                                    
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded                                                                                    
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
Xlib:  extension "NV-GLX" missing on display ":0".
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "Mesa DRI Intel(R) Ivybridge Mobile ", version "1.4 (3.0 Mesa 9.1.2)").
Xlib:  extension "NV-GLX" missing on display ":0".
fixme:win:EnumDisplayDevicesW ((null),0,0x32f398,0x00000000), stub!
Xlib:  extension "NV-GLX" missing on display ":0".
fixme:win:EnumDisplayDevicesW ((null),0,0x32f3d8,0x00000000), stub!
Xlib:  extension "NV-GLX" missing on display ":0".
X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  1140
  Current serial number in output stream:  1141

Не помогает

GreenTea ★★ ()
$ ~/Apps/link/Skyrim.desktop
$ xdg-open ~/Apps/link/Skyrim.desktop
i-rinat ★★★★★ ()
Ответ на: комментарий от GreenTea

Единственное отличие — glxspheres показывает FPS в 2 раза ниже

vblank_mode=0 primusrun glxspheres

:)

KennyMinigun ★★★★★ ()
Ответ на: комментарий от GreenTea
/home/archmage/Apps/link/TESV.desktop: line 1: [Desktop: команда не найдена
/home/archmage/Apps/link/TESV.desktop: line 2: Elder: команда не найдена

Судя по всему этот ваш *.desktop файл bash пытается интерпретировать как скрипт. Инкрементирую пост господина i-rinat:

primusrun bash
primusrun xdg-open ~/Apps/link/Skyrim.desktop
KennyMinigun ★★★★★ ()
Ответ на: комментарий от carasin

а у меня в приложениях, запущенные через примус, мышка замедляется раза в 2 (как будто dpi сенсора уменьшается)

leave ★★★★★ ()

а почему не запускать «env BLABLA optirun wine /mnt/BLABLA»?

leave ★★★★★ ()

carasin

А 32-битные либы блоба стоят?

Специально проверил, 32-битный nezuiz через optirun работает

KennyMinigun

vblank_mode=0 primusrun glxspheres

Так FPS в 2,5 раз выше, но с ворнингами

primusrun xdg-open ~/Apps/link/Skyrim.desktop

У меня через оптимус текстовый редактор открылся. Как это мне поможет?

leave

а почему не запускать «env BLABLA optirun wine /mnt/BLABLA»?

Я не знаю, что такое env и зачем он.

GreenTea ★★ ()

Похоже на вайнопроблемы или проблемы самой вендовой игры. Сейчас поставлю NWN2 и проверю там.

GreenTea ★★ ()
Ответ на: комментарий от GreenTea

Так FPS в 2,5 раз выше, но с ворнингами

Ну так ворнинги о том что типа «vblank_mode was overriden by environment»? Если так - думаю, что ничего страшного :)

primusrun xdg-open ~/Apps/link/Skyrim.desktop

У меня через оптимус текстовый редактор открылся. Как это мне поможет?

Похоже, что наш *.desktop файл так и не открылся. На askubuntu есть тема про это.

Раз так - то проще запускать не через *.desktop, а как-то вот так:

export WINEPREFIX="/home/archmage/.wine"
export vblank_mode=0
primusrun wine "/mnt/Aeroblink/DISK_D/Games/R.G. Catalyst/The Elder Scrolls V - Skyrim/TESV.exe"

KennyMinigun ★★★★★ ()
Ответ на: комментарий от GreenTea

А Wine-то 32-битный стоит?

Хотя... Если без optirun'а робит, то, очевидно, стоит :D

carasin ★★★★★ ()
Ответ на: комментарий от GreenTea

я имел в виду вставить оптиран в эту строку:

Exec=env WINEPREFIX="/home/archmage/.wine" ВОТ_СЮДА wine /mnt/Aeroblink/DISK_D/Games/R.G.\ Catalyst/The\ Elder\ Scrolls\ V\ -\ Skyrim/TESV.exe

leave ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.