LINUX.ORG.RU

Не запускается Postal 2

 , ,


0

1

Ubuntu 16.04(было и в ранних версиях, но на какой-то вроде 14.* запускалась игра), при запуске ./postal2 выдает такую ошибку:

Postal 2
Copyright 2003 Running With Scissors, Inc.
Unreal Engine
Copyright 2001 Epic Games, Inc.
open /dev/[sound/]dsp: No such file or directory
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  156 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  47
  Current serial number in output stream:  48

Т.е. если раньше просто не было звука, то теперь игра не запускается вообще.
user@user-Lenovo-G565:~/Загрузки/postal2$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CEDAR (DRM 2.43.0 / 4.6-2.dmz.2-liquorix-amd64, LLVM 3.8.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 12.1.0-devel (git-154c0a4 2016-06-19 xenial-oibaf-ppa)
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 12.1.0-devel (git-154c0a4 2016-06-19 xenial-oibaf-ppa)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 12.1.0-devel (git-154c0a4 2016-06-19 xenial-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:


Какие выхлопы еще нужны?


libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing

Разберись с этим

RedEyedMan4 ★★★★★ ()

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' ./postal2

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler
user@user-Lenovo-G565:~/Загрузки/postal2$ LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' ./postal2
ERROR: ld.so: object '/usr/$LIB/libgcc_s.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgcc_s.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgcc_s.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgcc_s.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgpg-error.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
./postal2-bin: ./libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/i386-linux-gnu/libstdc++.so.6)
ozzee ()
Ответ на: комментарий от ozzee

Похоже на неустановленный 32-битный видеодрайвер.

Myau ★★★★ ()
Ответ на: комментарий от Myau

Какие пакеты надо поставить?

Я из репозитория oibaf ставил драйверы

ozzee ()
Ответ на: комментарий от xDShot

Спешите видеть! Варез-помойки теперь и на линуксе!

Myau ★★★★ ()
Ответ на: комментарий от ozzee

Гугл подсказывает, что libgl1-mesa-dri:i386.

А вообще лучше у местных амдшников спросить.

Myau ★★★★ ()

Амд без блоба плохо играет. А вообще игра старая и лучше через вайн. Стимовская с английской озвучкой, груздевская доставляет больше.

Deleted ()
Ответ на: комментарий от ozzee

Это надо писать в свойствах игры в стиме. Как будто первый раз.

Aceler ★★★★★ ()

Не запускается Postal 2

И слава Богу! Зачем тебе симулятор морального урода? Ты выше этого.

anonymous ()

Рекомендую запускать win-версию через wine.

alexferman ()

Загрузки/postal2

Берешь и запускаешь со стима. Там все с первого раза запускается.

a1batross ★★★★★ ()

Загрузки

я не понял, ты софтину запускаешь из директории с кирилическим именем?? Исключи это.

targitaj ★★★★★ ()
Ответ на: комментарий от targitaj

Ты прав, большинство быдло-игр не умеют в utf-8, даже в 2016м это так.

anonymous ()

Ну не знаю, раз говоришь, что дрова в порядке. Из стима норм запускается

sehellion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.