LINUX.ORG.RU

Помогите собрать рпмку Самбы 3.0 для RH9


0

0

Выпадает ошибка
Compiling dynconfig.c
cc1: unrecognized option `-fPIE'
make: *** [dynconfig.o] Error 1

а если пытаюсь установить ими скомпилиную самбу выпадает следующее

rpm -Uvh samba-3.0.0-15.i386.rpm
error: Failed dependencies:
libacl.so.1(ACL_1.0) is needed by samba-3.0.0-15
libattr.so.1(ATTR_1.0) is needed by samba-3.0.0-15

хотя эти библиотеки есть в чем затыки?

anonymous

Re: Помогите собрать рпмку Самбы 3.0 для RH9

А что мешает взять src.rpm из rawhide?

McMCC ★★★ ()

Re: Помогите собрать рпмку Самбы 3.0 для RH9

> libacl.so.1(ACL_1.0) is needed by samba-3.0.0-15

Может, они где-нить не там есть?

/etc/ld.so.conf содержит путь?

С уважением -- Смоляное Чучелко

anonymous ()

Re: Помогите собрать рпмку Самбы 3.0 для RH9

Я тоже с таким столкнулся -- дело в том, что ее нужно собирать gcc 3.3 из того же rawhide. Там появилась новая опция -pie, и они пропатчили самбу. Можно, конечно, этот патч убрать и собирать 3.2.

Для этого нужно
rpm -i samba-3.0*-15.src.rpm
cd /usr/src/redhat/SPECS

Убрать из файла samba.spec все строчки с pie и 
rpmbuild -ba samba.spec

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.