LINUX.ORG.RU
ФорумAdmin

Обновление Sendmail


0

0

Hi all Такая проблема, хочу обновить Sendmail из rpm-ов, таков результат:

rpm -Uvh sendmail-8.13.4-2asp.i386.rpm error: Failed dependencies: libc.so.6(GLIBC_2.3.4) is needed by sendmail-8.13.4-2asp libcrypto.so.5 is needed by sendmail-8.13.4-2asp libdb-4.3.so is needed by sendmail-8.13.4-2asp liblber-2.2.so.7 is needed by sendmail-8.13.4-2asp libldap-2.2.so.7 is needed by sendmail-8.13.4-2asp libssl.so.5 is needed by sendmail-8.13.4-2asp setup >= 2.5.31-1 is needed by sendmail-8.13.4-2asp

Так понял ему нехватает glibc и setup, обновляю glibc, выдает:

rpm -Uvh glibc-2.3.5-10.3asp.i386.rpm glibc-common-2.3.5-10.3asp.i386.rpm glibc-devel-2.3.5-10.3asp.i386.rpm glibc-headers-2.3.5-10.3asp.i386.rpm glibc-kernheaders-2.4-9.1.94asp.i386.rpm

error: Failed dependencies: shadow-utils < 2:4.0.3-20 conflicts with glibc-2.3.5-10.3asp nscd < 2.3.3-52 conflicts with glibc-2.3.5-10.3asp binutils < 2.15.94.0.2-1 conflicts with glibc-devel-2.3.5-10.3asp libc.so.6(GLIBC_PRIVATE) is needed by (installed) nscd-2.3.2-101.4asp

Получается очень много зависимостей, обновлять setup не рискую, посоветуйте как решить проблему? Спасибо

anonymous

Ответ на: Re: Обновление Sendmail от Ej_Pulsar

Re: Обновление Sendmail

ку Linux version 2.4.22-1.2154.nptl.asp gcc version 3.3.2 20031022 (ASPLinux 3.3.2-1))

anonymous ()

Re: Обновление Sendmail

Не бери rpm из другой ветки (версии) дистрибутива.
Если под твой дистрибутив нет нужной версии пакета, придется собирать самому.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.