LINUX.ORG.RU

Хочется странного

 , ,


0

1

Доброго времени суток, камраден.

Третьего дня решил «по книжке» создать учебный проект. Но в созданном виртуальном окружении не получается поставить свежайший Джанго. Что интересно, без venv ставится влёт. pip install Django==2.2.6 DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support ERROR: Could not find a version that satisfies the requirement Django==2.2.6 (from versions: 1.1.3, 1.1.4, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 1.4.15, 1.4.16, 1.4.17, 1.4.18, 1.4.19, 1.4.20, 1.4.21, 1.4.22, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11, 1.5.12, 1.6, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.6.10, 1.6.11, 1.7, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9, 1.7.10, 1.7.11, 1.8a1, 1.8b1, 1.8b2, 1.8rc1, 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.8, 1.8.9, 1.8.10, 1.8.11, 1.8.12, 1.8.13, 1.8.14, 1.8.15, 1.8.16, 1.8.17, 1.8.18, 1.8.19, 1.9a1, 1.9b1, 1.9rc1, 1.9rc2, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.9.8, 1.9.9, 1.9.10, 1.9.11, 1.9.12, 1.9.13, 1.10a1, 1.10b1, 1.10rc1, 1.10, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.10.7, 1.10.8, 1.11a1, 1.11b1, 1.11rc1, 1.11, 1.11.1, 1.11.2, 1.11.3, 1.11.4, 1.11.5, 1.11.6, 1.11.7, 1.11.8, 1.11.9, 1.11.10, 1.11.11, 1.11.12, 1.11.13, 1.11.14, 1.11.15, 1.11.16, 1.11.17, 1.11.18, 1.11.20, 1.11.21, 1.11.22, 1.11.23, 1.11.24, 1.11.25)

Может кто-то подсказать, чего не так? Проблема не критичная, проект - учебный, и без виртуального окружения работает. Но всё же интересно, чегой ему не нравится?

ЗЫ. И как в проекту по умолчанию запускать питон3?

Ты venv от второго питона создаешь, а не от третьего. Что-то вроде такого тебе нужно, наверное (не работаю с venv):

pyvenv-3.5 project/

Второй питон не поддерживает вторую версию джанги

HerrWeigel ★★★★ ()
Последнее исправление: HerrWeigel (всего исправлений: 1)

с 2й джанги перестали поддерживать 2й питон. Используй 3.5+

ggrn ★★★★★ ()

Спасибо всем за помощь! Вся оказалось страннее и чудесатее, чем предполагалось: просто пакеты python3-pip и python-pip - это разные пакеты, а pip устанавливает джангу из 1-й ветки, в то время как pip3 устанавливает уже из второй ))

шёл 2019 год, а linux всё ещё не был готов к десктопу ((

zad1ra ()
Ответ на: комментарий от zad1ra

е@# ты тормоз, казалось бы причем тут линукс. эти джанго-разработчики даже не могут понять смысла строки из пяти слов, трудно поверить что и я когда-то был таким.

trashymichael ★★★ ()
Ответ на: комментарий от zad1ra

Потерпи еще 2 месяца, 2й питон отправят на помойку,а для особо одарённых как ты сделали pip и pip3.

а pip устанавливает джангу из 1-й ветки, в то время как pip3 устанавливает уже из второй ))

А почитать https://docs.djangoproject.com/en/2.2/releases/2.0/

Django 2.0 supports Python 3.4, 3.5, 3.6, and 3.7. We highly recommend and only officially support the latest release of each series.

The Django 1.11.x series is the last to support Python 2.7.

Django 2.0 will be the last release series to support Python 3.4. If you plan a deployment of Python 3.4 beyond the end-of-life for Django 2.0 (April 2019), stick with Django 1.11 LTS (supported until April 2020) instead. Note, however, that the end-of-life for Python 3.4 is March 2019.

тебе было наверное сложно.

Так вот причем тут линукс, если ты читать не умеешь?

ggrn ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.