LINUX.ORG.RU

Radeon HD 5145+Linux Mint 14+AMD 13.1 Proprietary Driver=?

 , , ,


0

1

Собственно уже бьюсь не один месяц над проблемой установки проприетарного драйвера AMD, видеокарта ноутбучная Radeon HD Mobility 5145, Linux Mint 14. На 13й версии Mint, устанавливал через стандартный установщик драйверов, было вроде нормально. Сейчас это убрали, в software source вот такая беда: https://www.dropbox.com/s/e3ls84si6uty6t6/lor_1.png

Устанавливал через репы:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy
Криво.

Устанавливал по инструкциям: http://help.ubuntu.ru/wiki/%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%B0_ati

http://www.money-vsem.com/2011/11/14/ustanovka/

с официального сайта та же беда

Генерировал:

sudo sh ./amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run --buildpkg Ubuntu/quantal
Результат:
dpkg-buildpackage: error: debian/rules binary gave error exit status 2

Пробовал и Catalyst 10, (ну мало-ли видеокарта не поддерживает новые драйвера) - та же фигня.

★★★★★

Сейчас драйвера обновились. Попробуйте со свежими.

Вы гениально расшарили изображения. (В том смысле, что вы этого не сделали.)

whiskydotjar ()

ведромодуль требует g++ и заголовки ведраю

ckotinko ☆☆☆ ()
Ответ на: комментарий от Amet13

Смотрю на скрин ваш. Ну и что, что тут написано «не используется». Вы как-то ещё работоспособность драйверов проверяли? При установке возникают какие-либо ошибки? Перед повторной установкой полностью удаляли предыдущие драйвера?

whiskydotjar ()
Ответ на: комментарий от whiskydotjar

если через

--buldpkg Ubuntu/quantal
- пакеты не генерируются если просто запускать скрипт
sudo sh ./amd...
запускаю, устанавливаю, в конце пишет ошибку, --aticonfig или --amdconfig тоже не работают, перезапускаю, отображается все размазано, в «system information» в графе драйвера пусто, я думаю что это из-за того что --aticonfig не инициализировался, а он в свою очередь не инициализировался из-за ошибки при установке

Amet13 ★★★★★ ()
Ответ на: комментарий от Amet13

Удалите вообще все драйвера, если таковые остались в системе. Но я не вижу вашей карточки здесь http://support.amd.com/us/kbarticles/Pages/AMDCatalyst131ProprietaryLinuxGrap...

Может вам legacy драйвера (AMD Catalyst™ 12.6 Proprietary Linux x86 Display Driver) попробовать:
http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux....

Вот, заявлена поддержка AMD Radeon HD 4000 Series

whiskydotjar ()
Ответ на: комментарий от whiskydotjar

Удалите вообще все драйвера, если таковые остались в системе. Но я не вижу вашей карточки здесь http://support.amd.com/us/kbarticles/Pages/AMDCatalyst131ProprietaryLinuxGrap...

Да, у меня из семейства 4500.

Может вам legacy драйвера (AMD Catalyst™ 12.6 Proprietary Linux x86 Display Driver) попробовать:
http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux....

Пробовал, разными способами, не получалось. Может дадите верный способ установки, если есть опыт?

Amet13 ★★★★★ ()
Ответ на: комментарий от Amet13

В смысле разными способами? Способ один: ставите зависимости, запускаете скрипт установки. Всё.

Подробнее:

sudo sh /usr/share/ati/fglrx-uninstall.sh

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

Скачиваете: http://www2.ati.com/drivers/legacy/12-6/amd-driver-installer-12.6-legacy-x86....

chmod +x amd-driver-installer-12.6-legacy-x86.x86_64.run

sudo sh amd-driver-installer-12.6-legacy-x86.x86_64.run

Далее следуете инструкциям установщика.

sudo aticonfig --initial -f

sudo reboot

whiskydotjar ()
Ответ на: комментарий от whiskydotjar

запустил скрипт, нажал ок, написано драйвер установлен, затем - ошибки https://www.dropbox.com/s/3h18l3emc5yltgq/error.png

Лог fglrx-install.log:

Check if system has the tools required for installation.
fglrx installation requires that the system have kernel >headers. /lib/modules/3.7.0-7-generic/build/include/linux/version.h cannot be found on this system.
fglrx installation is being forced. Installation will proceed without the required tools on the system.
Uninstalling any previously installed drivers.

Creating symlink /var/lib/dkms/fglrx/8.97.100.3/source ->
/usr/src/fglrx-8.97.100.3

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
cd /var/lib/dkms/fglrx/8.97.100.3/build; sh make.sh --nohints --uname_r=3.7.0-7-generic --norootcheck....(bad exit status: 1)
[Error] Kernel Module : Failed to build fglrx-8.97.100.3 with DKMS
[Error] Kernel Module : Removing fglrx-8.97.100.3 from DKMS

------------------------------
Deleting module version: 8.97.100.3
completely from the DKMS tree.
------------------------------
Done.
[Reboot] Kernel Module : update-initramfs

затем делаю

sudo aticonfig --initial -f

Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-0

сейчас перезагружу

Amet13 ★★★★★ ()

RussianNeuroMancer ты зачем удалили из wiki вот этот кусочек?

-	<note important>	 
-	** Catalyst 12.11 beta вплоть до версии beta 8 для 32 битных систем не сгенирирует deb пакеты так как имеют ошибку с путями до библиотек Qt в rules файле.**

Проверил генерацию пакетов на 32 битных системах? Собирается пакеты?

bhfq ★★★★★ ()
Ответ на: комментарий от Amet13

Куда ты перезагружаешься! Иксы скорее всего не заведутся! (Если ты все драйверы потёр.) Установи какие-нибудь драйвера, — тогда перезагружайся.

whiskydotjar ()
Ответ на: комментарий от Amet13

fglrx installation requires that the system have kernel >headers. /lib/modules/3.7.0-7-generic/build/include/linux/version.h cannot be found on this system.

Так установи build-essentials пакет и заголовки ядра linux-headers-generic

Хотя откуда в quantal ядро 3.7?

bhfq ★★★★★ ()
Ответ на: комментарий от Amet13

fglrx installation requires that the system have kernel >headers. /lib/modules/3.7.0-7-generic/build/include/linux/version.h cannot be found on this system

Установка требует зависимости.
Заголовки твоего ядра.

kernel headers

Это нужно, чтобы собрать модуль для твоего ядра.

whiskydotjar ()
Ответ на: комментарий от whiskydotjar

перезагрузился, все запустилось без проблем глючило немного центр управления включил компиз, глючить перестало

Amet13 ★★★★★ ()

в system information, разделе display

vendor unknown
renderer unknown
version unknown
opengl no

драйвер установился криво, либо вообще не установился например, пробовал запустить supertuxkart

Irrlicht Engine version 1.7.3
Linux 3.7.0-7-generic #15-Ubuntu SMP Sat Dec 15 16:34:21 UTC 2012 i686
[FileManager] Data files will be fetched from: >'/usr/share/games/supertuxkart'
[FileManager] Addons files will be stored in >'/home/amet13/.local/share/supertuxkart/addons'.
[translate] Env var LANGUAGE = 'ru_UA.UTF-8'
[translate] Env var LANGUAGE = 'ru_UA.UTF-8', which corresponds to 'Russian'
[IrrDriver] Trying OpenGL rendering.
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66 ()
Serial number of failed request: 25
Current serial number in output stream: 25

Amet13 ★★★★★ ()
Ответ на: комментарий от whiskydotjar
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic xserver-xorg-core libgcc1

Уже установлена самая новая версия build-essential.
Уже установлена самая новая версия cdbs.
Уже установлена самая новая версия debconf.
Уже установлена самая новая версия debhelper.
Уже установлена самая новая версия dh-make.
Уже установлена самая новая версия dkms.
Уже установлена самая новая версия execstack.
Уже установлена самая новая версия fakeroot.
Уже установлена самая новая версия libelfg0.
Уже установлена самая новая версия libgcc1.
Уже установлена самая новая версия libqtgui4.
Уже установлена самая новая версия libstdc++6.
Уже установлена самая новая версия wget.
Уже установлена самая новая версия dh-modaliases.
Уже установлена самая новая версия linux-headers-generic.
Уже установлена самая новая версия xserver-xorg-core.
обновлено 0, установлено 0 новых пакетов, для удаления >отмечено 0 пакетов, и 3 пакетов не обновлено.

Amet13 ★★★★★ ()
Ответ на: комментарий от whiskydotjar
sudo apt-get install linux-headers-3.7.0-7-generic

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлена самая новая версия linux-headers-3.7.0-7-generic.
linux-headers-3.7.0-7-generic установлен вручную.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.

Amet13 ★★★★★ ()
Ответ на: комментарий от whiskydotjar

та ладно уже, спасибо за помощь надоело, уже раз седьмой бьюся над одним и тем же, обойдусь без стима, так даже лучше будет

Amet13 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.