LINUX.ORG.RU
ФорумTalks

Драйвера для HD radeon


0

1

Вообщем есть тут бук у меня. На нем 2 видеокарточки:

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 9647
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]

Пытался поставить проприетарные драйвера! Первый раз имею дела с ATI в линукс. Я канечно слышал, что «ATI Radeon славятся «на весь мир» своей сыростью и проблемностью в установке».

Практически сразу после установки драйвера (ставил сразу из репозитария, и ставил в ручную), при перезагрузки вылетало «the system is running in low-graphics mode», а то и лучше, вообще ничего не было, только темный экран! Все то дело делалось на ядре 3.5 в ubuntu 12.04 и fedora 17.

Но ведь способ поставить то их нашелся!

Психанул, снес все нафиг - поставил ubuntu 12.04 стандартную сборку с ядром 3.2. Установил, не обновляясь полез в гугель искать, хоть какую нибудь инфу как поставить эти дрова!

В итоге сделал так:

1. Подключить дополнительный репозиторий Ubuntu-X:

# echo "deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu `lsb_release -cs` main" | sudo tee -a /etc/apt/sources.list
# echo "deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu `lsb_release -cs` main" | sudo tee -a /etc/apt/sources.list

2. Добавить ключ репозитория и обновить список доступных пакетов:

# sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com AF1CDFA9 && sudo apt-get update

3. Устанавливаем драйвер какой вам нужен:

  • на чипе ниже r2**/r3** включительно:
     # sudo apt-get install xserver-xorg-video-ati
  • на чипе выше r2**/r3**:
    # sudo apt-get install xserver-xorg-video-radeonhd
  • универсальный драйвер:
     # sudo apt-get install xorg-driver-fglrx

Это все нашлось здесь.

Далее сделал следующие:

sudo apt-get update && sudo apt-get install fglrx

P.S.

У каждого устройства есть идентификатор производителя (Vendor ID) и идентификатор устройства (Device ID). У ATI/AMD - идентификатор 1002. Если выполните на своём компьютере lspci -nn|grep -i 1002, то должны обнаружить свою ATI видеокарту.

Например, 01:05.0 VGA compatible controller [0300]: ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712]

Найдя на данной странице код 9712 - можно сделать вывод - какой пакет нужно установить, чтобы установить проприетарный драйвер от ATI с аппаратной поддержкой 3D.

Список пакетов и более подробно росписано тут.

★★★★★

В Ubuntu в опциях системы есть пункт «Драйверы устройств». Запускаешь и система сама предложит установить нужный драйвер из репозитория.

Если же хочешь установить самый последний драйвер,то:

1.Заходишь на сайт http://www.amd.com

2. Находишь нужный драйвер и скачиваешь

3. Запускаешь скаченный файл и устанавливаешь

Готово!

Я всегда устанавливал драйверы таким образом.

Jonson___ ()
Ответ на: комментарий от Jonson___

Дада, я так делал в итоге «the system is running in low-graphics mode».

Даже не знаю, чего так(

Licwin ★★★★★ ()

the system is running in low-graphics mode

Выбрось бяку и поставь вменяемое ДЕ.

devl547 ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

То ли я невезучий, толи руки у меня кривые))

Licwin ★★★★★ ()

Ты разделом ошибся. Да и видеокартами тоже - это не ATI.

xserver-xorg-video-ati

Это враппер для драйверов, а не самостоятельный драйвер. Он определяет, что у тебя за видеокарта, и подгружает один из свободных драйверов.

Психанул, снес все нафиг - поставил ubuntu 12.04 стандартную сборку с ядром 3.2. Установил, не обновляясь полез в гугель искать, хоть какую нибудь инфу как поставить эти дрова!

Я сделал намного проще - поставил Debian, подключил репозиторий non-free (в Synaptic одну галочку достаточно для этого поставить да список пакетов обновить) и apt-get install fglrx.

Quasar ★★★★★ ()

В F17 темный экран был только потому, что надо было в /etc/default/grub добавить «radeon.modeset=0» и сделать grub2-mkconfig, все бы отлично заработало.

ArtKun ★★★★★ ()
Ответ на: комментарий от Jonson___

3. Запускаешь скаченный файл и устанавливаешь

Я всегда устанавливал драйверы таким образом.

не надо всякую херню советовать. Если уж решил ставить через инсталлятор, то хотя бы пакет для дистрибутива собери

JB ★★★★★ ()
Ответ на: комментарий от OldWiseCat

Я пробовал несколько раз разные версии драйверов от AMD. Инсталлятор ни разу не смог сгенерировать пакет. Средства разработки и сборки пакетов DEB ставил. Эта же ошибка проявлялась много у кого. В итоге всем давали совет ставить драйвер из репозитория, на чём дело и останавливалось.

Quasar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.