LINUX.ORG.RU

Нужна переключалка клавиатуры для XFCE4

 


0

2

Сабж.

Стандартная xfce4-xkb-plugin 0.5.4.3 заколебала, ибо забывает свои настройки при закрытии крышки ноутбука, при работе с bluetooth-девайсами через blueman и других абсолютно бессвязных событиях.

ps: Попытки набега на багзиллу xfce прогресса не дали, переключалку никто не поддерживает. Выяснилось лишь, что проблема не только у меня одного.

Основные требования:

- запоминание раскладки между окнами

- иконка в трее или на панели

- переключение по CapsLock.

★★★★★

Тоже раньше мучился с постоянным забыванием настроек этим апплетом. Потом вылечилось само собой, уже давно не проявляется.

Можно попробовать xxkb. Пользовался ей, подобных глюков не было

bloodredfrog ★★ ()

1. Настройки -> Менеджер параметров -> Клавиатура -> Раскладка
Поставить галочку «Использовать системные параметры»

2. Настройки -> Системные параметры -> Автостарт программ -> Добавить
setxkbmap -layout us,ru -variant -option grp:caps_toggle

Если две раскладки то видимо будет то что нужно.
Если раскладок больше, то придется их постоянно переключать пока до нужной доберешься. Что, я думаю, не очень удобно.

Подойдет?

user0xff ()

Так перейди на глобальный уровень а не DE.
Вообще УМВР. Единственное что жалко размер шрифта из гуя менять в иконке в трее.

VictimOfLoveToLinux ()

Стандартная xfce4-xkb-plugin 0.5.4.3 заколебала, ибо забывает свои настройки при закрытии крышки ноутбука, при работе с bluetooth-девайсами через blueman и других абсолютно бессвязных событиях.

Э, да я не один такой!

AITap ★★★★★ ()

Всем спасибо за подборку. Сегодня вечером и завтра начну обрабатывать предложенные вариации.

Пока установил xxkb, но что-то у неё проблемы с user-friendly. Надо маны читать, чтоб понять как она работает.

shahid ★★★★★ ()
Ответ на: комментарий от ipwww

Не прокатит - «запоминание раскладки между окнами»

sergv ()
Ответ на: комментарий от ipwww

настрой переключение раскладок не в ДЕ, а в системе

Чтоб между окнами раскладка запоминалась, как сделать? Судя по всему, для этого нужно xxkb курить.

shahid ★★★★★ ()
Ответ на: комментарий от user0xff

1. Настройки -> Менеджер параметров -> Клавиатура -> Раскладка

Поставить галочку «Использовать системные параметры»

Нет такого.

2. Настройки -> Системные параметры -> Автостарт программ -> Добавить

Настройки > Сеансы и запуск -> Автозапуск приложений -> Добавить.

Короче, сделал. Добавил туда ещё вызов xxkb&. По идее должно работать ок.

shahid ★★★★★ ()

Короче, напишу step-by-step для других и чтоб самому не забыть.

0. Установить пакет xxkb.
pacman -S xxkb

1. Скопипастить конфиг отсюда в ~/.xxkbrc . Можно ничего не менять.

2. XFCE: Настройки > Сеансы и запуск -> Автозапуск приложений

2.1 Нажать кнопку Добавить. Придумать название, описание и указать команду xxkb &

2.2 Далее либо создать/отредактировать /etc/X11/xorg.conf.d/50-xkb.conf:

Section "InputDevice"
    Option "XkbLayout"  "us, ru"
    Option "XkbOptions" "grp:switch,grp:caps_toggle,grp_led:scroll"
EndSection

Либо снова нажать Добавить в окне Сеансы и запуск и указать в качестве команды
setxkbmap -layout us,ru -variant -option grp:caps_toggle

shahid ★★★★★ ()
Ответ на: комментарий от shahid

Так переключает голобально. Как сделать чтобы пооконно?

anonymous ()
Ответ на: комментарий от VictimOfLoveToLinux

Единственное что жалко размер шрифта из гуя менять в иконке в трее.

В 0.5.4.3 можно выбирать размер. В сообщении http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=576072#49 есть патч, добавляющий возможность выбора произвольного шрифта (в том числе и размера).

i-rinat ★★★★★ ()
Ответ на: комментарий от shahid

xxkb

У этой штуки проблемы с окнами LibreOffice, рекомендую более живой kbdd вместо.

GotF ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.