LINUX.ORG.RU

FC8 - не видит libcrypto.so.6 и libssl.so.6 для transmission


0

0

Всем здравствуйте и с Новым Годом :)

Пытаюсь обновить kdebase через yum до тестируемого (fc9). После автоматической загрузки всей необходимой коллекции пакетов зависимостей (154 пакета на 300+ метров) получаю:

Error: Missing Dependency: libssl.so.6 is needed by package transmission
Error: Missing Dependency: libcrypto.so.6 is needed by package transmission

В /lib у меня лежат libcrypto.so.0.9.8b и libssl.so.0.9.8b, а также симлинки на них libcrypto.so.6 и libssl.so.6 соответственно.
Пробовал установить заново openssl и transmission с диска Федоры.
rpm -ihv --oldpackage --replacefiles --replacepkgs /mnt/iso/Packages/openssl-0.9.8b-17.fc8.i386.rpm
rpm -ihv --oldpackage --replacefiles --replacepkgs /mnt/iso/Packages/transmission-0.82-1.fc8.i386.rpm
Не помогло.

yum update openssl
и
yum update transmission
дают ту же ошибку.

Плюнул, залез на официальный фтпшник, скачал оттуда transmission-debuginfo-0.95-1.fc9.i386.rpm и установил его в графическом режиме. Всё корректно прошло, даже никаких зависимостей не разрешалось. Результат yum update kdebase - тот же. Последнее я в упор не понимаю - если я уже установил последнюю версию transmission, значит, при построении зависимостей kdebase его (transmission) по идее обновлять не потребуется? Так откуда же ошибка?

Буду рад, если какая-нибудь добрая душа подскажет мне, в каком направлении копать...

Re: FC8 - не видит libcrypto.so.6 и libssl.so.6 для transmission

Вовремя.

anonymous ()

Re: FC8 - не видит libcrypto.so.6 и libssl.so.6 для transmission

>Предвижу флейм rpm vs deb...

А чего его предвидеть? И так всем понятно, что Федора/rpm - в топку! Бубунта/deb - наше всё!

ЗЫ: Сам использую Arch :)

anonymous ()

Re: FC8 - не видит libcrypto.so.6 и libssl.so.6 для transmission

Это, конечно, превосходно... а по делу неужели никто ничего не может посоветовать? :)

Skiminok ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.