LINUX.ORG.RU

Проблемы с USE'ами

 , ,


0

1

Привет, ЛОР! Поставил я gentoo, решил настроить сеть и поставить networkmanager, а он ни в какую не хочет ставится. Все нужные USE’ы прописал - безрезультатно. –autounmask-write - тоже самое. Новости читаю регулярно при входе в систему. В этот раз правда ставил из чрута убунты, но это мне кажется ничего не меняет.

Скриншотики:

https://imgur.com/pOe8Ghv

https://imgur.com/LEvgQKc

Ответ на: комментарий от eternal_sorrow

Там написано, что wpa_supplicant требует openssl версии не меньше 1.0.2k и с флагом bindist

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Dumppper001

package.use может быть как файлом, так и каталогом. Если у тебя каталог, просто создай внутри файл с именем openssl и пропиши туда use-флаг bindist.

otto ★★ ()
Последнее исправление: otto (всего исправлений: 1)

Убери bindist флаг из системы. Он тебе не нужен глобально. Ты же не занимаешься распространением с сборок пакетов третьим лицам.

grem ★★★★★ ()
Ответ на: комментарий от Dumppper001

Тогда дам такой совет: читай внимательно выхлоп портажа. Если что-то пошло не так, то выдаваемой информации обычно хватает чтобы нагуглить на родной вики решение проблемы.

otto ★★ ()
Ответ на: комментарий от Dumppper001

Просто надо было открыть хэндбук, на этой странице, на этом пункте, и почитать его. Там все описано:

If package.use is pre-existing as a directory (opposed to a single file), packages can have their USE flags modified by simply creating files under the package.use/ directory. […] For example, setting the bluray USE flag for the media-video/vlc package can be performed as follows: root #echo "media-video/vlc bluray" >> /etc/portage/package.use/vlc

Там же и для package.use, который текстовый файл, выше написано

snake266 ★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей