LINUX.ORG.RU

Разное масштабирование (dpi) в KDE

 , ,


0

2

Использую 2 монитора, один с разрешением 4К (3840х2160), а второй 1920х1080. Для основного я смог все настроить что бы не сьезжало (вроде бы) и было не мелко, поставил в xorg.conf dpi 192. Но дело в том что в конфигах у меня записано не 2 монитора, а они записаны как один монитор с разрешением 5760*2160. Соответсвенно, то что нормально выглядит на основном, слишком крупно на втором и наоборот. Версия kde plasma: 5.17.5 Проприетарный драйвер нвидиа: 440.82 Можно ли настроить для разных моников разный dpi, чтобы все выглядело адекватно на обоих?

Во первых, если лезешь в иксовые настройки, то надо понимать что делаешь. А во вторых для этых целей в КДЕ есть отдельное масштабирование для каждого монитора. На каком дистре сидишь?

ChekPuk ★★ ()
Последнее исправление: ChekPuk (всего исправлений: 1)
Ответ на: комментарий от ChekPuk

Ползунок масштабирования в настройках кде все равно применяется к обоим мониторам и как сделать его отдельным для каждого монитора я не нашел, иначе бы не задавал вопрос. Еще без лазания в конфиг иксов далеко не все работало корректно. Дистр: calculate linux

wellWINeo ()
Ответ на: комментарий от wellWINeo

Извини, перепутал. Странно, куда делась галочка раздельной настройки? У меня сейчас нет второго монитора, не могу проверить, но, точно помню что была галочка разного масштаба. Может в шрифтах при двух мониторах? Забыл.

ChekPuk ★★ ()

настрой масштабирование через апскейл на видюхе. я так настроил себе 4к и qhd. главное чтобы матрица на меньшем монике была не совсем говном

    Option         "metamodes" "DP-0: 2560x1440_60 +3840+0 {rotation=left, viewportin=2160x3840, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-2: 3840x2160_60 +0+310 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

Suicide_inc ★★ ()

В самом KDE никак.

У меня на ноутбуке разрешение 2560x1440 и DPI 144.

На мониторе 1920x1080. Все слишком крупно.

При подключении монитора запускаю:

xrandr --output HDMI1 --mode 1920x1080 --scale 1.4x1.4

В вашем случае нужно изменить опцию --scale на удобную для вас.

mamantoha ()
Последнее исправление: mamantoha (всего исправлений: 1)
Ответ на: комментарий от mamantoha

Получается такая ситуация, что половина основного монитора дублируется на половине второго. Такое же происходит если пытаться подправить конфиг иксов, как несколькими комментариями выше советовал человек

wellWINeo ()