LINUX.ORG.RU

Подскажите по Alt Linux

 ,


0

1

Добрый день.

Поставил себе Alt Linux P8 с рабочим столом Mate. Некоторые вещи мне пока до конца не понятны:

1. У меня не работает команда apt-get build-dep <пакет>. Нужно добавить какие-то дополнительные репозитории?

2. Насколько интенсивно будут приходить обновления с репозиториями p8 classic? Скажем, стоит ли ждать обновлений Firefox и прилетит ли вышедший недавно Thunderbird 68?

3. Подключил Сизиф. Некоторые программы оттуда ставятся, другие - нет, т.к. предлагают удалить пол системы. Например, в Сизифе есть пакет Blobby, но мне его не поставить.

4. Какой вообще правильный способ ставить программы, которых нет в стандартном репозитории? У Альта есть какая-то древняя и бестолковая вики, в которой нужной информации не найдёшь...

★★★★

4. Какой вообще правильный способ ставить программы, которых нет в стандартном репозитории? У Альта есть какая-то древняя и бестолковая вики, в которой нужной информации не найдёшь...

flatpak, snap, appimage

Vsevolod-linuxoid ★★★★★ ()

У меня не работает команда apt-get build-dep <пакет>. Нужно добавить какие-то дополнительные репозитории?

А выхлоп-то какой?

kekelia ()
Ответ на: комментарий от kekelia

Чтение списков пакетов... Завершено

Построение дерева зависимостей... Завершено

E: В sources.list должны быть указаны адреса репозиториев.

kknight ★★★★ ()

Сизиф не подключай, если не имеешь намерения все себе сломать :)

Для build-dep надо подключить deb-src. Ахтыжблин.. там же apt-rpm.. сходи на вики ихнюю..

aol ★★★★★ ()
Ответ на: комментарий от kekelia

Ничего.

# Local package resource list for APT goes here. # To inspect package defined part, see /etc/apt/sources.list.d/*.list

# rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/ x86_64 classic

# rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/ noarch classic

Как видно, даже Сифилис закомментирован. Редактор репозиторий в синаптике показывает две репы p8/classic для x86_64 и noarch.

kknight ★★★★ ()
Последнее исправление: kknight (всего исправлений: 2)

1. Читать

https://www.altlinux.org/Инструкция_по_сборке_пакетов_с_помощью_rpm

но если собирать «правильно», то лучше освоить

https://www.altlinux.org/Hasher/Краткое_руководство

2. У них уже 9ка, так что 8ка примерно как у дебиана oldstable

3. Пакеты из сизифа лучше перебрать у себя под 8ку с использованием srpm-пакета

4. кроме

https://packages.altlinux.org/ru

есть

https://www.altlinux.org/Карманы

можно и alien использовать и тупо пробовать ставить rpm из других дистров через apt-get install /path-to-package

anonymous ()
Ответ на: комментарий от anonymous

Спасибо, я понял. Я-то думал, что Сизиф - это как контриб у Росы, а тут надо делать rpmbuild -ba на половину нужного софта.

kknight ★★★★ ()

У Альта есть какая-то древняя и бестолковая вики, в которой нужной информации не найдёшь...

Искать надо уметь, там всё просто.

3. Подключил Сизиф. Некоторые программы оттуда ставятся, другие - нет

https://www.altlinux.org/Репозитории_ALT_Linux

4. Какой вообще правильный способ ставить программы, которых нет в стандартном репозитории?

https://www.altlinux.org/Где_и_как_искать_программы

AS ★★★★★ ()
Ответ на: комментарий от AS

Дистрибутив P9 beta. Как обновиться? Делаю apt-get upgrade и вижу сообщение, что этот параметр из-за чего-то там отключён. Как тогда получить свежие версии пакетов?

kknight ★★★★ ()

Подключил Сизиф

ну хоть не Иуда

chenbr0 ()
Ответ на: комментарий от AS

Спасибо, конечно, но в вики нет ответа на мой вопрос. Как правильно обновлять систему? Её вообще можно обновить?

kknight ★★★★ ()
Ответ на: комментарий от kknight

Спасибо, конечно, но в вики нет ответа на мой вопрос.

Как нет!? apt-get dist-upgrade всегда. Если репозиторий не меняешь основной, остаёшься в пределах бранча, если меняешь репозиторий, обновляешься до нового. А apt-get upgrade только тогда, когда точно знаешь, зачем. И до кучи, можно ещё продаунгрейдиться: https://www.altlinux.org/Downgrade

AS ★★★★★ ()
Последнее исправление: AS (всего исправлений: 2)
Ответ на: комментарий от kknight

Спасибо, конечно, но в вики нет ответа на мой вопрос.

И правда не упоминается в явном виде на этой странице. :-) Ну apt-get --help тогда, что ли...

AS ★★★★★ ()

уже p9 релизнулся. сам попробовал на днях (starter-kde) - сказка.
1. sudo $command
2. имхо - маловероятно.
3. сизиф уже зафризился - ставьте/обновляйте [до] p9
4. в p9 можно от шапки/кентоси/федоры ставить всё, они таки смогли побороть двухлетнию лень

etwrq ★★★★ ()

В общем, история закончилась так: у нас ввели авторизацию через прокси-сервер с Squid. Быстро выяснилось, что альтовский Apt не умеет правильно обрабатывать спецсиволы в паролях. Пароль вида P@ssword он не в состоянии распарсить, сколько я ни заменял @ на %40.

Задал вопрос на их форуме, мне там ответили, что мол пароль надо поменять на «нормальный». Ага, вот так я и пойду к админу околачивать пороги и просить поменять мой пароль…

На моей памяти это первый дистр, который не может нормально работать через прокси с авторизацией. Очень жаль.

kknight ★★★★ ()
Ответ на: комментарий от kknight

мне там ответили, что мол пароль надо поменять на «нормальный»

ЛОЛ. Почему-то я не удивлён.

no-such-file ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.