LINUX.ORG.RU
решено ФорумAdmin

CentOS 6: yum хочет поставить i686 пакеты на x86_64 систему

 ,


0

1

В процессе ознакомления с CentOS6 столкнулся:

# yum --disablerepo=\* --enablerepo=c6-media install samba-client samba-common cifs-utils
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * c6-media:
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package cifs-utils.i686 0:4.8.1-10.el6 will be installed
--> Processing Dependency: libtalloc.so.2 for package: cifs-utils-4.8.1-10.el6.i686
--> Processing Dependency: libcap-ng.so.0 for package: cifs-utils-4.8.1-10.el6.i686
---> Package samba-client.i686 0:3.5.10-125.el6 will be installed
--> Processing Dependency: libwbclient.so.0 for package: samba-client-3.5.10-125.el6.i686
--> Processing Dependency: libtdb.so.1 for package: samba-client-3.5.10-125.el6.i686
---> Package samba-common.i686 0:3.5.10-125.el6 will be installed
--> Running transaction check
---> Package libcap-ng.i686 0:0.6.4-3.el6_0.1 will be installed
---> Package libtalloc.i686 0:2.0.1-1.1.el6 will be installed
---> Package libtdb.i686 0:1.2.1-3.el6 will be installed
---> Package samba-winbind-clients.i686 0:3.5.10-125.el6 will be installed
--> Finished Dependency Resolution

Затем он патается скачать i686 пакеты, хотя в c6-media есть x86_64 версии этих пакетов и:

# uname -pi
x86_64 x86_64

Знающие, поясните смысл действий yum-а?

Ответ на: комментарий от dexpl

Оно по дефолту так и было:

# cat /etc/yum.conf | grep exactarch
exactarch=1

Эффекта нет.

omegatype ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.