LINUX.ORG.RU
ФорумAdmin

не видит либы

 


0

1

всем привет
хочу поставить пакет prosody
выход такая бяка, что нужны пакеты libcrypto.so.10 и libssl.so.10
centos 6

--> Running transaction check
---> Package prosody.x86_64 0:0.9.10-1.el6 will be installed
--> Processing Dependency: lua-socket for package: prosody-0.9.10-1.el6.x86_64
--> Processing Dependency: lua-sec for package: prosody-0.9.10-1.el6.x86_64
--> Processing Dependency: lua-filesystem for package: prosody-0.9.10-1.el6.x86_64
--> Processing Dependency: lua-expat for package: prosody-0.9.10-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: prosody-0.9.10-1.el6.x86_64
--> Running transaction check
---> Package lua-expat.x86_64 0:1.3.0-1.el6 will be installed
---> Package lua-filesystem.x86_64 0:1.4.2-1.el6 will be installed
---> Package lua-sec.x86_64 0:0.5-4.el6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: lua-sec-0.5-4.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: lua-sec-0.5-4.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) for package: lua-sec-0.5-4.el6.x86_64
---> Package lua-socket.x86_64 0:3.0-0.10.rc1.el6 will be installed
---> Package prosody.x86_64 0:0.9.10-1.el6 will be installed
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: prosody-0.9.10-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: lua-sec-0.5-4.el6.x86_64 (epel)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: prosody-0.9.10-1.el6.x86_64 (epel)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: lua-sec-0.5-4.el6.x86_64 (epel)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: lua-sec-0.5-4.el6.x86_64 (epel)
           Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)

при том что все эти либы уже есть.

/usr/lib64/libcrypto.so.10
/usr/lib64/libssl.so.10


Шо за дистр?

sudo ldconfig не помогает?

anonymous ()

Это не ссылки случаем, посмотри вывод:

ls -ls /usr/lib64/libcrypto.so.10
ls -ls /usr/lib64/libssl.so.10

kostik87 ★★★★★ ()

Наличие файлов бибилиотек не имеет значение, поскольку библиотеки должны быть поставлены через пакеты. Вариант первый - посмотреть кто провайдит эти зависимости (и провайдит ли вообще). Вариант второй - поставить с --nodeps через rpm, а не yum

no-dashi ★★★★★ ()
Ответ на: комментарий от carter

а разве либы не через переменные ищутся?

не знаю, как там в centos, но, обычно, пакетный менеджер вообще не ищет «либы», он ищет пакеты.

CryAngel ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.