LINUX.ORG.RU
решено ФорумAdmin

Проблема c обновлением CentOS 6.2 x64


0

1

День добрый!

Словил вот такую ошибку при обновлении центоса:

>yum update
Error: Protected multilib versions: gnutls-2.8.5-4.el6.3.x86_64 != gnutls-2.8.5-4.el6_2.2.i686
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
gnutls-2.8.5-4.el6_2.2.x86_64 is a duplicate with gnutls-2.8.5-4.el6.i686

yum update --skip-broken не помогает.

Каким-то образом из-за кривых рук затесалась 32 битная версия gnutls, пытаюсь её удалить:

>rpm -e gnutls-2.8.5-4.el6.i686
error: Failed dependencies:
        gnutls = 2.8.5-4.el6 is needed by (installed) gnutls-openssl-2.8.5-4.el6.x86_64

Удалять gnutls-openssl тоже не могу, так как на серваке уже во всю работает сайт. При попытке удалить 64х битную версию естественно тоже ошибка:

>rpm -e gnutls-2.8.5-4.el6_2.2.x86_64
error: Failed dependencies:
        libgnutls.so.26()(64bit) is needed by (installed) gnutls-openssl-2.8.5-4.el6.x86_64
        libgnutls.so.26()(64bit) is needed by (installed) csync2-1.34-1.2.x86_64
        libgnutls.so.26(GNUTLS_1_4)(64bit) is needed by (installed) gnutls-openssl-2.8.5-4.el6.x86_64
        libgnutls.so.26(GNUTLS_1_4)(64bit) is needed by (installed) csync2-1.34-1.2.x86_64
        libgnutls.so.26(GNUTLS_PRIVATE)(64bit) is needed by (installed) gnutls-openssl-2.8.5-4.el6.x86_64

Одно ясно, оба пакета в зависимостях у gnutls-openssl, как бы безболезненно убрать один из пакетов, есть ли какой-нибудь способ решить подобную проблему?



Последнее исправление: dsf435 (всего исправлений: 2)

Ответ на: комментарий от Pinkbyte

только потом сразу yum update, а то консистентность системы нарушена будет

Pinkbyte ★★★★★
()
Ответ на: комментарий от dsf435

Всегда пожалуйста. Только повторюсь - не забудь сделать yum update - мало ли какие зависимости такое удаление порушило

Pinkbyte ★★★★★
()

добавь exclude=*.i386 *.i686 в конфиг юма.

xpahos ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.