LINUX.ORG.RU
решено ФорумAdmin

debian wheezy+libc.so.6

 ,


0

1

Камрады, доброго дня!

Так вышло, что по своей торопливости устанавливая на сервер (3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux) zabbix-agent, подключил старый репозиторий и разумеется в процессе инсталляции он перетёр некоторые библиотеки. Самая главная проблема в том, что сейчас не работает mount.nfs который очень нужен, места на диске мало и бэкапы с этого сервера сваливаются на «nfs-шару». Что делаю: mount -a В ответ получаю: /sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1) /sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.16' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1) /sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1)

Пробовал разумеется apt-get -f install

Следующие пакеты устанавливались автоматически и больше не требуются: libossp-uuid16 libpq5 libxslt1.1 postgresql-client-9.1 postgresql-client-common postgresql-common ssl-cert Для их удаления используйте «apt-get autoremove». Пакеты, которые будут УДАЛЕНЫ: libtirpc1 locales nfs-common postgresql postgresql-9.1 postgresql-contrib postgresql-contrib-9.1 rpcbind обновлено 0, установлено 0 новых пакетов, для удаления отмечено 8 пакетов, и 10 пакетов не обновлено. не установлено до конца или удалено 2 пакетов. Но postgresql критически важен, сервер с базами данных, все в боевом режиме сейчас. Можно ли как-то «залечить» чтобы хотя бы работал mount.nfs? p.s. При попытке переустановить libc6 apt-get install libc6 Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»: Пакеты, имеющие неудовлетворённые зависимости: libc6 : Зависит: libc-bin (= 2.13-38+deb7u3) но 2.13-38+deb7u1 будет установлен libtirpc1 : Зависит: libc6 (>= 2.16) но 2.13-38+deb7u3 будет установлен locales : Зависит: glibc-2.19-1 но он не может быть установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

Заранее спасибо!

Ответ на: комментарий от anonymous

Глупый вопрос, как? учитывая, что в системе теперь поломанные зависимости...

profit_crash ()
Ответ на: комментарий от menzoberronzan

aptitude install libc6 Следующие пакеты будут обновлены: libc-bin libc6 Следующие частично установленные пакеты будут настроены: libtirpc1{b} locales{b} 2 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 8 пакетов не обновлено. Необходимо получить 5 493 kB архивов. После распаковки освободится 146 k байт. Следующие пакеты имеют неудовлетворённые зависимости: locales : Зависит: glibc-2.19-1 который является виртуальным пакетом. libtirpc1 : Зависит: libc6 (>= 2.16) но устанавливается 2.13-38+deb7u3. Следующие действия разрешат зависимости:

Удалить следующие пакеты: 1) libtirpc1 2) locales 3) nfs-common 4) postgresql 5) postgresql-9.1 6) postgresql-contrib 7) postgresql-contrib-9.1 8) rpcbind

Оставить следующие зависимости неразрешёнными: 9) mutt рекомендует locales

Принять данное решение? [Y/n/q/?] Я так понимаю приняв данное решение я потеряю боевой сервер...

profit_crash ()
Ответ на: комментарий от profit_crash

Зависит: libc6 (>= 2.16) но устанавливается 2.13-38+deb7u3

Судя по этому у тебя все еще подключен репозиторий squeeze.
Подключи wheezy и повтори aptitude.

menzoberronzan ()
Ответ на: комментарий от menzoberronzan

я подключал вообще sid) echo «deb http://mirror.yandex.ru/debian sid main non-free contrib» >> /etc/apt/sources.list делал так, как в статье) так как из дебиана и в squeeze был исключен zabbix, не поправили ошибки на которые Debian им указал.

Сейчас мой /etc/apt/source.list

# deb http://mirror.yandex.ru/debian/ wheezy main

deb http://mirror.yandex.ru/debian/ wheezy main deb-src http://mirror.yandex.ru/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile' deb http://mirror.yandex.ru/debian/ wheezy-updates main deb-src http://mirror.yandex.ru/debian/ wheezy-updates main

profit_crash ()
Ответ на: комментарий от vtVitus

Да zabbix-agent уже стоит) Нашел deb-пакет для своей сборки. Главная проблема сейчас - это не работающий mount.nfs

profit_crash ()
Ответ на: комментарий от vtVitus

/sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1) /sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.16' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1) /sbin/mount.nfs: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /lib/x86_64-linux-gnu/libtirpc.so.1)

Не могу примонтировать шару, библиотеки пошли под откос((

profit_crash ()
Ответ на: комментарий от profit_crash

это делалось с целью тупо установить zabbix-agent. сервер работает на debian (wheezy) 7.5

в /etc/apt/sources.list.d/zabbix добавить:

deb-src http://repo.zabbix.com/zabbix/2.2/debian wheezy main
deb http://repo.zabbix.com/zabbix/2.2/debian wheezy main
wget http://repo.zabbix.com/zabbix-official-repo.key -O - | apt-key add - 
apt-get update

petav ★★★★★ ()
Ответ на: комментарий от petav

на будущее возьму на заметку) благодарю. агент устраивает, работает штатно. меня больше волнует проблема с mount.nfs

profit_crash ()
Ответ на: комментарий от profit_crash

попробуй aptitude install libc6 libtirpc1 locales nfs-common postgresql postgresql-9.1 postgresql-contrib postgresql-contrib-9.1 rpcbind

по умолчанию при удалении пакета, конфиги и данные не удаляются. Для этого нада purge явно говорить, поэтому сделай бекап и вперёд к экспериментам +).

vtVitus ★★★★★ ()
Ответ на: комментарий от vtVitus

это чревато стоп/стартом postgres, живые абоненты на нём... Сейчас скачал для удовлетворения зависимости deb пакет libc-bin, ругается теперь только на: Пакеты, имеющие неудовлетворённые зависимости: libtirpc1 : Зависит: libc6 (>= 2.16) но 2.13-38+deb7u3 будет установлен locales : Зависит: glibc-2.19-1 но он не может быть установлен

profit_crash ()
Ответ на: комментарий от vtVitus

Не понимаю конечно, что его не устраивает libtirpc1 так как: apt-cache policy libtirpc1 libtirpc1: Установлен: 0.2.3-2 Кандидат: 0.2.3-2

profit_crash ()
Ответ на: комментарий от profit_crash

У них для стейбл + в архиве можно найти для предыдущих.

invokercd ★★★★ ()

Камрады, всем спасибо за советы! Решил проблему через aptitude -f install выбрав правильные варианты его действий)

profit_crash ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.