LINUX.ORG.RU

Сломал дебиан GLIBC_2.14 not found

 ,


0

1

При выполнении команды ls, cp, dpkg вылазит ошибка

# ls ls: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

Данная ошибка возникла после долгих эксперементов с обновлением. Как можно вернуть систему к жизни?

# apt-cache policy libc6 libc6:

Installed: 2.13-38+deb7u10

Candidate: 2.13-38+deb7u10

Version table:

*** 2.13-38+deb7u10 0

500 http://security.debian.org/ wheezy/updates/main amd64 Packages

100 /var/lib/dpkg/status 2.13-38+deb7u8 0

500 http://mirror.yandex.ru/debian/ wheezy/main amd64 Packages


Ох уж эти эксперементы с обновлением... Какой версии libselinux1 установлен? И как эта версия проникла к тебе в wheezy? Надо ее либо удалить, либо заменить на подходящую. И ой как хорошо будет, если больше ничего не испортилось...

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

# apt-cache policy libselinux1

libselinux1:

Installed: 2.3-2

Candidate: 2.3-2

Version table:

*** 2.3-2 0

100 /var/lib/dpkg/status

2.1.9-5 0

500 http://mirror.yandex.ru/debian/ wheezy/main amd64

Packages

В том то и дело что запутался совсем и не пойму откуда ноги растут. Качал пакеты в ручную и ставил через dpkg -i видимо так и попал

vagon ()
Ответ на: комментарий от vagon

Удаляй или даунгрейди. Как видим, идея ставить пакеты вручную, не обращая внимания на зависимости, себя не оправдывает.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

# apt-get remove libselinux1

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: coreutils : PreDepends: libselinux1 (>= 1.32) but it is not going to be installed

cron : Depends: libselinux1 (>= 1.32) but it is not going to be installed

dbus : Depends: libselinux1 (>= 1.32) but it is not going to be installed

dpkg : PreDepends: libselinux1 (>= 1.32) but it is not going to be installed

libc6 : Depends: libc-bin (= 2.13-38+deb7u10) but 2.13-38+deb7u4 is to be installed

libdevmapper1.02.1 : Depends: libselinux1 (>= 1.32) but it is not going to be installed

libglib2.0-0 : Depends: libselinux1 (>= 1.32) but it is not going to be installed

libmount1 : Depends: libselinux1 (>= 1.32) but it is not going to be installed

libpam-modules : PreDepends: libselinux1 (>= 2.0.85) but it is not going to be installed

libpam-modules-bin : Depends: libselinux1 (>= 1.32) but it is not going to be installed

libsemanage1 : Depends: libselinux1 (>= 1.32) but it is not going to be installed

libsystemd-login0 : Depends: libselinux1 (>= 2.0.65) but it is not going to be installed

logrotate : Depends: libselinux1 (>= 1.32) but it is not going to be installed

mount : PreDepends: libselinux1 (>= 2.0.15) but it is not going to be installed

openssh-client : Depends: libselinux1 (>= 1.32) but it is not going to be installed

openssh-server : Depends: libselinux1 (>= 1.32) but it is not going to be installed

passwd : Depends: libselinux1 (>= 1.32) but it is not going to be installed

sed : PreDepends: libselinux1 (>= 1.32) but it is not going to be installed

sudo : Depends: libselinux1 (>= 1.32) but it is not going to be installed

sysvinit : Depends: libselinux1 (>= 1.32) but it is not going to be installed

sysvinit-utils : Depends: libselinux1 (>= 1.32) but it is not going to be installed

udev : Depends: libselinux1 (>= 1.32) but it is not going to be installed

util-linux : PreDepends: libselinux1 (>= 1.32) but it is not going to be installed

vim-tiny : Depends: libselinux1 (>= 1.32) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

vagon ()
Ответ на: комментарий от vagon

Спешу тебя обрадовать: у тебя уже не wheezy. Вместо того, чтобы даунгрейдить libselinux1, придется апгрейдить libc6. А может libc6 у тебя уже тоже из jessie стоит? Тогда, небось, достаточно будет перезагрузиться. Или даже перелогиниться.

Удалить libselinux1, это я не подумавши ляпнул. Оно имеет приоритет required, так что никогда не надо удалять.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

Сервак в ДЦ, по ssh по новой не пускает. Висит не закрытая сессия ssh, она работает. Ехать в ДЦ не охота, вопрос можно ли как нибудь убедиться наверняка что поднимется сервак после reboot?

vagon ()
Ответ на: комментарий от Nao

Есть, есть опасения что если придется переустанавливать ось то нужно будет ехать в ДЦ. Такие приключения в моей жизни в первые, поэтому не знаю поднимется ли сервер после такого «выстрела в ногу»

vagon ()
Ответ на: комментарий от vagon

Не уверен, что можно надежно убедиться, что сервер поднимется после перезагрузки. Но для начала посмотри, какая версия libc6 сейчас установлена.

TeopeTuK ★★★ ()
Ответ на: комментарий от vagon

Это версия из wheezy. А куча всего у тебя уже из jessie, включая ту же libselinux1. Поэтому не надо перезагружаться. Наверняка что-нибудь важное не запустится.

Я не могу видеть, что сделать проще, откатить обновленные пакеты или дообновить до разумного состояния уже. Возможно, простое обновление libc6 до версии из jessie тебя спасет.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

вот такая история # aptitude install libc-bin_2.13-38+deb7u10_amd64.deb

Couldn't find any package whose name or description matched «libc-bin_2.13-38+deb7u10_amd64.deb»

Couldn't find any package whose name or description matched «libc-bin_2.13-38+deb7u10_amd64.deb»

No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 495 not upgraded.

Need to get 0 B of archives. After unpacking 0 B will be used.

The following packages have unmet dependencies:

libselinux1 : Depends: libc6 (>= 2.14) but 2.13-38+deb7u10 is installed and it is kept back.

libc6 : Depends: libc-bin (= 2.13-38+deb7u10) but 2.13-38+deb7u4 is installed and it is kept back.

The following actions will resolve these dependencies:

Upgrade the following packages: 1) libc6 [2.13-38+deb7u10 (now) -> 2.19-18+deb8u2 (stable)]

Accept this solution? [Y/n/q/?] Y

The following packages will be upgraded:

libc6

1 packages upgraded, 0 newly installed, 0 to remove and 494 not upgraded.

Need to get 0 B/4666 kB of archives. After unpacking 784 kB will be used.

Do you want to continue? [Y/n/?] Y

Can't set locale; make sure $LC_* and $LANG are correct!

Reading changelogs... Done

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

LANGUAGE = (unset),

LC_ALL = (unset),

LC_TIME = «ru_RU.UTF-8»,

LC_MONETARY = «ru_RU.UTF-8»,

LC_ADDRESS = «ru_RU.UTF-8»,

LC_TELEPHONE = «ru_RU.UTF-8»,

LC_NAME = «ru_RU.UTF-8»,

LC_MEASUREMENT = «ru_RU.UTF-8»,

LC_IDENTIFICATION = «ru_RU.UTF-8»,

LC_NUMERIC = «ru_RU.UTF-8»,

LC_PAPER = «ru_RU.UTF-8»,

LANG = «ru_RU.UTF-8»

are supported and installed on your system.

perl: warning: Falling back to the standard locale («C»).

locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Cannot set LC_MESSAGES to default locale: No such file or directory

locale: Cannot set LC_ALL to default locale: No such file or directory

Preconfiguring packages ...

/usr/bin/dpkg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover:

dpkg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

vagon ()
Ответ на: комментарий от TeopeTuK

Всё равно не заводится

# aptitude install libc6_2.19-18+deb8u3_amd64.deb

Couldn't find any package whose name or description matched «libc6_2.19-18+deb8u3_amd64.deb»

Couldn't find any package whose name or description matched «libc6_2.19-18+deb8u3_amd64.deb»

No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 495 not upgraded.

Need to get 0 B of archives. After unpacking 0 B will be used. The following packages have unmet dependencies:

libselinux1 : Depends: libc6 (>= 2.14) but 2.13-38+deb7u10 is installed and it is kept back.

libc6 : Depends: libc-bin (= 2.13-38+deb7u10) but 2.13-38+deb7u4 is installed and it is kept back.

The following actions will resolve these dependencies:

Upgrade the following packages: 1) libc6 [2.13-38+deb7u10 (now) -> 2.19-18+deb8u2 (stable)]

Accept this solution? [Y/n/q/?] Y

The following packages will be upgraded:

libc6

1 packages upgraded, 0 newly installed, 0 to remove and 494 not upgraded.

Need to get 0 B/4666 kB of archives. After unpacking 784 kB will be used.

Do you want to continue? [Y/n/?] Y

Can't set locale; make sure $LC_* and $LANG are correct!

Reading changelogs... Done

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

LANGUAGE = (unset),

LC_ALL = (unset),

LC_TIME = «ru_RU.UTF-8»,

LC_MONETARY = «ru_RU.UTF-8»,

LC_ADDRESS = «ru_RU.UTF-8»,

LC_TELEPHONE = «ru_RU.UTF-8»,

LC_NAME = «ru_RU.UTF-8»,

LC_MEASUREMENT = «ru_RU.UTF-8»,

LC_IDENTIFICATION = «ru_RU.UTF-8»,

LC_NUMERIC = «ru_RU.UTF-8»,

LC_PAPER = «ru_RU.UTF-8»,

LANG = «ru_RU.UTF-8»

are supported and installed on your system.

perl: warning: Falling back to the standard locale («C»).

locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Cannot set LC_MESSAGES to default locale: No such file or directory

locale: Cannot set LC_ALL to default locale: No such file or directory

Preconfiguring packages ...

/usr/bin/dpkg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover:

dpkg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

vagon ()
Ответ на: комментарий от vagon

dpkg, как видим, не работает из-за слишком старой glibc (она же libc6). Вот такая катастрофа. Я бы взял бы файлы из пакета libc6 из jessie, руками бы положил бы в /usr/local/lib, запустил бы ldconfig и попробовал бы установить еще раз. В общем, работа творческая, интересная, удачи!

И не забудь после того, как все закончится, написать 1000 раз в тетрадке: «Я больше никогда не буду игнорировать зависимости!»

TeopeTuK ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.