LINUX.ORG.RU
ФорумAdmin

Удаление пакета, без удаления пакетов что от него зависят


0

1

Установил libc6=2.17-93 теперь в системе так

apt-cache show libc6
Package: libc6
Status: install ok installed
Priority: required
Section: libs
Installed-Size: 10164
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: amd64
Multi-Arch: same
Source: eglibc
Version: 2.17-93
Replaces: libc6-amd64
Provides: glibc-2.17-1
Depends: libgcc1
Suggests: glibc-doc, debconf | debconf-2.0, locales
Breaks: locales (<< 2.17), locales-all (<< 2.17), lsb-core (<= 3.2-27), nscd (<< 2.17)
Conflicts: prelink (<= 0.0.20090311-1), tzdata (<< 2007k-1), tzdata-etch
Conffiles:
 /etc/ld.so.conf.d/x86_64-linux-gnu.conf 593ad12389ab2b6f952e7ede67b8fbbf
Description-ru: библиотека Embedded GNU C (динамические библиотеки)
 Содержит стандартные библиотеки, которые используются всеми
 программами системы. Данный пакет содержит динамические версии
 стандартной библиотеки C и стандартной математической библиотеки,
 а также многих других библиотек.
Homepage: http://www.eglibc.org

Package: libc6
Source: eglibc
Version: 2.13-38
Installed-Size: 9517
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: amd64
Replaces: libc6-amd64
Provides: glibc-2.13-1
Depends: libc-bin (= 2.13-38), libgcc1
Suggests: glibc-doc, debconf | debconf-2.0, locales
Conflicts: prelink (<= 0.0.20090311-1), tzdata (<< 2007k-1), tzdata-etch
Breaks: locales (<< 2.13), locales-all (<< 2.13), lsb-core (<= 3.2-27), nscd (<< 2.13)
Description-ru: библиотека Embedded GNU C (динамические библиотеки)
 Содержит стандартные библиотеки, которые используются всеми
 программами системы. Данный пакет содержит динамические версии
 стандартной библиотеки C и стандартной математической библиотеки,
 а также многих других библиотек.
Multi-Arch: same
Homepage: http://www.eglibc.org
Description-md5: 5089b4da6684d7432ab618fb5b79cec5
Tag: implemented-in::c, role::shared-lib
Section: libs
Priority: required
Filename: pool/main/e/eglibc/libc6_2.13-38_amd64.deb
Size: 4338780
MD5sum: dcc8db0b8b81dd79922cc5418f3bc7fd
SHA1: a2ccb5608428e5a50f57aeb03a1fea58619aae34
SHA256: 277df303a2aca247b8ea3f367f949b01e9a3ff67206fe41ff943a7a6c93109ed

Хочу удалить apt-get remove libc6=2.17-93 ну есс-но он хочет удалить всю систему которая зависит от этого пакета. Хочу удалить 2.17.93 оставить 2.13-38, без удаления зависимостей. Как сделать правильно?

Не пытайся сделать это на дебиане, он для этого не предназначен. Тебя предупредили.

anonymous ()

Хочу удалить 2.17.93 оставить 2.13-38, без удаления зависимостей. Как сделать правильно?

Проще всего через aptitude. Но можно попробовать apt-get -f install libc6=2.13-38

i-rinat ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.