LINUX.ORG.RU

PyDev 1.5.0

 , ,


0

0

Вышел PyDev 1.5.0 - плагин для Eclipse, поддерживающий разработку на Python, Jython и IronPython. Главная новость выпуска - интеграция PyDev Extensions в основную версию PyDev (ранее PyDev Extensions распространялись как платный closed-source продукт).

PyDev включает в себя всё, что ожидается от современной IDE: code completion, синтаксический анализ on-the-fly, рефакторинг, интегрированный отладчик, для вынужденных переселенцев с Лиспа имеется интерактивная консоль. Есть также поддержка работы с Google Application Engine.

>>> Подробности

★★★★★

Проверено: Dimez ()

Ответ на: Re: PyDev 1.5.0 от anotheranonymous

Re: PyDev 1.5.0

> В арче уже почти неделю в репах :)

А почему ты не написал новость? :)

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от IgorIs

Re: PyDev 1.5.0

> с джанго у него как?

Судя по вопросам в форуме, с Джангой у него никакой _особой_ интеграции нет. Она поддерживается ровно так же, как и любой другой набор Питон-библиотек.

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

>Она поддерживается ровно так же, как и любой другой набор Питон-библиотек.

И даже хуже, так как Джанга насквозь динамическая. Очень многие вещи PyDev просто никак не понимает и, соответственно, не дополняет/подсказывает. Ну и так в принципе нормально :)

Dirty_Diana ()

Re: PyDev 1.5.0

У меня дежавю? o_O Я вроде новость об этом видел на ЛОРе еще, этак, с неделю назад.

twosev ★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

Долгое время было в неподтвержденных - уже нет. Мамой клянусь, сестра.

twosev ★★ ()
Ответ на: Re: PyDev 1.5.0 от anotheranonymous

Re: PyDev 1.5.0

> В арче уже почти неделю в репах :) А вообще - отличная новость.

Ставить эклипс из реп нельзя. Просто нельзя.

kost-bebix ★★ ()

Re: PyDev 1.5.0

Очень позитивная новость. Наконец-то я вижу мои unused imports, unused variables и могу наглядно оценить количество (очевидных) проблем в своём коде.

anonymous ()
Ответ на: Re: PyDev 1.5.0 от anonymous

Re: PyDev 1.5.0

> Наконец-то я вижу мои unused imports, unused variables и могу наглядно оценить количество (очевидных) проблем в своём коде.

Вообще-то для этого хватит pylint (+ pyflakes опционально) :)

tailgunner ★★★★★ ()

Re: PyDev 1.5.0

А вот это действительно хорошая новость !

kitov ★★★ ()
Ответ на: Re: PyDev 1.5.0 от kost-bebix

Re: PyDev 1.5.0

> Ставить эклипс из реп нельзя. Просто нельзя.

Паркуа бы и не па?

baverman ★★★ ()

Re: PyDev 1.5.0

Зачетная новость! С PyDev эклипс стал самой навороченной IDE для разработки сложных питонских проектов. Особенно при смеси питон+Си+тикль.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Linfan

Re: PyDev 1.5.0

> С PyDev эклипс стал самой навороченной IDE для разработки сложных питонских проектов. Особенно при смеси питон+Си+тикль

А что, для тикля тоже есть плагин?

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от anonymous

Re: PyDev 1.5.0

> Чем оно лучше rope?

"Rope is a python refactoring library". Я правильно понял вопрос: "Чем готовая IDE лучше библиотеки для построения IDE?"

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

>А что, для тикля тоже есть плагин?

угу, входит в Dynamic Languages Toolkit.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от fenris

Re: PyDev 1.5.0

> Писать на питоне в жабном DE не извращение ли?

А писать на Питоне в редакторе, написанном на Си? А на смеси Си и Лиспа?

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от fenris

Re: PyDev 1.5.0

>Писать на питоне в жабном DE не извращение ли?

А пофиг :) Да хоть на бейсике и лично Балмером писанная :) Основное требование - удобство разработки и экономия времени, а не Ъ-ушность.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

> Я правильно понял вопрос: "Чем готовая IDE лучше библиотеки для построения IDE?"

Ну есть же ropemacs. Получается emacs+ropemacs+flymake+pyflakes даёт всё то же, что pydev. И без этого чудовищного эклипса. Признаюсь, я его не осилил. Заблудился в интерфейсе, пытаясь понять, а куда же собственно печатать код :/

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

>Заблудился в интерфейсе, пытаясь понять, а куда же собственно печатать код

В Имаксе значит разобрался, а интуитивную среду не осилил :-)

kitov ★★★ ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

>> Я правильно понял вопрос: "Чем готовая IDE лучше библиотеки для построения IDE?"

> Ну есть же ropemacs

Но вопрос-то был про rope.

> Получается emacs+ropemacs+flymake+pyflakes даёт всё то же, что pydev.

Кроме интегрированного отладчика (или он уже есть в emacs?) и мелочей типа GAE, скриптинга на Jython, настройки через нормальный GUI (а не через ужоснах емаксового customize). Это, правда, не говоря о том, что _качество_ работы rope и pydev как бы никто не сравнивал, и что лучше - хз.

А еще лично моему глазу Eclipse гораздо приятнее Emacs.

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

Получается emacs+ropemacs+flymake+pyflakes даёт всё то же, что pydev.

И в каждой этой хрени надо разобраться и настроить.

a3 ()
Ответ на: Re: PyDev 1.5.0 от a3

Re: PyDev 1.5.0

> И в каждой этой хрени надо разобраться и настроить.

Нечего там разбираться. Мне вот куда как сложнее было разбираться в хитросплетениях эклипсовых менюшек. Ну это индивидуально, спорить не буду.

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

> Кроме интегрированного отладчика (или он уже есть в emacs?)

Графического нет, pdb можно прикрутить.

> и мелочей типа GAE, скриптинга на Jython,

Это я не знаю зачем надо, но вероятно нет.

> настройки через нормальный GUI (а не через ужоснах емаксового customize).

Customize вполне себе нормален. Логичная организация, подробное описание опций. Внешний вид не нравится что ли?

> А еще лично моему глазу Eclipse гораздо приятнее Emacs.

Уж не знаю чем отличаются поля ввода на вид :) То что в еклипсе полно всякой гуи-шелухи, это да. Зачем оно всё надо - хз. Впрочем, всё бы можно было стерпеть, если бы эта монстровина так не тормозила. Почему то у меня даже Комодо, который на XUL, шустрее откликается (хотя тоже не фонтан). Поэтому выбираю емакс как наиболее оптимальный компромисс. Тем более для скриптов на Питоне... цельный эклипс... Это ж пушкой по воробьям :)

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

Ну ropevim, скажем. Я юзаю для автодополнения - вообще шикарно.

//4

anonymous ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

> pdb можно прикрутить.

Держите меня трое %) Можно, конечно... можно и заново его написать, чего мелочиться.

> Customize вполне себе нормален. Логичная организация, подробное описание опций. Внешний вид не нравится что ли?

Мне в customize не нравится убогая попытка эмулировать GUI в текстовых буферах. Впрочем, всё остальное тоже не нравится.

> выбираю емакс как наиболее оптимальный компромисс.

А я вот отладчик считаю полезным... Но привинчивать pdb своими рукам желания совсем нет, так что Emacs на роль компромисса даже не рассматривается. Это не говоря о том, что, привинти я pdb, придется взяться за доводку GUD до уровня отладчика CDT (ага, не Питоном единым).

> для скриптов на Питоне... цельный эклипс... Это ж пушкой по воробьям :)

Для скриптов на Питоне... цельный Emacs... Это ж пушкой по воробьям :)

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

Держите меня трое %) Можно, конечно... можно и заново его написать, чего мелочиться.

Да уже прикрутили за нас, не волнуйтесь так :) http://www.emacswiki.org/emacs/PdbNotes

Мне в customize не нравится убогая попытка эмулировать GUI в текстовых буферах.

Дык имакс и не является gui-приложением вообще то.

А я вот отладчик считаю полезным...

Если требуется суровая отладка, то можно и еклипс запустить. Знаю людей, которые под виндой кодят в емаксе, а отлаживают в Visual Studio.

Для скриптов на Питоне... цельный Emacs... Это ж пушкой по воробьям

Да, тоже избыточно. Но имакс бережно относится к ресурсам, так что можно позволить и дополнительные удобства.

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

> Да уже прикрутили за нас, не волнуйтесь так :)

А я волнуюсь? Мне само предложение прикручивать смешно. Зачем, если в Eclipse уже есть?

> http://www.emacswiki.org/emacs/PdbNotes

Доо, в убогой gdb mode.

>> Мне в customize не нравится убогая попытка эмулировать GUI в текстовых буферах.

> Дык имакс и не является gui-приложением вообще то.

Я бы понял, если бы emacs-nox не был GUI-приложением, но emacs, собранный с GUI toolkit - ему-то какой смысл? Можешь не отвечать, вопрос риторический.

> имакс бережно относится к ресурсам

Да предрассудки это всё... когда ему было столько же лет, сколько Eclipse сегодня, он жрал тогдашних ресурсов еще похлеще, чем Eclipse жрет сегодняшних. А экономить 200-400 метров, занимаемых Eclipse, лично мне не имеет смысла уже неколько лет. Буду программировать на нетбуке - подумаю об emacs.

tailgunner ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

>Но имакс бережно относится к ресурсам, так что можно позволить и дополнительные удобства.

хм... гиг памяти нонче стоит меньше 20$. Ради человеческого интерфейса можно и не пожлобится :)

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Linfan

Re: PyDev 1.5.0

> хм... гиг памяти нонче стоит меньше 20$.

Да не важно. Меня устраивают joe и emacs. Никаких киллер-фич в больших ide не вижу. Зачем чего то там апгрейдить? Если бы я участвовал в крупных проектах на Java, тогда ещё был бы смысл. Я когда то с винды бежал как от чумы из-за её нелогичности, сложности, монстрового тормозного софта. Возвращаться к этому в линуксе не хочу.

Hjorn ()
Ответ на: Re: PyDev 1.5.0 от Hjorn

Re: PyDev 1.5.0

>Если бы я участвовал в крупных проектах...

Вот тут то собак и порылся :) Для написания мелких прог с головой хватает и KWrite. Сопровождение сложного проекта требует IDE.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Linfan

Re: PyDev 1.5.0

+1 за emacs.

искал кучу вариантов, в том числе eclipse, но действительно ужасно тормозит :(

позвольте узнать насколько сложным должен считаться проект, чтобы использовать IDE а-ля eclipse?

LestatCheb ()
Ответ на: Re: PyDev 1.5.0 от LestatCheb

Re: PyDev 1.5.0

>позвольте узнать насколько сложным должен считаться проект, чтобы использовать IDE а-ля eclipse?

Единых правил нет и быть не может. Каждый сам выбирает уровень сложности для IDE, ну или уровень комфорта при разработке. Я например, как только попробовал Eclipse с плагинами под питон, тикль и Си + Subclipse + code compare - сразу же пошел и обновил машину до Core2Duo c 2 гигами памяти, т.к. мое время мне дороже, чем разруливание проекта в нескольких разных прогах. Опять же, я говорю про свой проект sK1 Project. Возможно, что в более гомогенном проекте все гораздо проще.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от LestatCheb

Re: PyDev 1.5.0

>искал кучу вариантов, в том числе eclipse, но действительно ужасно тормозит

на вышеуказанной конфигурации не тормозит. Кстати, в eclipse.ini можно увеличить минимальный объем памяти для жабки. Помогает от подвисания когда жабский garbage collector просыпается :)

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от LestatCheb

Re: PyDev 1.5.0

> искал кучу вариантов, в том числе eclipse, но действительно ужасно тормозит :(

Как всегда, Eclipse из репов Ubuntu (или Fedora), запускаемый поверх gij?

tailgunner ★★★★★ ()

Re: PyDev 1.5.0

Пишу Django приложения в эклипсе. Почему?

Потому, что:

1) PyDev - удобен и обладает всеми нужными функциями. Здесь почему-то еще никто не говорит про Code Coverage. Или что, красноглазым юниттесты ни к чему, ваш код безглючен? А рефакторинг? Или у вас с первого раза выстраивается чистая архитектура, и рефакторинг ей не нужен?

2) Там же, в эклипсе, никуда не переключаясь, великолепный HTML редактор с подсветками, автодополнениями, дополнениями CSS даже внутри style="..., дополнениями JS даже внутри <script>... и валидацией кода *на лету* а не сабмитом на валидатор.

3) Я уж не говорю про отличный CSS редактор

4) JS редактор с автодополнением и встроенным JS Lint, который _на_лету_ анализирует код и выдает подскази, которые, конечно, не заменят мозга, но опечатки ловят отлично.

5) Встроенная поддержка SVN

6) Local history, которая в случае SVN в общем-то излишек, но для мелких проектов, где SVN сам п осебе не нужен - очень даже хорошая вещь которая обладает всеми функциями, работает автоматически и порой выручала очень сильно.

Вы знаете... Вы можете сколько угодно радоваться и харахориться емаксами, но работа должна приносить удовольствие. Мне приятно, когда я сажусь, все открыто, все интегрировано, все в одном месте - переключаешься табами, код анализируется и дополняется, отступы идут сами, от меня лишь требуется работа над алгоритмом, его формализацией, его архитектурой, а не о мелочах.

alexey_ ()

Re: PyDev 1.5.0

Ура!!! Отличная новость. В понедельник на работе буду обновляться. :)

shty ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от Dirty_Diana

Re: PyDev 1.5.0

>И даже хуже, так как Джанга насквозь динамическая

ага, а Питон статически линкуется везде и строгую типизацию внедряет...

shty ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

>Вообще-то для этого хватит pylint (+ pyflakes опционально) :)

и, блин, в pydev они прикручиваются "искаропки"

shty ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от fenris

Re: PyDev 1.5.0

>Писать на питоне в жабном DE не извращение ли?

А что Вас смущает уважаемый?

Вы пишете на Python, не??

shty ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от alexey_

Re: PyDev 1.5.0

+1000

и добавим интеграцию с pylint, позволяющую проверять код не отходя от кассы...

shty ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от shty

Re: PyDev 1.5.0

>>гиг памяти нонче стоит меньше 20$.

>вообще-то уже 2 гига

Ну это расплывчатая сущность - смотря какая, смотря где и т.п. Но даже 20 баксов - это весьма скромные затраты затраты для комфортного девелопмента.

Linfan ★★★★★ ()
Ответ на: Re: PyDev 1.5.0 от tailgunner

Re: PyDev 1.5.0

стандартный eclipse из репы extra в арчлинуксе..

ладно, попробую еще раз его поставить и помучить :)

может кто даст хорошую ссылку на настройку eclipse+pydev+django и т.д.? :)

LestatCheb ()
Ответ на: Re: PyDev 1.5.0 от LestatCheb

Re: PyDev 1.5.0

> стандартный eclipse из репы extra в арчлинуксе..

Про арч - хз, но в убунте, дебильяне и федоре Eclipse из репов ставить просто нельзя.

> может кто даст хорошую ссылку на настройку eclipse+pydev+django и т.д.? :)

Скачать с оффсайта, поставить Sun Java, распаковать PyDev в каталог с Eclipse.

tailgunner ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.