LINUX.ORG.RU

OpenIndiana Hipster 2017.10

 , ,


2

3

Проект Open Indiana представил новый выпуск дистрибутива свободной операционной системы на основе кодовой базы Illumos под названием OpenIndiana Hipster 2017.10. Illumos продолжает развитие OpenSolaris, включая в том числе такие его компоненты, как ZFS (в виде OpenZFS) и DTrace. OpenIndiana поставляется в трех редакциях: минимальной сборке, с поддержкой только консольных приложений, с графическим окружением Mate.

Основные изменения:

  • Xorg обновлен до версии 1.19.5 (Если вы запускаете OpenIndiana в VirtualBox, то используйте драйвер VESA, т. к. последние дополнения гостевой ОС версий 5.1.30 и 5.2.0 не поддерживают Xorg драйвера Solaris для Xorg 1.19). Ошибка, из-за которой Xorg запускался от пользователя root, была исправлена.
  • MATE обновлен до версии 1.18.
  • Текстовый установщик теперь может выполнить базовую установку OpenIndiana на существующий пул ZFS (например, для параллельной установки с другой инсталляцией OpenIndiana).
  • IIIM (Internet/Intranet Input Method Framework) не включен в образ системы с GUI (взамен этого он поставляется с IBus). В установщик были внесены изменения, благодаря которым раскладка клавиатуры в MATE изменяется с помощью XKB. Раскладка US всегда является одной из раскладок по умолчанию, дополнительная раскладка по умолчанию определяется исходя из используемого в системе языка.
  • Набор программ для развертывания кластера был обновлен (corosync 2.4.2, resource-agents 4.0.1, pacemaker 1.1.17, pcs 0.9.159, cmrsh 3.0.1). В его состав входят только 64-х битные приложения.
  • Реализована ABI-поддержка исполняемых файлов Solaris 10u10.
  • Начат процесс удаления из дистрибутива приложений и библиотек GNOME 2 (предупреждение пользователям, которые не перешли на MATE).

Изменения пользовательских программ:

  • Enlightenment обновлен до версии 0.21.8.
  • Firefox обновлен до версии 52.4.1.
  • VLC обновлен до версии 2.2.6.
  • Thunderbird обновлен до версии 52.4.0.
  • Lightdm теперь правильно взаимодействует с Solaris-специфичным интерфейсом Xorg, позволяя X-серверу запускаться с правильными привилегиями.
  • Было исправлено несколько ошибок в time-slider (исправлена работа сложных конфигураций с множеством включенных/исключенных файловых систем, плагин zfs-send вновь работает).
  • libjpeg обновлен до версии 1.5.2.
  • Gstreamer и плагины обновлены до версии 1.12.3.
  • WebkitGTK2 обновлен до версии 2.16.6.
  • btltty обновлен до версии 5.5.
  • Драйвер NVIDIA обновлен до версии 340.104.
  • goffice обновлен до ABI-несовместимой версии 0.10.35. Все зависящие от него приложения должны быть скомпилированы заново.

Изменения системных программ и библиотек

  • zsh обновлен до версии 5.3.1.
  • mc обновлен до версии 4.8.19.
  • tmux обновлен до версии 2.6, screen — до 4.6.1.
  • tcpdump обновлен до версии 4.9.2.
  • mutt обновлен до версии 1.9.0.
  • Добавлен fish версии 2.6.
  • GNU sed обновлен до версии 4.4.
  • GNU awk обновлен до версии 4.1.4.
  • В OpenSSL добавлена поддержка шифров GOST.

Изменения библиотек и инструментов разработчиков:

  • Добавлен GCC 7.
  • Добавлены Jenkins версий 2.73.2 (LTS) и 2.85.
  • Добавлен Golang версии 1.8. Версия 1.6 удалена.
  • OpenJDK 8 обновлен до версии 1.8.131.
  • Tcl/Tk был обновлен до версии 8.6.6.
  • Mercurial обновлен до версии 4.2.3.
  • Git обновлен до версии 2.14.2.
  • ccache обновлен до версии 3.3.4.
  • Valgrind обновлен до версии 3.13.0.

Изменения серверного ПО:

  • Добавлен PostgreSQL 10, PostgreSQL 9.4–9.6 обновлены до последних минорных версий. PostgreSQL 9.3 удален (Теперь версия по умолчанию — 9.4).
  • MongoDB 3.4 был обновлен до версии 3.4.9. Благодаря сотрудничеству с разработчиками MongoDB было исправлено несколько связанных с портированием ошибок.
  • MariaDB 10.1, Percona Server 5.6, 5.7 обновлены до последних минорных версий. Percona Server 5.5 and MariaDB 5.5 были удалены.
  • Net-snmp обновлен до ABI-несовместимой версии 5.7.3. Все зависимые пакеты должны быть собраны заново.
  • OpenVPN обновлен до версии 2.4.3.
  • ISC Bind обновлен до версии 9.10.6.
  • Сервер ISC DHCP обновлен до версии 4.3.5.
  • Squid обновлен до версии 3.5.27.
  • Nginx обновлен до версии 1.13.6.
  • Apache 2.4 обновлен до версии 2.4.29. Apache 2.2 был удален.
  • Lighttpd обновлен до версии 1.4.46.
  • Postfix обновлен до версии 3.1.6.
  • Samba обновлен до версии 4.4.16.
  • GeoIP обновлен до версии 1.6.11.
  • Nodejs обновлен до версий 0.12.18, 6.11.5, 7.10.1 и 8.8.1.

Также были добавлены многие другие малозначимые обновления программ и исправлено множество ошибок.

>>> Полный список изменений и ссылки для скачивания

>>> Подробности

Ответ на: комментарий от NextGenenration

С играми в стиме возится не надо. Они уже готовы, бери и играй. А если не готовы - требуй деньги назад.

Ноутбук тоже готов: бери да играйся с ним.

Он говорит о том что выявляет какие-то проблемы openbsd. Вот мне и интересно, какие такие проблемы возможно обнаружить на старом железе, но принципиально невозможно обнаружить на новом. Из всех его стараний видно только то что он запустил достаточно большое количество версий, для того чтобы обнаружить начиная с какой что отваливается. Что дальше? Патч? Какая его практическая польза? Поможет тем у кого осталось такое железо?

Там скорее другая проблема: поддержку не то что не довели, а уже выпилили за ненужностью. Практической пользы не вижу.

devzero ()
Ответ на: комментарий от Quasar

Уже публиковали же.

Ну они каждую версию выкладывают в паблик вроде.

Даже дистрибутив был.

Был N лет назад. С тех пор я ничего не слышал про дистрибутивы Дарвина.

Там нет важных дров, т.е. они есть, но проприетарные в составе макоси. Не слышал, чтобы кто-то взялся решать эту проблему.

devzero ()
Последнее исправление: devzero (всего исправлений: 1)
Ответ на: комментарий от NextGenenration

Внезапно, тратят деньги те у кого они есть, а не те у кого их нет. Да и потом, ты вряд ли даже с торрентов поиграешь. Как у тебя написано - вина нет.

user@jessie:~$ wine --version
wine-1.8.7 (Debian 1.8.7-2)
user@jessie:~$ uname -a
Linux jessie 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64 GNU/Linux
user@jessie:~$ cat /etc/debian_version 
9.1

А зачем с ним возится?

даже не трудись понять. а то перенапряжёшься. это слишком не вписывается в твою картину мира, а я не хочу быть тем, кто тебе её сломает :)

buratino ★★★ ()
Ответ на: Может быть. от anonymous

Я же тестирую одновременно и разные версии OpenBSD и разные версии Debian. но если в Debian всёработает, значит проблема именно с OpenBSD. Сломанная звуковая подсистема после 5.7 для звуковух с прошивками - это явно проблема OpenBSD :) Только чинить уже некому :)

buratino ★★★ ()
Ответ на: комментарий от buratino

меня же интересует именно современная ос для подобного старого железа

Не нужно быть пророком, чтобы сказать что на таком железе работать будет не всё.

Кроме того, одной оси недостаточно. Нужен прикладной софт. Сможешь запустить ноду? Как быстро она будет работать?

NextGenenration ()

индиана появилась кажется в 2010
тогда они заявили, что :
Из планов на будущее отмечается реализация поддержки платформы SPARC и интеграция GCC вместо компиляторов SunStudio
изолированные контейнеры (Zones)
SMF ( Service Management Framework)
система управления сбоями
COMSTAR iSCSI/FCoE
виртуальный сетевой стек Crossbow.

что мы имеем сейчас ?

kto_tama ★★★★★ ()
Ответ на: Это почему? от anonymous

потому что те, кто могут исправить проблему, не имеют такого железа. а я что-то пытался ковырять драйвер - так ничего и не наковырял, проблема не в драйвере

если бы это по горячим следам хватились... тогда проблема быстро исправляется. а через 2 - 2.5 года уже никто не найдёт решения

buratino ★★★ ()
Ответ на: комментарий от buratino

linux != openbsd. Неужели сейчас выяснится что у тебя есть железо поприличнее?

это слишком не вписывается в твою картину мира, а я не хочу быть тем, кто тебе её сломает

Твоё ЧСВ даже муху не сможет обидеть, не то чтоб чью-то картину мира поломать

NextGenenration ()
Ответ на: комментарий от devzero

Некоторые о ней даже не слышали.

Зато некоторые ТОЛЬКО слышали. Но попробовать не могут.

Боюсь порвать тебе шаблон, но в мире не только лишь всем нужна нода

Не бойся, не порвёшь. Вот вопрос к buratino: какую современную технологию(к примеру язык) потянет твоя машина? Сколько времени понадобится на сборку какого-нибудь среднего пакета?

NextGenenration ()
Ответ на: комментарий от buratino

а через 2 - 2.5 года уже никто не найдёт решения

А сколько людей вообще заметит эту проблему?

если бы это по горячим следам хватились

Уже eol этих версий?

NextGenenration ()
Последнее исправление: NextGenenration (всего исправлений: 1)
Ответ на: комментарий от Leupold_cat

OmniTI выпускали дистрибутив, который они в том числе предлагали использовать для развертывания NAS или SAN. Возможно, для своего хранилища они используют те же технологии, что они предлагают пользователям своего дистрибутива.

У них вся инфра на omnios.

anonymous ()
Ответ на: комментарий от devzero

Там нет важных дров, т.е. они есть, но проприетарные в составе макоси. Не слышал, чтобы кто-то взялся решать эту проблему.

ненадо решать то, что хорошо работает. ни к чему феррари приделывать «устройство по экономии топлива путём ориентации магнитных диполей»:D макось отлично работает из коробки, со всеми драйверами и всем остальным.... с системд и прочими шедеврами лучще «решайте проблему», хотя там один чёрт - поздно уже. титаник тонет, и фуфайкой там дыру никак не заткнуть....:\

wisedraco ★★ ()