<!DOCTYPE html>
<html lang=ru>
<head>
  <link href='https://fonts.googleapis.com/css?family=Open+Sans:600&amp;subset=latin,cyrillic' rel='stylesheet'
        type='text/css'>
  <link rel="stylesheet" type="text/css" href="/tango/combined.css?20170317-1336">

<link rel="yandex-tableau-widget" href="/manifest.json" />
<meta name="referrer" content="always">

<script type="text/javascript">
  /*!
  * $script.js Async loader & dependency manager
  * https://github.com/ded/script.js
  * (c) Dustin Diaz, Jacob Thornton 2011
  * License: MIT
  */
(function(e,d,f){typeof f.module!="undefined"&&f.module.exports?f.module.exports=d():typeof f.define!="undefined"&&f.define=="function"&&f.define.amd?define(e,d):f[e]=d()})("$script",function(){function y(f,e){for(var h=0,g=f.length;h<g;++h){if(!e(f[h])){return E}}return 1}function x(d,c){y(d,function(b){return !c(b)})}function w(p,k,h){function c(b){return b.call?b():K[b]}function q(){if(!--d){K[e]=1,f&&f();for(var b in I){y(b.split("|"),c)&&!x(I[b],c)&&(I[b]=[])}}}p=p[D]?p:[p];var g=k&&k.call,f=g?k:h,e=g?p.join(""):k,d=p.length;return setTimeout(function(){x(p,function(b){if(G[b]){return e&&(J[e]=1),G[b]==2&&q()}G[b]=1,e&&(J[e]=1),v(!L.test(b)&&H?H+b+".js":b,q)})},0),w}function v(h,g){var b=N.createElement("script"),a=E;b.onload=b.onerror=b[z]=function(){if(b[B]&&!/^c|loade/.test(b[B])||a){return}b.onload=b[z]=null,a=1,G[h]=2,g()},b.async=1,b.src=h,M.insertBefore(b,M.firstChild)}var N=document,M=N.getElementsByTagName("head")[0],L=/^https?:\/\//,K={},J={},I={},H,G={},F="string",E=!1,D="push",C="DOMContentLoaded",B="readyState",A="addEventListener",z="onreadystatechange";return !N[B]&&N[A]&&(N[A](C,function u(){N.removeEventListener(C,u,E),N[B]="complete"},E),N[B]="loading"),w.get=v,w.order=function(f,e,h){(function g(a){a=f.shift(),f.length?w(a,g):w(a,e,h)})()},w.path=function(b){H=b},w.ready=function(f,d,h){f=f[D]?f:[f];var g=[];return !x(f,function(b){K[b]||g[D](b)})&&y(f,function(b){return K[b]})?d():!function(b){I[b]=I[b]||[],I[b][D](d),h&&h(g)}(f.join("|")),w},w},this);</script>

<!--[if lt IE 9]>
  <script src="/webjars/html5shiv/3.7.2/html5shiv.min.js" type="text/javascript"></script>
<![endif]-->

<script type="text/javascript">
  $script('/webjars/jquery/1.12.3/jquery.min.js', 'jquery');

  $script.ready('jquery', function() {
    $script('/js/plugins.js?20170317-1336', 'plugins');
    $script('/js/lor.js?20170317-1336', 'lorjs');
  });

  $script('/js/highlight.pack.js', 'hljs', function() { hljs.initHighlightingOnLoad(); });
</script>
<title>OpenMotif 2.3.7 — Open Source — Новости</title>
<meta property="og:title" content="OpenMotif 2.3.7" >

<meta property="og:image" content="https://www.linux.org.ru/img/good-penguin.png">
  <meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@wwwlinuxorgru">
<meta property="og:description" content="Спустя 9 месяцев разработки (предыдущая версия, 2.3.6, была выпущена в июне 2016 года) вышла новая версия библиотеки  OpenMotif . Напомню, что  OpenMotif  -- это одна из старейших библиотек для построения GUI, использующая механизм  X Toolkit Intrins...">
<meta property="og:url" content="https://www.linux.org.ru/news/opensource/13317004">

<link rel="canonical" href="https://www.linux.org.ru/news/opensource/13317004">

<link rel="Previous" id="PrevLink" href="/news/conference/13316162" title="Крупнейшая в мире серия хакатонов AngelHack стартует в Новосибирске 15-16 апреля">
<link rel="Next" id="NextLink" href="/news/conference/13316631" title="Очередная встреча сообщества RuHaskell">
<link rel="alternate" title="Comments RSS" href="/news/opensource/13317004?output=rss" type="application/rss+xml">
<script type="text/javascript">
  $script.ready('lorjs', function() { initNextPrevKeys(); });
  
    $script('/js/realtime.js', "realtime");
    $script.ready('realtime', function() {
        startRealtimeWS(13317004, "/news/opensource/13317004", 13317421, "wss://www.linux.org.ru:9000/");
    });
  </script>
<link rel="search" title="Search L.O.R." href="/search.jsp">
<meta name="referrer" content="always">

<base href="https://www.linux.org.ru/">

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
<meta name="viewport" content="initial-scale=1.0">
</head>
<body>
<div id="hd">
  <a id="sitetitle" href="/">LINUX.ORG.RU</a>

  <div class="menu">
    <div id="loginGreating">
      <div id="regmenu" class="head">
          <a href="https://www.linux.org.ru/register.jsp">Регистрация</a> -
          <a id="loginbutton" href="https://www.linux.org.ru/login.jsp">Вход</a>
        </div>

        <form method=POST action="https://www.linux.org.ru//ajax_login_process" style="display: none" id="regform">
          <input type="hidden" name="csrf" value="L1o4bAOb5bsFkrQPNO0aKQ==">
<label>Имя: <input type=text name=nick size=15 placeholder="nick или email" autocapitalize="off"></label>
          <label>Пароль: <input type=password name=passwd size=15></label>
          <input type=submit value="Вход">
          <input id="hide_loginbutton" type="button" value="Отмена">
        </form>
      </div>

    <ul>
      <li><a href="/news/">Новости</a></li>
      <li><a href="/gallery/">Галерея</a></li>

      <li><a href="/forum/">Форум</a></li>
      <li><a href="/tracker/">Трекер</a></li>
      <li><a href="/search.jsp">Поиск</a></li>
    </ul>
  </div>
</div>
<div style="clear: both"></div>
<div id="bd">
<div class=messages itemscope itemtype="http://schema.org/Article">

<article class=msg id="topic-13317004">
<header>
    <div class="msg-top-header">
    <span itemprop="articleSection">
      <a href="/news/">Новости</a> —
      <a href="/news/opensource/">Open Source</a>
      </span>
      </span>
    </div>

    <h1 itemprop="headline">
      <a href="/news/opensource/13317004">OpenMotif 2.3.7</a>
      </h1>

    <p class="tags"><i class="icon-tag"></i>&nbsp;<a class=tag rel=tag href="/tag/motif">motif</a>, <a class=tag rel=tag href="/tag/x11">x11</a>, <a class=tag rel=tag href="/tag/%D0%B8%D1%81%D1%82%D0%BE%D1%80%D0%B8%D1%8F%20%D1%83%D1%81%D0%BF%D0%B5%D1%85%D0%B0">история успеха</a></p></header>

  <div class="msg-container">

    <div class="fav-buttons">
        <a id="favs_button" href="#"><i class="icon-star"></i></a><br><span
              id="favs_count">0</span><br>
        <a id="memories_button" href="#"><i class="icon-eye"></i></a><br><span
              id="memories_count">1</span>
      </div>
    <div class="msg_body">
  <div itemprop="articleBody">
      <p>Спустя 9 месяцев разработки (предыдущая версия, 2.3.6, была выпущена в июне 2016 года) вышла новая версия библиотеки <i>OpenMotif</i>.</p><p>Напомню, что <i>OpenMotif</i>&nbsp;&mdash; это одна из старейших библиотек для построения GUI, использующая механизм <a href="https://ru.wikipedia.org/wiki/X_Toolkit_Intrinsics">X Toolkit Intrinsics</a>, лежащая в основе сред <a href="https://sourceforge.net/projects/cdesktopenv/">CDE</a>, <a href="https://ru.wikipedia.org/wiki/IRIX_Interactive_Desktop">IRIX Interactive Desktop</a> и <a href="http://5dwm.org/maxxi/screenshots.html">MaXX Desktop</a> и распространяемая по лицензии LGPL 2.1. Наилучшее представление о разнообразии графических компонентов <i>Motif</i> даёт, пожалуй, <a href="http://5dwm.org/shots/periodic.png">вот этот снимок</a>.</p><p><b>Что нового в этой версии:</b></p><p>Официальный файл <span class="code"><code>RELNOTES</span></code> сообщает:
 </p><ul><li> Fixed segmentation faults associated with option menus or other popup windows
 </li></ul><p>
На деле это исправление сводится к одному коммиту (<a href="https://sourceforge.net/p/motif/code/ci/18de86345d5e455b815fe0395d2992b9a2f1195f/">18de86</a>), который откатывает неудачное исправление <a href="http://bugs.motifzone.net/show_bug.cgi?id=1565">бага #1565</a>, который изначально был заведён в <a href="https://bugzilla.redhat.com/show_bug.cgi?id=810435">RHEL</a> и над исправлением которого коллектив <i>OpenMotif</i> работал более пяти лет. Сам баг #1565 помечен как <span class="code"><code>WONTFIX</span></code>.</p><p>
          &gt;&gt;&gt; <a href="https://sourceforge.net/p/motif/code/ci/master/tree/RELNOTES">Подробности</a></p>
      </div>
<footer>

<div class="userpic"><img class="photo" src="/photos/14943:-1860923697.gif" alt="" width=100 height=100 ></div><div class=sign >
  <a rel="author"itemprop="creator" href="/people/Bass/profile">Bass</a> <span class="stars">★</span><br>
  <time datetime="2017-03-28T21:06:22.139+03:00" itemprop="dateCreated">28.03.2017 21:06:22</time><span class="sign_more">
  <br>Проверено: <a  href="/people/Shaman007/profile">Shaman007</a>
        (<time datetime="2017-03-29T01:49:01.125+03:00" itemprop="datePublished">29.03.2017 1:49:01</time>)
      </span>
</div>
</footer>

    <div class=reply>
          <div class="social-buttons">
            <a target="_blank" style="text-decoration: none"
               href="https://twitter.com/intent/tweet?text=OpenMotif+2.3.7&amp;url=https%3A%2F%2Fwww.linux.org.ru%2Fnews%2Fopensource%2F13317004&amp;hashtags=%D0%BB%D0%BE%D1%80">
              <img src="/img/twitter.png" width=16 height=16 alt="Share on Twitter" title="Share on Twitter">
            </a>
          </div>
          <ul id="topicMenu">
          <li><a href="comment-message.jsp?topic=13317004">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>
            <li><a href="/news/opensource/13317004">Ссылка</a></li>
          </ul>
        </div>
      </div>
</div>
</article>

<script type="text/javascript">
  $script.ready('lorjs', function() {
    initStarPopovers();
  });
</script>
<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/conference/13316162" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/conference/13316162" rel=prev>
                Крупнейшая в мире серия хакатонов AngelHack стартует в Новосибирске 15-16 апреля</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
    </div>
    <div class="grid-3-3">
      <table align="right">
          <tr valign=middle align=right>
            <td class="hideon-phone">
              <a href="/news/conference/13316631" rel=next>
                Очередная встреча сообщества RuHaskell</a>
            </td>
            <td align="right" valign="middle" style="padding-left: 5px">
              <a href="/news/conference/13316631" rel=next>→</a>
            </td>
          </tr>
        </table>
      </div>
  </div>
  </div><div class="comment" id="comments" style="padding-top: 0.5em">

<div style="text-align: center; margin-top: 0.5em; margin-bottom: 1em; height: 91px" id="interpage-adv">
  </div>
  <script type="text/javascript">
    $script.ready('lorjs', function () {
      var ads = [
        {
          type: 'img',
          src: '/adv/miran-e3.gif',
          href: 'https://miran.ru/services/dedicated/?utm_source=linux.org.ru&utm_medium=banner&utm_campaign=dedicated'
        }
      ];

      init_interpage_adv(ads);
    });
  </script>

<article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13317040" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/50207:1211644613.jpg" width="130" height="140"></div><div class="msg_body message-w-userpic"><blockquote><p>На деле это исправление сводится к одному коммиту</p></blockquote><p>Вот это релиз так релиз, вот это я понимаю.</p><div class="sign"><a itemprop="creator" href="/people/unfo/profile">unfo</a> <span class="stars">★★★★★</span> (<time datetime="2017-03-28T21:23:14.545+03:00" itemprop="commentTime">28.03.2017 21:23:14</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13317004&amp;replyto=13317040">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13317004?cid=13317040">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13317089" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/opensource/13317004?cid=13317040">комментарий</a> от unfo <time datetime="2017-03-28T21:23:14.545+03:00" itemprop="false">28.03.2017 21:23:14</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/14943:-1860923697.gif" width="100" height="100"></div><div class="msg_body message-w-userpic"><p>Да, мне с трудом удалось (я надеюсь) сохранить тон новости нейтральным. Но в процессе написания я неприлично ржал.</p><div class="sign"><a itemprop="creator" href="/people/Bass/profile">Bass</a> <span class="stars">★</span> (<time datetime="2017-03-28T21:42:31.152+03:00" itemprop="commentTime">28.03.2017 21:42:31</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13317004&amp;replyto=13317089">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13317004?cid=13317089">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13317418" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/63534:-950002687.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><h2>t</h2><p>Мог бы Motif в современные HiDPI-дисплеи, и Qt можно было бы смело закапывать.</p><div class="sign"><a itemprop="creator" href="/people/EXL/profile">EXL</a> <span class="stars">★★★★</span> (<time datetime="2017-03-29T02:09:18.216+03:00" itemprop="commentTime">29.03.2017 2:09:18</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13317004&amp;replyto=13317418">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13317004?cid=13317418">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13317421" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/116628:-1638857743.png" width="150" height="102"></div><div class="msg_body message-w-userpic"><p>Скажите, а программисты, использующие Motif для создания интерфейсов всё так же кончают жизнь самоубийством сразу после релиза?</p><div class="sign"><a itemprop="creator" href="/people/hateyoufeel/profile">hateyoufeel</a> <span class="stars">★★★</span> (<time datetime="2017-03-29T02:12:35.253+03:00" itemprop="commentTime">29.03.2017 2:12:35</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13317004&amp;replyto=13317421">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13317004?cid=13317421">Ссылка</a></li></ul></div></div></div></article></div>

<div id="realtime" style="display: none"></div>

<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/conference/13316162" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/conference/13316162" rel=prev>
                Крупнейшая в мире серия хакатонов AngelHack стартует в Новосибирске 15-16 апреля</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
      <a title="Новости - Open Source"
         href="/news/opensource/">
          Open Source</a>
    </div>
    <div class="grid-3-3">
      <table align="right">
          <tr valign=middle align=right>
            <td class="hideon-phone">
              <a href="/news/conference/13316631" rel=next>
                Очередная встреча сообщества RuHaskell</a>
            </td>
            <td align="right" valign="middle" style="padding-left: 5px">
              <a href="/news/conference/13316631" rel=next>→</a>
            </td>
          </tr>
        </table>
      </div>
  </div>
  </div></div>

<section id="related-topics">
    <h2>Похожие темы</h2>

    <div id="related-topics-list">
      <ul>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/development/12205416">XmStringGenerate() в режиме XmMULTIBYTE_TEXT или XmWIDECHAR_TEXT</a> (2015)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/desktop/2857754">openMotif темы</a> (2008)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/general/798479">openMotif-2.2.3 ?</a> (2005)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/linux-general/5574">Linux 2.3.7</a> (1999)
            </li>
          <li>
              <span class="group-label">Галерея</span>
              <a href="/gallery/screenshots/1176686">Живой OpenMotif.</a> (2005)
            </li>
          </ul>
      <ul>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/general/1499">PPP-2.3.7</a> (1999)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/proprietary/8072029">CDE открыли под LGPL</a> (2012)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/general/2059">ppp-2.3.7</a> (1999)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/desktop/857651">Замена mwm из openmotif</a> (2005)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/development/119758">Документация по openMotif</a> (2001)
            </li>
          </ul>
      </div>
  </section>
</div>
<footer id="ft">

<p id="ft-info">
  <a href="/about">О Сервере</a> -
  <a href="/help/rules.md">Правила форума</a> -
  <a href="/help/lorcode.md">Правила разметки</a><br>
  <a href="https://www.linux.org.ru/">https://www.linux.org.ru/</a>
</p>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-2184304-1']);
  _gaq.push(['_setCustomVar', 1, 'Authorized', 'false']);
  _gaq.push(['_setCustomVar', 2, 'Style', 'tango']);
  _gaq.push(['_setSiteSpeedSampleRate', 10]);
  _gaq.push(['_gat._forceSSL']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = 'https://ssl.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

</footer>
</body></html>
