LINUX.ORG.RU

RetroShare 0.6.2

 


2

4

Доступен релиз RetroShare 0.6.2 — платформы для конфиденциального обмена файлами и сообщениями при помощи шифрованной F2F-сети. В данной разновидности одноранговых сетей пользователи устанавливают прямые соединения только с доверенными пирами. Сборки подготовлены для Windows, FreeBSD и многих дистрибутивов GNU/Linux. Исходный код RetroShare написан на языке C++ с использованием тулкита Qt и распространяется под лицензией GPLv2+.

Основные изменения:

  • Реализовано сквозное шифрование файлообмена при использовании анонимных туннелей.
  • Полностью переработана система кэширования файлов и распространения списков файлов.
  • Улучшен интерфейс, в т. ч. появилась возможность выбрать срок хранения сообщений в форумах.
  • Переработана система репутаций, реализованная в прошлой версии.
  • Обеспечена поддержка OpenSSL 1.1.0.
  • Устранено множество утечек памяти, потребление ОЗУ сократилось в 1,5-2 раза.
  • Временно приостановлено формирование сборок для macOS (пока не будет найден новый сопровождающий).

Из планов отмечается переработка и унификация системы обмена сообщениями, доработка веб-интерфейса в рамках GSoC2017, выпуск клиента для Android, добавление возможности редактировать свои сообщения на форумах, реализация поддержки IPv6.

>>> Подробности

★★

Проверено: Shaman007 ()

Смотрел я на эту ретрошару. Хрень какая-то. Интерфейс не удобный, скорость скачивания файлов маленькая(пока в друзья полстраны не добавишь вообще ничего не скачать). В общем к сожалению как всегда не нужно.

Rodegast ★★★★ ()
Ответ на: комментарий от Rodegast

Если нужен файлообменник, пользуйся скайпом.

Quasar ★★★★★ ()

Обеспечена поддержка OpenSSL 1.1.0.

димква, привет

к сожалению нужно ещё чтобы sqlcipher обновился, иначе у мну не собирается :(

anonymous ()
Ответ на: комментарий от Rodegast

Он просто со своими особенностями. На любителя.

th3m3 ★★★★ ()

Для параноиков и Сноудена самое то. Пару лет назад мне там предлагали свергнуть правительство…

KOT040188 ()
Ответ на: комментарий от KOT040188

В свете последних событий, паранойя становятся всё более привлекательной

anonymous ()
Ответ на: комментарий от anonymous

к сожалению нужно ещё чтобы sqlcipher обновился, иначе у мну не собирается :(

В release notes сказано, что это только на Debian GNU/Linux.

xdimquax ★★ ()
Ответ на: комментарий от xdimquax

Так ретра не просто p2p, оно f2f — каждый пир вручную добавлять. А это очень сильно сужает область использования.

sand_circle ()
Последнее исправление: sand_circle (всего исправлений: 1)
Ответ на: комментарий от sand_circle

Да там все всех в друзья добавляют, только кинь сертификат, исключения бывают только среди пользователей tor. Уж не знаю, какая там была изначальная идея, но получились всеобщие обнимашки-целовашки.

Памяти действительно стало потреблять вдвое меньше.

abraziv_whiskey ★★★★★ ()
Ответ на: комментарий от abraziv_whiskey

Уж не знаю, какая там была изначальная идея,

Что пользователи будут строить сеть только из доверенных контактов.

но получились всеобщие обнимашки-целовашки.

После того, как в 0.6 добавили поддержку анонимных личностей и Tor/I2P, подобная гигиена перестала быть столь актуальной, т.к. появилась возможность писать везде из под анонимной личности.

xdimquax ★★ ()
Последнее исправление: xdimquax (всего исправлений: 1)
Ответ на: комментарий от reedych

Уже готовлю слакбилд.

Поделись уж, как приготовишь. Чем не подошел слакбилд с SBo?

darkpony ()
Ответ на: комментарий от darkpony

На SBo старый, а я не мейнтейнер. Летом как будет не лень, попрошусь заместо него (ему на него пофигу). Скачай пока слакбилд отсюда: https://github.com/Reedych/slackbuilds

Нужные исходники скачивать через wget -i slack-link

Чуть не забыл, NOGUI=yes, если нужен

reedych ()

с использованием тулкита Qt

Дальше не читал.

entefeed ()
Ответ на: комментарий от reedych

На SBo старый

Ну, различия между твоим и SBo-шным файлом там минимальны... Да и версия на SBo не такая уж и старая - 0.6.1
Больше интересует такая строчка:

#rm -rf plugins

Так почему собираем (или не собираем) плагины? На SBo есть пометка: Plugins no longer build and so are disabled.

darkpony ()
Ответ на: комментарий от xdimquax

В release notes сказано, что это только на Debian GNU/Linux.

это не только на Дебиан, в самом git sqlcipher ещё нет фикса для openssl-1.1.0. а кирила я просил об апгрейде на новый ссл ещё месяц назад. ну вобщем ждём свеженький sqlcipher.. и да, бомбу там готовьте :D

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.