LINUX.ORG.RU

Первый выпуск LEDE — форка OpenWrt

 , , ,


4

4

Спустя 9 месяцев после того, как восемь наиболее активных разработчиков OpenWrt покинули проект и начали работу над созданием форка, получившего название LEDE (Linux Embedded Development Environment), состоялся первый стабильный выпуск.

Основные изменения:

  • Ядро Linux обновлено с версии 3.18 до 4.4.50
  • Обновлено основное ПО:
    • dnsmasq до 2.76
    • busybox до 1.25.1
    • polarssl 1.3.14 заменён на mbedtls 2.4.0
    • openssl до 1.0.2k
  • Усилена безопасность:
    • Для проверки целостности исходного кода пакетов вместо MD5 теперь используется SHA256
    • mbedtls: отключена поддержка SSLv3
    • OpenSSL: отключены сжатие, печально известное расширение Heartbeat, NPN, Whirlpool и J-PAKE
    • Усилена защита от атак, связанных с повреждением памяти:
      • в GCC используются опции -Wformat и -Wformat-security
      • защита от переполнения стека в пространстве пользователя
      • защита от переполнения стека в пространстве ядра
      • определение переполнения буфера (FORTIFY_SOURCE)
      • защита RELRO
  • Улучшена поддержка сети:
    • Smart Queue Management (SQM) уменьшает влияние промежуточной буферизации пакетов (bufferbloat). К сожалению, в релиз не вошло ядро 4.9, где была проведена ещё большая работа в этом направлении
    • Промежуточная буферизация также снижена на чипсетах ath9k,mt76 и некоторых чипсетах ath10k
    • Драйвер ath9k переведён на использование планировщика Airtime, что существенно уменьшило эфирное время, занимаемое медленными устройствами
    • Повышена стабильность работы беспроводного стека в общем, и драйвера ath9k в частности
    • Для чипсета ath10k-ct опционально доступен альтернативный драйвер от Candela-Tech
    • Улучшена защищённость IPv6
  • Обновлён тулчейн:
    • musl 1.1.16
    • gcc 5.4.0
    • binutils 2.25.1
  • Платформы и драйверы:
    • Lantiq:
      • добавлена прошивка DSL
      • обновлены драйверы DSL phy
    • Новые платформы:
      • apm821xx (AppliedMicro APM821xx)
      • arc770 (Synopsys DesignWare ARC 770D)
      • archs38 (Synopsys DesignWare ARC HS38)
      • armvirt (QEMU ARM Virtual Machine)
      • ipq806x (Qualcomm Atheros IPQ806X)
      • layerscape (NXP Layerscape)
      • zynq (Xilinx Zynq 7000)
    • Реорганизована платформа x86:
      • платформа Xen DomU объединена с платформой x86/generic
      • реализована поддержка ускорения инструкций AES-NI
    • Удалена поддержка платформ:
      • realview (заменена на armvirt)
      • ppc44x (код был неработоспособен)
      • netlogic (из-за отсутствия оборудования)
  • Улучшена сборочная система:
    • Базовая система отделена от пакетов, поддерживаемых сообществом. Это упрощает распространение бинарных обновлений
    • Исправлена и улучшена обработка зависимостей пакетов
    • Для каждого устройства теперь формируются отдельные образы rootfs, что позволяет индивидуально выбирать пакеты для профилей устройств
    • Переписан код сборки образов, что позволило снизить затраты времени на компиляцию и упростить определение профилей устройств
    • В Makefile добавили новые команды для запуска серий стандартных диагностических наборов.
    • Исходники теперь могут быть загружены с помощью сurl
    • Тарболы с исходным кодом теперь воспроизводимы
  • Image Builder / SDK
    • Переработана сборка библиотек (для лучшей переносимости между разными дистрибутивами Linux)
    • Реализована возможность сборки модулей ядра, используя SDK
  • Добавлена поддержка множества новых роутеров и плат

>>> Подробности

anonymous

Проверено: Klymedy ()

Ох уж этот опенсорс, чуть что - форк.

GblGbl ★★★★★ ()
Ответ на: комментарий от GblGbl

Форк был необходим, поскольку, насколько я понимаю, договориться о решении проблем мирным обсуждением не получилось. Сейчас уже обсуждают вопрос о слиянии проектов обратно, но пока решение не принято.

Что касается сабжа: пишут, что можно апгрейдиться из OpenWrt с сохранением настроек. Но лично мне спокойнее поставить начисто. Полёт уже 2 суток нормальный. Апгрейдился потому, что в стабильной OpenWrt нет некоторых нужных мне пакетов (например, adblock).

anonymous ()
Ответ на: комментарий от GblGbl

В этом вся суть, нужность и польза. Когда форкнут lor-source? достали уже мейнтейнеры!

Valman_new ()

Интересно. А есть список поддерживаемого оборудования?

SjZ ★★★★★ ()

Интересно, надо будет затестить, а то OpenWRT в последнее время начинает выносить мозг. Хотя может это провайдер.

flappyright ()

форка
покинули проект

Слишком много антагонизма, которого, КМК, в реальности нет.

asaw ★★★★★ ()
Ответ на: комментарий от anonymous

Сейчас уже обсуждают вопрос о слиянии проектов обратно, но пока решение не принято.

Надеюсь это обратное слияние останется проектом LEDE. Пользуюсь почти год, объективно лучше. Везде где раньше ставил OpenWRT - перепрошил на LEDE. Пусть и дальше развиваются под этим брэндом и кодовой базой.

anonymous ()
Ответ на: комментарий от GblGbl

Ох уж этот опенсорс, чуть что - форк.

Ох уж эти гнилые комментаторы с ЛОРа, чуть что - высер.

Такое ощущение, что стена улучшений, описанная в новости, прошла мимо тебя. Такие как ты заходят только чтоб просраться, видимо потому что обычным способом (в сортире по утрам) не получается, а погадить на ЛОРе - словно слабительное, да? После него уже и в обычном сортире можно.

anonymous ()

А как в netgearе посмотреть какая версия у меня? v1 или v2? В списке LEDE поддерживаемых железок рядом с моим роутером стоит «v2» - это что?

anonymous ()

LEDE

Почудилось, будто портянка об очередном DE(Desktop Environment)..

Horse ()
Ответ на: комментарий от anonymous

Иногда по штрих-коду можно понять, а вообще смотри по начинке. Этим D-Link обычно грешит по-моему, что не роутер, так 100500 версий, из которых половина не умеет в альтернативные прошивки.

xdimquax ★★ ()
Ответ на: комментарий от xdimquax

Хе, в админке посмотрел - моя версия в таблице. Это значит я смогу без проблем накатить себе LEDE, и гарантированно ничего не сломаю? Или есть маленький шанс превратиться в кирпич?

anonymous ()

Народ!

Вот в таблице LEDE списки моделей роутеров. Там колонка CPU.

Как вообще можно узнать какой CPU в твоем роутере? Есть такая команда в Linux, чтоб пробить начинку роутера?

anonymous ()

Лучше бы musl на mips64 запилили.

CYB3R ★★★★★ ()
Ответ на: комментарий от CYB3R

musl

Не слышал.

mips64

Не слышал.

А вот про OpenWRT слышали все. И роутерами пользуются все.

anonymous ()
Ответ на: комментарий от anonymous

OpenWrt использует именно musl. На всех платформах, кроме mips64. А mips64 обещает быть относительно популярной платформой для роутеров, которыми пользуются все.

CYB3R ★★★★★ ()

И как понимать этот пздц?

https://lede-project.org/toh/views/toh_fwdownload

Заявлена поддержка:

Netgear / WNR1000 / v2

Смотрим минимальные требования:

https://lede-project.org/docs/guide-quick-start/start

Your router has at least 8 MBytes of Flash and 64 MBytes of RAM

А затем сюда:

https://wiki.openwrt.org/toh/netgear/wnr1000

v2 / v2C / Atheros AR7240 400 MHz / 32 MiB / 4 MiB

ЗБС да? Flash и RAM в 2 раза меньше минимального необходимого, но мамой клянус все заработает, Ашот гарантирует LEDE выкатывает билд для прошивки роутера.

anonymous ()
Ответ на: комментарий от xdimquax

этим грешат все. что тплинк (741 уже 9-й ревизии, и от первой отличается всем; не говоря уже о том что 8 и 9 - на одном и том же чипе но разная нумерация портов и т.п.), что асус (rt-n12e - есть и на богомерзких реалтеках, и на ралинках - 1:1 rt-n12+, отличий не найдено; аналогично rt-g32 - 3 ревизии, причем С1 - копия rt-n10, а стоит дешевле), что длинк (там вообще 100500 ревизий, на разных платформах, в одной и той же модели).

NiTr0 ★★★★★ ()
Ответ на: комментарий от anonymous

а если прочитать чуть дальше, то можно с удивлением для себя узнать:

Routers with 4 MBytes (or less) of Flash work, but usually require a firmware rebuild to include any additional packages you need.

NiTr0 ★★★★★ ()
Ответ на: комментарий от NiTr0

И что это значит? И что насчет рамы? Ее тоже в 2 раза меньше.

anonymous ()
Ответ на: комментарий от anonymous

то и значит - дополнительные пакеты ставить некуда. как собссно и в openwrt (на 14.хх на девайсах с 4мб флэш f2fs килобайт на 300-500).

а на раму - пофиг. нет софта чтобы ее загрузить (потому что его некуда записать).

всяко лучше будет работать, чем корявая поделка от вендора.

NiTr0 ★★★★★ ()
Последнее исправление: NiTr0 (всего исправлений: 1)

Ну вот одна из проблем опенсорса, сразу делать форк. Силы сообщества распыляются на кучу форков и в итоге имеем кучу недоработанных альтернатив одному единственному проприетарному *product_name*.

karton1 ★★★ ()
Ответ на: комментарий от NiTr0

Я тебя не понимаю. Что такое дополнительные пакеты? Это какие? Что за софт, который надо грузить, и почему на раму пофиг?

всяко лучше будет работать, чем корявая поделка от вендора.

Может и будет, но если в минимальные требования не вписывается, то где гарантия что оно вообще поставится (а не станет кирпичом), и что не будет постоянно лагать инет?

anonymous ()
Ответ на: комментарий от anonymous

нет некоторых нужных мне пакетов

Всё равно приходится некоторые пакеты пересобирать, так что... Я так mediatomb собирал.

Shadow ★★★★★ ()
Ответ на: комментарий от anonymous

RAM в 2 раза меньше минимального необходимого

На 32MiB ОЗУ и 4 MiB флеша тоже будет работать, но не очень. Между прочим, у популярного ранее D-Link DIR-320 именно столько и ничего, правда с LuCi еле ворочается.

xdimquax ★★ ()
Ответ на: комментарий от NiTr0

всяко лучше будет работать, чем корявая поделка от вендора.

Во-во, более менее приличные прошивки разве что у Mikrotik-ов.

xdimquax ★★ ()
Ответ на: комментарий от anonymous

8 rom и больше нужно для всяких usb пакетов, ipsec, vpn и т. п.

Больше 32 ram для них же + разные драйвера (WiFi тот же) могут неплохо потреблять.

Кроме того, в роутерах с 4ROM/32RAM обычно ставят дохлый проц (аля MIPS на 400-600 МГц). Чтобы он совсем не загнулся используются аппаратные/софтварные ускорялки роутинга/ната/форвардинга для unicast/multicast трафика. В основной ветке OpenWrt/Lede их нет, потому что суть их сводится к многочисленным хакам в ядре + порождает множество ограничений (и потенциальных багов). Как итог - производительность такого роутера с WRT будет хуже, чем на оригинальной прошивке (хотя нельзя недооценивать ущербность некоторых прошивок).

anonymous ()
Ответ на: комментарий от karton1

это не баг, а фича

они, как правило, прекрасно мержатся
и если ты зайдешь на гитхаб и захочешь «привнести» в какойнть проект - то, внимание, тебе нужно его ФОРКНУТЬ
потом ты делаешь в своей копии правки и отсылаешь PR в основной проект

и да, в основном проекте счетчик форков вырос на 1

anTaRes ★★★★ ()
Ответ на: комментарий от CYB3R

Когда доберемся до 666, тогда и начнем разговор о переходе на EULA.

Valman_new ()
Ответ на: комментарий от anTaRes

Ну главное тогда, что бы разработчики форка не окукливались, а общались с разработчиками. Бывает что форки делают по принципу «я сделаю свой *name*, с гитхабом и комментариями, авторы не нужны».

karton1 ★★★ ()
Ответ на: комментарий от anonymous

Я тебя не понимаю. Что такое дополнительные пакеты? Это какие? Что за софт, который надо грузить, и почему на раму пофиг?

ознакомьтесь для начала, что такое *wrt и чем оно отличается от вендороблобов. тогда может и поймете что-то...

NiTr0 ★★★★★ ()
Ответ на: комментарий от anonymous

Что касается сабжа: пишут, что можно апгрейдиться из OpenWrt с сохранением настроек.

Подтверждаю! У меня был OpenWRT 14.хх на TP-Link WDR4300. Сделал sysupgrade, работает как часы.

Irben ★★ ()
Ответ на: комментарий от anonymous

400-600МГц мипсы стоят во всех железках. и только в очень крутых - двухголовые.

у атеросов аппаратных оффлоадов нет вообще (вернее, есть в отдельном свиччипе, который порой ставится в гигабитные модели типа тплинков 1043).

в опенврт оффлоадов нет совсем не потому, что они корявые/глючные (они вполне себе стабильно работают, если допилить). там скорее паранойя насчет лицензионной чистоты (настолько, что изобрели свой ethernet драйвер для ралинка, хотя тот что шел в сдк - поставлялся под гпл).

девайсы с 32 рамы идут типово с сдрам (реже - ддр1) памятью. и там из-за мелкого кеша (8-16кб) на производительность сильно влияет размер структур ядра. которые за последние пяток лет таки разжирели.

NiTr0 ★★★★★ ()
Ответ на: комментарий от xdimquax

чего же, зухели тоже вполне себе умеют пилить.

но у остальных - глюки, висы и утечки памяти.

NiTr0 ★★★★★ ()
Ответ на: комментарий от GblGbl

Ох уж этот опенсорс, чуть что - форк.

Вам не понять.

anonymous ()

Установил на wr842nd полет нормальный, настройка быстрая и легкая.

sniper21 ★★★★★ ()

Кстати насчёт системных требований. У меня сейчас TP-Link 4мб/32мб с OpenWrt и LuCi. В то же время LEDE требует минимум 8мб/64мб, а про меньшую память написано, что LuCi поставить будет нельзя. Это значит что он разжирел относительно OpenWrt или просто врут?

andreymal ()
Ответ на: комментарий от andreymal

У меня wr-841nd, стандарт поставляется с luci. Но я пересобрал без luci и некоторых других штук, потому что иначе wireguard не влезает

derlafff ★★★★★ ()
Ответ на: комментарий от xdimquax

На 32MiB ОЗУ ... тоже будет работать, но не очень.

На TL-WR1043ND v1 работает изумительно, несмотря на 32 мегабайта оперативки. Держит 30-мегабитный канал, приватную и публичную WiFi-сети, шейпинг трафика, DNSCrypt, блокировку рекламных хостов.

anonymous ()

Для тех, кто столкнётся с этим:

The available memory on devices with 32MB RAM might be too low to reliably run opkg or sysupgrade operations, especially in conjunction with LuCI

Да, при попытке установки любого пакета вылезает ошибка о нехватке оперативки. Достаточно в списке реп (через веб-морду или правку файла /etc/opkg/distfeeds.conf) временно закомментировать ненужные и обновить список пакетов. Мне хватило закомментировать репу reboot_telephony.

anonymous ()
Ответ на: комментарий от NiTr0

в опенврт оффлоадов нет совсем не потому, что они корявые/глючные

Я где-то читал обратное, что поддержка этих оффлоадов сделана через адовые костыли, а девелоперы OpenWrt не хотят пускать к себе такое говно.

anonymous ()
Ответ на: комментарий от anonymous

8 rom и больше нужно для всяких usb пакетов, ipsec, vpn и т. п.

Если в роутере есть USB-порт, то проблема легко решается выносом overlay на флешку - extroot.

anonymous ()
Ответ на: комментарий от anonymous

Обновился с сохранением настроек. Перед этим на всякий случай забэкапил настройки. Однако апдейт прошёл гладко, всё работает как надо, и о бэкапе настроек впоминать не пришлось. Мало того, по субъективым впечатлениям на моём TP-LINK эта прошивка ещё и работает более стабильно, чем OpenWRT 15.0.2.

lucentcode ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.