LINUX.ORG.RU

pgAdmin 4 v1.0

 


1

1

После более 10 000 часов разработки, стала доступна для загрузки новая версия pgAdmin 4 v1.0.

pgAdmin 4 — это полностью переписанный на Python и Javascript/jQuery pgAdmin. Доступен вариант для десктопной среды, написанный на C++ и Qt, для автономного пользования отдельными пользователями, и веб-приложение, которое можно использовать через браузер. По сравнению с pgAdmin 3, pgAdmin 4 значительно ушёл вперёд в плане визуальной составляющей, удобстве развёртывания и установки, богатства приборных панелей и более современного дизайна.

>>> Скриншоты, анонс, ссылки на загрузку

★★★★★

Проверено: Klymedy ()

Очередная программа перешла c GTK на Qt.

anonymous ()

Погодите, это теперь чо, писанная на твиттер бутстрапе вебня, которая работает под апачем, а десктопный клиент это она же, но под QT браузером?

emcode ()
Ответ на: комментарий от anonymous

Увы, никто на QT не переходил. Теперь сабж стрёмное говно в стиле PhpMyAdmin.

emcode ()
Ответ на: комментарий от emcode

Вам пользоваться или ныть о том, что внутри?

Deleted ()

pgAdmin 4 — это полностью переписанный на Python и Javascript/jQuery pgAdmin

Requiescat in pace.

dexpl ★★★★★ ()

Пока там чего-то очень интересного не появится, смысла использовать вместо pgadmin3, нет. Ну и нет pgadmin4 пока в репозитории pg, тем более.

anonymous_sama ★★★★★ ()

Продолжу пользоваться pgAdmin 3. А так лучше помогли бы adminer пилить, чем свой сабж

CrazyAlex25 ★★ ()
Ответ на: комментарий от CrazyAlex25

Чем ты продолжишь пользоваться чудик? ))) pgAdmin 3 не поддерживает новую версию 9.6 и никогда не будет поддерживать...

tumbler ()

pgAdmin 4 — это полностью переписанный на Python и Javascript/jQuery pgAdmin.

хм. что-то уже страшно.

samy_volosaty ★★★★★ ()
Ответ на: комментарий от anonymous

pgAdmin3 был на wxWidgets. GTK использовался, если в системе порт wxGTK стоял для wxWidgets.

xxblx ★★★ ()
Ответ на: комментарий от tumbler

Я недавно только на 9.5.4 перешел )) Так что до 9.6 как до звёзд... К тому же для себя не увидел новых плюшек (от БД мне нужно только индексируемое хранилище)

CrazyAlex25 ★★ ()
Ответ на: комментарий от xxblx

GTK использовался, если в системе порт wxGTK стоял для wxWidgets.

А ничего другого хоть сколько-нибудь юзабельного и нет. Порты под X11, Motif и Qt присутствуют чисто формально и фейлятся даже на простых примерах.

anonymous ()

Тянет вагон питоновского гавна по зависимостям:

Babel==1.3
beautifulsoup4==4.4.1
blinker==1.3
click==6.6
django-htmlmin==0.8.0
extras==0.0.3
fixtures==2.0.0
Flask==0.11.1
Flask-Babel==0.11.1
Flask-Gravatar==0.4.2
Flask-Login==0.3.2
Flask-Mail==0.9.1
Flask-Principal==0.4.0
Flask-Security==1.7.5
Flask-SQLAlchemy==2.1
Flask-WTF==0.12
html5lib==1.0b3
itsdangerous==0.24
Jinja2==2.7.3
linecache2==1.0.0
MarkupSafe==0.23
passlib==1.6.2
pbr==1.9.1
psycopg2==2.6.2
pycrypto==2.6.1
pyrsistent==0.11.13
python-dateutil==2.5.0
python-mimeparse==1.5.1
pytz==2014.10
simplejson==3.6.5
six==1.9.0
speaklater==1.3
SQLAlchemy==1.0.14
testscenarios==0.5.0
testtools==2.0.0
traceback2==1.4.0
unittest2==1.1.0
Werkzeug==0.9.6
WTForms==2.0.2
sqlparse==0.1.19
Нафигнужно.

lystor ★★ ()
Ответ на: комментарий от AEP

И зачем эта вся радость мне на workstation, если раньше было только wxwidgets по зависимостям?

lystor ★★ ()
Ответ на: комментарий от anonymous

Очередная программа перешла c GTK на Qt.

В вот и нихрена! Она перешла на броузер типа phpmyadmin.

Rodegast ★★★★★ ()
Ответ на: комментарий от Rodegast

Она перешла на броузер типа phpmyadmin.

все рано или поздно перейдет на броузер

kto_tama ★★★★★ ()
Ответ на: комментарий от kto_tama

все рано или поздно перейдет на броузер

Ну тебя на х...

Rodegast ★★★★★ ()
Ответ на: комментарий от anonymous

Это понятно. Я к тому, что pgAdmin - кросс-платформенное ПО, кроме линукса оно под виндой и под макос используется активно, где явно не wxGTK используется. По этому едва ли переход с wxWidgets конкретно в данном случае можно засчитать за «целенаправленный уход с GTK». Скорее все-таки целенаправленный уход в веб, а GTK/Qt/что-то еще тут не при чем.

xxblx ★★★ ()
Последнее исправление: xxblx (всего исправлений: 1)

Кто-нибудь уже начал использовать в работе эту версию?

anonymous ()

Ух ты! Красота! Не ожидал! Попробуем!

GladAlex ★★★★★ ()

Выглядит неплохо для веб-приложения.

tailgunner ★★★★★ ()

v1.0

Автокомплит хоть довели до ума? Или просто пришло время менять циферки?

anonymous ()
Ответ на: комментарий от Deleted

Одно вообще-то очень часто связано с другим (например, Oracle Enterprise manager до сих пор пользуем стандалоно-жабовый, ну вот удобнее, чем веб-гуя (не говоря уж о вмваре-клиенте)).

spqr ★★ ()

А ребяты молодцы - в репе для Fedora 23 лежит django-htmlmin для Python 3.4, а сам pgAdmin написан на втором питоне.

kernelpanic ★★★★★ ()
Ответ на: комментарий от lystor

аналогичный вопрос нахрен тебе posgtresql server на workstation?

BigAlex ★★★ ()
Ответ на: комментарий от BigAlex

аналогичный вопрос нахрен тебе posgtresql server на workstation?

Пичалька, если ты не знаешь, что pgadmin умеет к удаленным серверам подключаться.

lystor ★★ ()

У кого-нибудь эта «поделка на коленке» на RHEL7 без сбоев заработала?

anonymous ()
Ответ на: комментарий от Deleted

Вам пользоваться или ныть о том, что внутри?

Мне пользоваться на десктопе. Соот. я хочу вменяемый десктопный UI, а веб-интерфейс пока еще нормально имитировать UI декстоп приложений не научился.

emcode ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.