LINUX.ORG.RU

Релиз Awesome 3.5.6

 , ,


0

2

Вышел релиз оконного менеджера Awesome, версии 3.5.6, с названием «For Those About To Rock». Произведено 24 изменения. Основные изменения:

  • Оптимизированно использование скрытых элементов
  • Добавлена возможность получать данные от других layout, что позволяет делать скриншоты, использовать Alt+Tab для других тегов
  • Удалены неиспользуемые элементы (rounded_corners)
  • Добавлено управление в меню в стиле vim
  • Исправлено мерцание черным при закрытии окон
  • Переписана функция set_image() для awful.widget.button
  • Регистрация/перерегистрация systray производится при необходимости
  • Исправлено выравнивание в systray
  • Добавлена функция find_widgets()
  • Menubar теперь проверяет все стандартные каталоги

>>> Страница загрузки



Проверено: Shaman007 ()

Menubar теперь, проверяет
Проверено: Shaman007

fmdw ()
Ответ на: комментарий от makoven

Шоткаты в русской раскладке так и не починили?

а они были поломаны? В 3.5.5 работает ок (например Mod4+ш вместо 'i', и Mod4+ф вместо 'a').

redhat ()
Ответ на: комментарий от makoven

Нет, уже не в первый раз натыкаюсь на проблемы осома конкретно в арче, недавно читал issue арчевода в репе atom, что у него не запускается из mod4+r программа из /usr/bin/* - хотя с терминала всё ок.

Может там у вас какой-то лапоть его собирает со своими чудо-патчами?

Ну а вообще, когда-то была проблема с кириллицей (на раскладках, отличных от en_US нельзя было кликнуть по таскам, табы просто не кликабельны были. Лечилось откатом xkbcomp до версий меньше 1.2.4. Но я не помню, влияло ли это на шоткаты.

redhat ()
Ответ на: комментарий от redhat

Посмотрим, может в этой версии на девственном конфиге все заработает)

makoven ★★★★★ ()
Ответ на: комментарий от redhat

Ну а вообще, когда-то была проблема с кириллицей (на раскладках, отличных от en_US нельзя было кликнуть по таскам, табы просто не кликабельны были.

В арче так и осталось до сих пор.

Anarchist ()

Спасибо за новость, я пошел пересобирать свою 9999-версию. Кстати, кому нужен свежий 9999, подрубите оверлей.

DeadEye ★★★★★ ()

Дистровотч подсказывает, что в Debian Jessie всё ещё будет 3.4.15, так что дёргаться мне нет смысла, если только не буду собирать руками?

Вообще, в осоме ветки 3.5 есть что-то принципиально интересное, кроме того, что (опять-таки судя по рассказам) сломали совместимость по конфигам?

hobbit ★★★★★ ()
Ответ на: комментарий от hobbit

Не нужны костыли типа oocairo, например. Больше библиотек. Виджеты типа скроллов.

DeadEye ★★★★★ ()
Ответ на: комментарий от hobbit

большинство либ и виджетостроителей перебрались (уже давненько) на 3.5.*; если говорить о дефолте, то теперь нормально работает композитинг (если он есть), принципиально интересного в 3.5 не появилось (если использовать дефолт).

redhat ()
Ответ на: комментарий от redhat

большинство либ и виджетостроителей перебрались (уже давненько) на 3.5.*

Вот это, кстати, может оказаться принципиальным, если понадобится какая-нть новая библиотека, спасибо.

hobbit ★★★★★ ()
Ответ на: комментарий от redhat

так третья цифра только поменялась — ничего кроме багфиксов и не должно было появиться-то

actionless ★★★★★ ()
raddyomin % awesome --version
awesome v3.5.6-1-g635223b (For Those About To Rock)
 • Build: Jan 11 2015 15:54:05 for x86_64 by gcc version 4.9.2 (@gentoo-td-work)
 • Compiled against Lua 5.1.5 (running with Lua 5.1)
 • D-Bus support: ✔

:3

DeadEye ★★★★★ ()

Хорошая новость. Осом стал еще лучше

sehellion ★★★★★ ()
Ответ на: комментарий от NeverLoved

Откати xkbcomp до предыдущего минора и всё починится.

Спасибо! Тоже был этот баг. Только откатывать надо до 1.2.3. В арче сейчас 1.3.0, предыдущая 1.2.4

Psych218 ★★★★★ ()

Обновился. Косяки с русской раскладкой на месте

makoven ★★★★★ ()
Ответ на: комментарий от Psych218

Да, ты прав, действительно 1.2.3.
Я просто замаскировал всё, что >1.2.3, и не увидел что уже 1.3 появилась.

NeverLoved ★★★★★ ()
Ответ на: комментарий от redhat

Понятия не имею, в чём твоя проблема, но заверяю, что у меня всё работало и на арче, и на генте, пока сидел на awesome.

Deleted ()
Ответ на: комментарий от endeneu13

Вон даже как. Спасибо! Правда сработало.

xkbcomp $DISPLAY - | egrep -v "group . = AltGr;" | xkbcomp - $DISPLAY
чинит сразу же, даже без перезапуска иксов. Прописал в .xinitrc себе, доволен.

Psych218 ★★★★★ ()

Не могу свернуть единственное окно на тэге

После обновы перестал работать как надо шорткат для сворачивания активного окна. Если на тэге развернуто несколько окон, то сворачиваются по одному - все в порядке, но, как только остается одно последнее, экран моргает, а окно остается развернутым.

Код шортката:

    awful.key({ alt, }, "Escape",
        function (c)
            c.minimized = true
        end),

flyboy14 ()
Ответ на: комментарий от redhat

нет, дефолт не работает тоже, но работает клик мышью по задаче не таскбаре, сворачивает как надо. не пойму в чем дело, видимо, и правда баг

flyboy14 ()
Ответ на: комментарий от makoven

Причина использования 5.1 в режиме совместимости с 5.2 в том, что очень мало библиотек и разработчиков используют 5.2 версию. За подробностями сюда

Faiver ()
Ответ на: комментарий от DeadEye

Не старая.

Не старая, а древняя, как говно мамонта. В других дистрах давно уже 5.2 используется, даже для awesome, у которого с ним некоторые трудности.

5.2 под маском

Причём уже давно, и размаскировывать его, видимо, не собираются.

Только что поколдовал над 5.2, но ничего так и не вышло, ебилд Lua у меня нет желания разбирать. Поправят ебилд Lua — будет вам awesome под lua-5.2 и luajit.

funeralismatic ★★★ ()
Ответ на: комментарий от Crocodille

да мне уже подсказали, я думал, что вики с ноября не изменили (по-диагонали читанул), а оказалось, что wmname Sawfish всё чинит, так что всё пучком, травки!

redhat ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.