LINUX.ORG.RU

openSUSE 12.2 (Mantis)

 


0

3

Представлен новый релиз дистрибутива openSUSE.

Основные компоненты:

  • Linux 3.4.6.
  • KDE 4.8.4 собранный с Qt 4.8.1, быстрый и стабильный.
  • KDE3 с поддержкой Udisks2 и Upower.
  • GNOME 3.4 теперь работает на любом железе благодаря llvmpipe.
  • GIMP 2.8.
  • LibreOffice 3.5.
  • GCC 4.7.
  • В дистрибутив включено значительное количество пакетов python3, но по умолчанию все еще используется python27.
  • Systemd 44 — добавляет возможность использования watchdog для сервисов. Добавлен специальный патч, который позволяет использовать симлинки вида /usr/sbin/rcfoo → /sbin/service для управления сервисом foo, как в традиционной openSUSE с sysvinit.
  • Grub 2.0 используется по умолчанию.
  • XOrg 1.12 с поддержкой мультитача и новыми видео драйверами (NVIDIA GeForce 600 «Kepler», AMD Radeon 7xxx и AMD Trinity APU).

>>> Скачать

Have a lot of fun!

>>> Подробности

★★★★★

Проверено: JB ()

от это, я понимаю, новость. приятно почитать

pyometra ★★★★★ ()

Язаапрув новости.

bhfq ★★★★★ ()
Ответ на: комментарий от bhfq

Я бы пока не подтверждал. Вместе с релизом размещают огромный Release Notes, а в новости пока что только изменившиеся версии программ.

ZenitharChampion ★★★★★ ()

А как правильно установить KDE3? А то делал по инструкции с сайта, добавил репозиторий, установил пакет kdebase3-session с зависимостями, а он мне TWM и Openbox втюхивает.

cinyflo ★★★★★ ()
Ответ на: комментарий от cinyflo

> А как правильно установить KDE3? А то делал по инструкции с сайта, добавил репозиторий, установил пакет kdebase3-session с зависимостями, а он мне TWM и Openbox втюхивает.

Вот кнопка 1-click-install. http://en.opensuse.org/KDE3 По желанию набор пакетов можно сократить, например мне он предлагает загрузить стомегабайтный texlive.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от HighwayStar

> 4.1. sysvinit Deprecated

Ну вот и всё: openSUSE не нужен.

> Some desktop components depend on services provided by systemd only. So while openSUSE 12.2 still has basic support for booting a system with sysvinit as fallback, sysvinit nevertheless is considered deprecated and probably even faulty or broken in some regard. If you have any issues with a sysvinit booted system, use systemd before filing bug reports.

А, ну тогда ладно. Его не удалили и выбрать «использовать systemv/systemd» по-прежнему можно.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от ZenitharChampion

> 5.2. Booting with Deprecated sysvinit

> By default, openSUSE now boots using systemd. In case of trouble, you can try to switch back to the deprecated sysvinit way by pressing the F5 key on the boot. For more information about limitations when booting with sysvinit, see Section 4.1, “sysvinit Deprecated”.

> ...

> 5.5. systemd: Making Use of tmpfs: /run, /var/run, /media, etc.

> systemd mounts several directories that are meant to contain volatile data only, as tmpfs filesystems: /run, /var/run, /var/lock, and /media are those directories. For background information, see http://lwn.net/Articles/436012/.

> Note: Do not store files that are meant to survive a reboot, in /run, /var/run, etc.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)

Linux 3.4.6

KDE 4.8.4 собранный с Qt 4.8.1

Не успел выйти, а уже устарел.

Kindly_Cat ()
Ответ на: комментарий от ZenitharChampion

ээ проблема то из-за удева растёт, если удев новый поставишь тоже сможешь словить ту самую багу.

Thero ★★★★★ ()

Почему не написано о том, что был перенос бинарников и либ в /usr, как сделали редхатовцы?

Urchin ★★★ ()

они и дальше проталкивают гуй с ястом на все, что только можно?

PaulCarroty ★★★★ ()

А на сайте ссылка до сих пор на старую версию....
Новая версия доступна через «перейти к разрабатываемой версии».

AndriAno ()

Офигенный дистр. Кому нужна федора, но чтобы не отваливалось железо при обновлении ядра/драйверов - это он.

ArtKun ★★★★★ ()

Моя линуксоидность начиналась с зюзю. Сейчас не горю желанием слезать со стабильно работающего дистра.

Akamanah ★★★★★ ()

Уважуха! Первый дистр, 11.1 хорошие впечатления, аж обратно с деба вернуться захотелось ))

Hertz ★★★★★ ()

Linux 3.4.6

KDE 4.8.4 собранный с Qt 4.8.1

GNOME 3.4

LibreOffice 3.5

Стыдоба.

anonymous ()

Со времёе 11.1 ни разу у меня с нею не срослось. То падает, то установщий глючит, то пакетов нужных нет. Попробовать нужно, но сил нет.

Vudod ★★★★★ ()
Ответ на: комментарий от Urchin

Почему не написано о том, что был перенос бинарников и либ в /usr, как сделали редхатовцы?

поленился написать, большую часть системных утилит перенесли, но в билдсервис строгую политику не вводили по удалению бинарников из /bin /sbin еще не вводили, это запланировано на 12.3

те же /sbin/SuSEConfig, /sbin/SuSEFirewall и /sbin/yast2 все еще на месте

HighwayStar ★★★★★ ()
Ответ на: комментарий от Hertz

Первый дистр, 11.1 хорошие впечатления

Да, 11.1 и правда был неплох. После него ушёл на Дебиан, 11.4 и 12.1 не смог принять.

Vudod ★★★★★ ()

В дистрибутив включено значительное количество пакетов python3

pyopencl для 3-го есть? Если да, то какой версии, надеюсь 2012.1?

Vudod ★★★★★ ()
Ответ на: комментарий от anonymous

Стыдоба

стабильнота

после решении о задержке релиза было решено только править баги, с новыми версиями пришлось бы релизить еще позже

HighwayStar ★★★★★ ()
Ответ на: комментарий от Hertz

Так давай уже. После апта даже zypper - глоток воздуха.

ArtKun ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

ZenitharChampion

Может быть, но у меня - отдельный раздел /usr.

systemd никак не мешает /usr на отдельном разделе. Мешает только мэйнтейнер systemd. В альте все работает из коробки, поскольку все нужное из sysemd для загрузки перенесли в /lib.

Vovka-Korovka ★★★★ ()

Сусе не нужен.

Qt 4.8.1

На слаке 14 Qt 4.8.2, KDE 4.8.5, хоть разница и небольшая, а приятно!

SIvan32 ()

KDE3 с поддержкой Udisks2

чума, его же KDE4 пока что не поддерживает

dt1 ★★ ()
Ответ на: комментарий от HighwayStar

Сусепроблемы. И таки стыдоба.

anonymous ()
Ответ на: комментарий от Vudod

pyopencl для 3-го есть? Если да, то какой версии, надеюсь 2012.1?

еще нет, но пишете нужные пакеты, то я сделаю на досуге

я в первую очередь сделал те пакеты что были нужны для работы numpy, scipy, ipython, h5py, sphinx

HighwayStar ★★★★★ ()

KDE 4.8.4 собранный с Qt 4.8.1, быстрый и стабильный.

откуда инфа? быстрее чем в дебиан тестинг?

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

откуда инфа?

джентльмены верят друг другу на слово

registrant ★★★★★ ()

Я рад за ребят, рад за новый релиз, для меня openSUSE - один из немногих дистрибутивов, с которыми удобно сейчас и от которых стоит ждать приятных нововведений в будущем. Я начинал с 9.1, но где-то на 11 версии решил просто попробовать пожить на чем-то другом, хотя потом все-таки вернулся обратно.

ins3y3d ★★★★★ ()

KDE 4.8.4 собранный с Qt 4.8.1, быстрый и стабильный.

Тонкий намек на то что плазма не падает

smolnij ()

Мазел тов опен сьюси

q9 ()

Не нужно. Можно спокойно использовать openSUSE 11.4.

Pidgin ★★ ()

Как-то внезапненько. Обновится бы. Для десктопа это будет четвёртое или пятое, не помню, безпроблемное обновление.

Q3164 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.