LINUX.ORG.RU

AzPainter 2.0.1

 ,


6

3

7 февраля, спустя год после финального выпуска AzPainter 1.0.7, был представлен релиз AzPainter 2.0.1 — свободного (GPL v3) графического редактора полноцветных изображений, основанного на наработках проектов AzPainter 1.x и AzPainterB (последний приспособлен для pixel art). Данная ветка содержит огромное количество улучшений по сравнению с AzPainter2 (Windows). Уже сейчас AzPainter может посоревноваться в удобстве с такими проектами, как mtPaint, благодаря парадигме UI, схожей с классическими парадигмами GIMP и Photoshop.

Главные отличия ветки 2.x от 1.x

  • Код переписан c C++ на C для упрощения портирования на другие ОС.
  • Тулкит AzXClass заменён на mlib. Оба тулкита разработаны автором и работают поверх X Window System (без зависимостей от других тулкитов или DE).
  • Добавлен однооконный режим.
  • Максимальный размер холста увеличен с 9999 × 9999 до 20000 × 20000 пикселей.

Особенности программы

  • поддержка полноцветных изображений с прозрачностью (RGBA, 16bit);
  • поддержка регулирования размера кисти в соответствии с показаниями датчика давления планшета или относительно скорости движения курсора;
  • поддержка слоёв и разнообразных операций по работе с ними;
  • наличие большого количества фильтров;
  • поддержка выделения произвольной формы, а также инструмента «волшебная палочка»;
  • собственный формат APD;
  • поддержка открытия и сохранения APD (v3), PSD, BMP, PNG и JPEG;
  • поддержка открытия APD (до v3), ADW (v1—v2) и GIF.

Список изменений (за январь—февраль 2017)

  • Изменён порядок действия при выделении с зажатыми клавишами Shift (добавить к выделенному) и Ctrl (убрать из выделенного).
  • При заливке с зажатием клавиши Ctrl применяется «transparent (antialias)».
  • Изменение цвета слоя стало возможным при выборе цвета в палитре с зажатой клавишей Shift.
  • Добавлен файл справки на японском языке.
  • Исправлен проблема с окном предпросмотра.
  • Исправлен инструмент прямоугольного выделения.
  • В процессе создания слоёв теперь можно выбрать название из предварительно созданного списка типовых названий (можно создать собственные шаблоны).
  • Добавлена опция «Key + Operation Selection Range Tool Action» в «Canvas Key Setting». Теперь можно настроить ассоциацию клавиш для Selection Tool в любой момент.
  • Улучшена интерполяция при увеличении угла поворота canvas.
  • Исправлена ошибка, приводящая к исчезновению перемещаемого элемента, если не было определено «left / right movement» в «Palette placement setting».
  • Исправлена ошибка, из-за которой порядок отображения слоёв был неправильным, если сразу же отпустить кнопку после быстрого перемещения полосы прокрутки в списке слоёв.
  • В меню настроек «Operation» теперь можно настроить действия кнопок мышки и стилуса планшета. Также можно добавить операции на ЛКМ.
  • Реализовано автоматическое скрытие рамки выделения при перемещениях с зажатой клавишей Ctrl для смещения или копирования изображения в выделенном регионе.
  • В диалоге трансформации по нажатию Ctrl + Left Drag теперь включается прокрутка canvas.
  • При настройке толщины кистей настройки автоматически сохраняются и для следующей сессии, если не отключено автосохранение.
  • Изменён шаг фиксации слайдеров прокручивания.
  • Цветовые маски и маска прозрачности слоя привязаны к цвету линии (влияет на ввод кистью с включённым сглаживанием).
  • Во время рисования кистью произвольных линий теперь используется информация от устройства ввода, которым была активирована кисть (если кисть активирована нажатием левой кнопки мышки, то и кисть будет реагировать только на движения мышки, а если инструмент был активирован через нажатие на планшете, то кисть будет реагировать на ввод с планшета; данную опцию можно отключить или настроить на своё усмотрение).
  • Добавлена опция «Select grabbed layer» в настройки горячих клавиш в настройках canvas.
  • Добавлена опция «Create new layer above this folder» и «Move check layer to this folder» в меню ПКМ на значке папки списке слоёв.
  • Тип области выделения теперь изменяется при нажатии на соответствующий значок.
  • Заменена иконка палитры видимой области canvas.
  • Исправлено ошибка, из-за которой отображался индикатор «No change» после сохранения копии изображения.
  • Исправлена ошибка в окне слоев, из-за которой увеличивались некоторые элементы списка слоев и возникали проблемы при прокрутке списка.
  • Исправлена функция поддержки фиксированных углов (шаг 45 градусов) при зажатии клавиши Shift.
  • Добавлена локализация на бразильский вариант португальского языка (pt_BR).
  • Заменена иконка программы, добавлен её SVG-вариант.

Дальнейшее развитие

На данном этапе автор приостанавливает разработку AzPainter 2.x и переключает свое внимание на усовершенствование AzDrawing 1.x — минималистичной программы для рисования и создания эскизов с поддержкой лишь оттенков серого (8bit).

Ранее автор заявлял о планах создания AzDrawing 2.x (Linux), но скорее всего, доработанный код будет объединён с AzPainter 2.x в одну программу, ведь они обе имеют много идентичных функций и отличаются по большому счёту лишь поддержкой цветовой гаммы. Возможно, код AzPainterB также будет включён в финальный продукт, в результате чего три отдельных приложения будут заменены одним. В конечном счёте слияние сэкономит время на разработку.

Также не исключена вероятность того, что объединение повлияет на размер программы и отразится на поддержке прошлых форматов файлов (APD и ADW).

Скриншоты и обзоры процесса разработки

  1. Официальный блог автора (на японском).
  2. Блог пользователя из Бразилии (на португальском).
  3. AzPainter 1.0.7 и AzDrawing 1.5 в разделе «Галерея → Скриншоты».

>>> Все программы для GNU/Linux на сайте автора

>>> Исходный код

>>> Сборки для разных дистрибутивов

>>> Подробности

Ответ на: комментарий от AP

Вот Жеана это достало, и он щас пилит апстримный флатпак наконец-то.

Здравое решение!

Linfan ★★★★★ ()
Ответ на: комментарий от AP

А где можно попросить сделать Flatpack для AzPainter? (в коллекцию сборок)

P.S.: я договорился с одним пакетировщиком насчет сборок для Trusty 14.04, после выходных должны появится на Launchpad. Возможно, если успею сделать дополнительные локализации, в том числе и на русский, то они будут включены DEB'ы

atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 1)
Ответ на: комментарий от Linfan

А почему он не настроил автоматическу сборку на OBS? Или там нет поддержки Flatpack?

https://forums.opensuse.org/showthread.php/518321-Flatpack-and-flatpack-apps-...

OOMapper вот настроил разработчик, и собирает для всех дистров автоматом.

http://download.opensuse.org/repositories/home:/dg0yt/

atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 1)
Ответ на: комментарий от Linfan

Ежели вы столь круты, что вам требуется самый последний писк из гитхаба, кто мешает собирать из сорцов?

И с какой стати мне что-то собирать и опакечивать когда в нормальных дистрибутивах уже сделано?

глубокой альфе всей операционки, отрабатывая альфа-тестером всего и вся

Это ваши глубокие комплексы. Ничем моя альфа не менее стабильна вашей Ubuntu Rotty. Если бы я нарвался где-то на проблему, я бы её просто исправил, только нечего исправлять.

slovazap ★★★★★ ()
Ответ на: комментарий от atsym

Мне интересно, как в этих дурацких ресурсных файлах обновляются строки для перевода. Помню, когда-то давно возюкался с локализацией Freemind, всё проклял.

AP ★★★★★ ()
Последнее исправление: AP (всего исправлений: 1)
Ответ на: комментарий от slovazap

когда в нормальных дистрибутивах уже сделано?

Это хорошо только в том случае, если маинтейнеры дистрибутива знают о программе, а если программа новая или специализированная то кто его знает когда ее официально опакетят в дисрах

atsym ★★★★★ ()
Ответ на: комментарий от atsym

Это хорошо только в том случае, если маинтейнеры дистрибутива знают о программе

О какой программе? О чём ты вообще?

slovazap ★★★★★ ()
Ответ на: комментарий от slovazap

Если бы я нарвался где-то на проблему, я бы её просто исправил, только нечего исправлять.

Мсье, вы про свой OpenCV или таки готовы править все подряд: LibreOffice, Gnome, KDE и т.д.? )))

Linfan ★★★★★ ()
Ответ на: комментарий от slovazap

))))))))))))))

я бы её просто исправил, только нечего исправлять

т.е. вы утверждаете, что в ваш солнцеликий арчик все приезжает без багов. А в другие дистры приезжает с багами. Видимо агенты злобной M$ вносят баги по пути к ширнармассам? ;)

Linfan ★★★★★ ()
Ответ на: комментарий от slovazap

ппц, скомпилить свежий OpenCV - труд неподъемный. А братся фиксить баги во всем подряд - это само собой ))))

Linfan ★★★★★ ()
Ответ на: комментарий от antares0

100-200 рублей в месяц

Много.

Тогда новый DEB его волновать не будет

От наглости зависит. Знаю пару наглых пенсионеров, которые права качают только так.

за исключением онлайн-видяшек

Онлайн-видяшки можно в 144p смотреть, ещё и качать, если планируется пересматривать.

тупой набор капчей

Для него надо иметь здоровые глаза и руки, как минимум. Причём глаза от капчей можно и сломать. А ещё права на ошибку на такой работе нет, 5 неверных — бан без вывода средств.

ВЫ не в теме к сожалению. Займитесь собственым ликбезом:(

Да? Ну давайте разбирать. Что у нас есть на рынке фриланса распространённого?

  • Набивать посты — ходить на странички, грузить их, многократно грузить их, вылезает в трафик.
  • Писать/переписывать тексты — само по себе оффлайн-занятие, но дёргать многократно системы антиплагиата — тоже вылезает в трафик.
  • Переводить тексты — относительно оффлайново, да, если хорошо знать целевые языки, в том числе в нужной предметной области, и/или запастись единократно оффлайн-словарями.
  • Удалённое администрирование — ну NIX-сервера по SSH ещё куда ни шло, и то, кучу логов на локалхост слить проблематично будет. А если удалённый рабочий стол...
  • Тестить — отпадает, на чём инвалиду-нищеброду тестить?
  • Кодить — ну тут вообще ахтунг, инструменты разработки огромные качай, библиотеки качай, проекты на доработку качай, ещё и заказчики многие предпочитают голосом общаться. А если вебня, просто дёргает интернет-сервисы или работает на специфичных серверах, то вообще вешайся со своим узким каналом сразу. Разработка под контроллеры относительно оффлайнова, но контроллер и программатор надо сначала приобрести.

Остальное слишком редко встречается, ничего не забыл ведь?

bodqhrohro_official ()
Ответ на: комментарий от bodqhrohro_official

Онлайн-видяшки можно в 144p смотреть, ещё и качать, если планируется пересматривать.

+1

http://saveitoffline.com

P.S.: у меня мобильный доступ временный, а так то есть возможность скачивать/выгружать и тяжелые файлы, но не напрямую из своего ПК, а так сказать из другого ПК.

atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 2)
Ответ на: комментарий от slovazap

Ещё раз, не в Linux, а в гнилых «стабильных» недодистрибутивах.

Вот так чохом обозвал кучу дистрибутивов, в том числе и такие основные как Debian

Я вижу тут только одну проблему - парадоксальное желание со стороны пользователей «стабильщины» и рыбку съесть и на * сесть, а именно, с одной стороны сидеть на вылизанном софте и не сталкиваться с багами в свежатине, с другой, почему-то, ставить свежатину которой нужны новые версии библиотек. Что действительно оптимально, так это игнорировать их.

Тут нет никакого парадокса. Хочется стабильных системных библиотек и софта с обновлениями безопасности и т.п., но свежего прикладного ПО. Проблема в том, что отделить одно от другого в Linux достаточно сложно и в итоге прикладные либы тянут за собой и всё остальное.

Для сравнения: в даже старую винду обычно можно поставить самый свежий софт. Даже в WinXP всё ещё очень многое можно установить из прикладного, а в Win7 почти всё.

anonymous_incognito ★★★★★ ()
Последнее исправление: anonymous_incognito (всего исправлений: 1)
Ответ на: комментарий от bodqhrohro_official

А ещё права на ошибку на такой работе нет, 5 неверных — бан без вывода средств.

Я же говорю учи матчасть или хотя бы пробуй на себе. Ты сейчас просто придумаешь на ходу что-то не связаное с реальностью:(

Про фриланс тоже уж коментировать не буду за объемностью и общей необразованостью.

antares0 ★★★ ()
Ответ на: комментарий от AP

Локализация AzPainter

Собственно сегодня-завтра будут готовы DEB с встроенными дополнительными локализациями Launchpad.

На скриншоте показано как компилируется mtr-файл локализации, и как потом запустить AzPainter с полученной локализацией независимо от локали ОС:

http://pasteall.org/pic/index.php?id=112641

atsym ★★★★★ ()
Ответ на: Локализация AzPainter от atsym

Есть подозрение, что там на самом деле не «вода», а «акварель».

AP ★★★★★ ()
Ответ на: комментарий от AP

Точно. Эту строку вчера ночью писал :) Я вообщем-то подглядываю в перевод для GIMP и пару словарей. Но, думаю надо будет тебе вечером дать файл перевода для быстрой вычитки на ошибки

Дело в том что приходиться кроме перевода еще и попутно править английскую локаль от автора, которая сама по себе содержит небольшие неточности

atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 2)
Ответ на: комментарий от atsym

Если AP согласится, англицкую локаль тоже отдавай на правку ;)

Linfan ★★★★★ ()
Ответ на: комментарий от anonymous_incognito

Вот так чохом обозвал кучу дистрибутивов, в том числе и такие основные как Debian

Да, именно это я и сделал. И да, Debian прежде всего.

Тут нет никакого парадокса. Хочется стабильных системных библиотек и софта с обновлениями безопасности и т.п., но свежего прикладного ПО.

Одного без другого не бывает, потому что библиотеки это неотъемлемая часть софта. Пора бы знать.

Для сравнения: в даже старую винду обычно можно поставить самый свежий софт. Даже в WinXP всё ещё очень многое можно установить из прикладного, а в Win7 почти всё.

Потому что тащат всё с собой и никогда не обновляют. Это вашим хотелкам несколько противоречит, но вообще такое и на Linux возможно со всякими flatpak'ами.

slovazap ★★★★★ ()
Ответ на: комментарий от antares0

или хотя бы пробуй на себе

Капчи пробовал.

тоже уж коментировать не буду за объемностью и общей необразованостью

Удосужьтесь хотя бы пару пунктов прокомментировать, иначе сочту толстым ленивым троллингом.

коментировать
необразованостью

И эти люди меня в необразованности упрекают.

bodqhrohro_official ()
Ответ на: комментарий от slovazap

Одного без другого не бывает, потому что библиотеки это неотъемлемая часть софта. Пора бы знать.

Да мы уже в курсе, кто самый продвинутый пианэр тут :)

Linfan ★★★★★ ()
Ответ на: комментарий от Linfan

т.е. вы утверждаете, что в ваш солнцеликий арчик все приезжает без багов

Я утверждаю что не видел никаких страшных багов ни на одном из роллингов что использовал. Ни на арч, ни на FreeBSD.

slovazap ★★★★★ ()
Ответ на: комментарий от slovazap

Да, именно это я и сделал. И да, Debian прежде всего.

Подскажи, какой дистр вместо дебиана надо использовать, если не хочется быть бета-тестером?

Одного без другого не бывает, потому что библиотеки это неотъемлемая часть софта. Пора бы знать.

Разные библиотеки.

Потому что тащат всё с собой и никогда не обновляют. Это вашим хотелкам несколько противоречит, но вообще такое и на Linux возможно со всякими flatpak'ами.

Есть тенденция, когда у разработчика все библиотеки самые совремённые, это хорошо, но как я сказал, не все хотят быть бета-тестерами. Или даже не все могут. Я никогда не поставлю обычному пользователю на его комп нестабильный дистрибутив. Ибо одно из двух: или он обновляться не будет и скоро будет с кучей незакрытых дырок или после очередного обновления иксы слетят или ещё какие жёсткие баги будут.

В результате получается, что с таким подходом самый свежий софт только для энтузиастов. Хотя может быть у вас заказчик под него специально конфигурацию делает, такой метод тоже оправдан, если больше особо ни с чем не работают.

anonymous_incognito ★★★★★ ()
Ответ на: комментарий от AP

Локализации для AzPainter 2.0.1 (неполные)

Сегодня уже не успею доделать локализации, но уже вроде больше 70% переведено в ловкализации на русский + добавил слегка исправленную английскую локаль. Посмотри как оно сейчас смотрится, может поправить что нужно в уже переведенных строках. (добавил и бинарник конвертора). Вот архив (AzPainter должен быть уже установлен)

http://hnng.moe/f/NkZ

atsym ★★★★★ ()

Код переписан c C++ на C для упрощения портирования на другие ОС.

на C

$ azpainter
Ошибка сегментирования (core dumped)

Закапывайте! Лучше бы он на дельфях написал, тогда бы хоть в вайне погонять можно было а потом нормально портировать на линукс.

Napilnik ★★★★★ ()
Ответ на: комментарий от bodqhrohro_official

Капчи пробовал.

Устало. В рунете раскручено ровно два места где за это платят новичкам. И в обоих политика «за что и как банят» не разу не подходит под твои домыслы. И к слову гораздо терпимее к новичкам. То есть вышепомяные ~100р. более чем реально. Но ты вместо того что бы попробывать тупо гонишь лажу с эмоциями. Любимый пример дешевых текстовиков. Они просто больше ничего не умеют.

Удосужьтесь хотя бы пару пунктов прокомментировать, иначе сочту толстым ленивым троллингом.

Нужность антиплагиата например. Он нужен как постоянный инструмент рерайтеру который ограничен до уроня полена и как следствие урезан в доходах и работает путем подгонки чужих текстов под плеткой антиплагиата. Копирайтер пишет свои мысли. Их очень трудно излагать плагиатным стилем. Это как выдавать перевод гугль-транслейтом за человеческий. Но ты не видя разницы радостно приравниваешь условия труда рерайтера и копирайтера и рассуждаешь об антиплагиате. Навыки анализа и как следствие кругозор отсутствуют.

Ты не понимаешь что кодеры не одиноковые по языкам и технологиям. И для PHP и JS/Верстки очень многое уже готово в линуксе из коробки. И как дешевый гуманитарий просто не способен посчитать в уме сколько мегабайт надо докачать. Иначе не пел бы песни про много-много. И даже клиентом «желающих голосом» имеено на на этом ценовом уровне можно посылать лесом.

Ты банально не можешь в матчасть что эти грошовые тарифы ограничены скоростью а не трафиком. И по факту за 4р/сутки от 300 мег до гигабайта в сутки. Что перекроет кодерские потребности. Но ты как гуманитарий посчитать это не можешь, вместо этого с надрывом рассуждая о недоступности сферических коней в ваккуме.

, иначе сочту толстым ленивым троллингом.

Сделай милость Ты меня уже посмешил:)

И эти люди меня в необразованности упрекают.

Ты необразован именно вот потому что не различаешь образованность и грамотность. Сам же палишся

P.S. Заигнорен

antares0 ★★★ ()
Ответ на: комментарий от AP

Русская локализация AzPainter 2.0.1 (готова на 95%)

AP, вот уже почти готовая локализация. Просто посмотри локаль, там строк 20-30 я сам уже не знаю как переводить (в локали GIMP похожих нет, а GoogleTranslate выдает бред а не перевод). Пожалуйста!

СКАЧАТЬ - http://hnng.moe/f/Nlp

Linfan ты тоже посмотри, если можешь, может ты подскажешь как перевести то что осталось.

P.S.: все желающие посмотрите тоже, может вы что подскажите.

Исходник локализации файл ../azpainter_mtr/ru, бинарный файл локали ../azpainter_mtr/ru.mtr.

Чтобы запустить AzPainter 2.0.1 (должен быть уже установлен) с данной русской локалью используйте комманду

$ azpainter --trfile ../azpainter_mtr/ru.mtr

Для автоматического определения языка программы, системный язык вашей ОС должен быть «русский», а сам файл перевода лежать по пути:

/usr/share/azpainter/tr/ru.mtr

или

/usr/local/share/azpainter/tr/ru.mtr
atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 2)
Ответ на: комментарий от AP

Есть много вопросов к английской локализации.

atsym, вишь, я не зря рекомендовал натравить на перевод динозавра локализации ;)

Linfan ★★★★★ ()

Linfan ты тоже посмотри, если можешь, может ты подскажешь как перевести то что осталось.

Не, я погромист, а не лингвист. Мне нужно для SwatchBooker закончить екстеншин python-lcms2 (кажись, AP писал, что такой погремухи до сих пор нет в природе).

Linfan ★★★★★ ()
Последнее исправление: Linfan (всего исправлений: 1)
Ответ на: комментарий от Linfan

Мне нужно для SwatchBooker закончить екстеншин python-lcms2 (кажись, AP писал, что такой погремухи до сих пор нет в природе).

А ты хочешь .sbz в sK1 использовать что ли?

AP ★★★★★ ()
Ответ на: комментарий от AP

Не, в sbz нет практического смысла. Это Оливер попросил помочь с привязкой. В sK1/UniConvertor привязка к lcms2 уже с 2012го есть. Но она сделана под потребности приложения. Оливер в нативных экстеншинах не разбирается, поэтому я ее отрефакторил и сделал соместимой с python-lcms. Сегодня-завтра проаннонсируем: https://github.com/sk1project/python-lcms2

Linfan ★★★★★ ()
Ответ на: комментарий от Linfan

Перевод для AzPainter 2.0.1 готов! (100%)

AP, Linfan и компания!

Перевод готов (я завершил перевод сегодня утром)! Переведено все строки!

Вечером добавлю ссылки на уже собранные пакеты с полноценным русским переводом :)

atsym ★★★★★ ()
Ответ на: комментарий от Linfan

Не, в sbz нет практического смысла.

Как, совсем? :)

AP ★★★★★ ()
Ответ на: комментарий от AP

Этот формат нужен самому SwatchBooker, поскольку это его внутренний формат. В «дикой природе» он практически отсутствует. Сделать его поддержку несложно, но это не приоритетное направление.

Linfan ★★★★★ ()
Ответ на: комментарий от Linfan

Ну, я лично вижу в лице SBZ отличную замену гимповскому GPL, который давно не соответствует современным требованиям.

Одна из проблем с общим переходом на этот формат в том, что Оливье так и не отрелизил новую версию с поддержкой градиентов и текстур. Пару недель назад, например, у меня из-за этого не получилось «продать» SBZ одному из инкскейперов, который удумал добавить градиенты в GPL.

AP ★★★★★ ()
Ответ на: комментарий от AP

Но зачем пхнуть градиенты и текстуры («материал») в файлы палитры («коробка карандашей»)???

В SBZ случайно кисти еще не пытались запихнуть вместе с фильтрами? Чо уже там мелочиться, и форматы бумаги с направляющими и сетками привязки...

Хотя, постойте, это же получается файл «проекта», а не «палитры», не?

atsym ★★★★★ ()
Последнее исправление: atsym (всего исправлений: 2)
Ответ на: комментарий от atsym

SwatchBooker обрабатывает и палитры и текстуры и градиенты. Т.е. разношерстные сэмплы-ресурсы. Поэтому в его родном формате есть все.

Linfan ★★★★★ ()
Ответ на: комментарий от AP

Ну, я лично вижу в лице SBZ отличную замену гимповскому GPL, который давно не соответствует современным требованиям.

Учтитывая, что сам автор пишет про SBZ:

«This is in a developement stage so it will most probably change before version 1.0»

делать стандартом пока его не стоит.

Касательно версии 0.8 - один из серьезных затыков связан с биндингов к lcms2, поскольку lcms1 выкидывают из современных дистров.

Linfan ★★★★★ ()
Ответ на: комментарий от Linfan

Поэтому в его родном формате есть все.

... его родном формате...

Ну, дык я о чем и говорю: пхнуть внутренний формат программы (которая генерирует уже стандартизованные и более простые форматы типа GPL-палитры) непосредственно в графические редакторы? Кроме дополнительного распорошивания времени разработчиков графических редакторов и кучи потенциальных багов и дополнительных зависимостей для графического редактора это больше ничего не принесет...

Не надо вскрывать часы, пока они работают «как часы».

atsym ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.