LINUX.ORG.RU

На сайте «Компьютерры» опубликовано интервью с разработчиком Deepsolver

 ,


0

1

Существующие менеджеры пакетов для Linux часто критикуют за высокую для неопытных пользователей сложность, трудности с разрешением зависимостей между пакетами и тому подобные вещи. О новых подходах к управлению установленными программами задумываются разработчики многих дистрибутивов, и российские компании не исключение. Инженер-программист «Альт Линукс», кандидат технических наук Михаил Пожидаев рассказал «Компьютерре» о Deepsolver — перспективной разработке, которая может заменить в дистрибутивах ALT Linux использующийся сейчас «Advanced Packaging Tool» (APT).

>>> Подробности

★★

Проверено: maxcom ()

Ответ на: комментарий от Oleaster

Я пробовал не давеча как этой весной на свежекупленном ноутбуке HP с предустановленной СЮЗЕй. Сейчас я не помню версию, возможно, была устаревшая, но не на пять лет, это точно. Поэтому у меня настороженное отношение к этой системе.

anonymous ()
Ответ на: комментарий от anonymous

ставишь игрушку
ставишь программу

Ты бесконечно прав дорогой, именно что в винде, или маке ты сможешь этот софт все же установить, и он у тебя даже будет работать, пускай и без твоих любимых видероликов. В отличие от, где пакет просто напросто ругнется и предложит тебе сосать лапу если не подключен к сети.

anonymous ()
Ответ на: комментарий от anonymous

А, это какое-то быдлоподелие из СНГ? Действительно, требует пол-системы переставить. Ну так это характерно для любого снговённого софта. А про нормальных разработчиков — ну там, Blizzard — примеры есть?

Oleaster ★★★ ()
Ответ на: комментарий от anonymous

В зюзе без пакмана вообще нечего делать, если чо.

Oleaster ★★★ ()
Ответ на: комментарий от anonymous

для маугли, выращенного дятлами в деревне под Улан-Удэ, где до сих пор нет интернета, венда в самом деле лучший выбор :D

пакет просто напросто ругнется и предложит тебе сосать лапу если не подключен к сети

можно кликнуть на пакете и поставить его

anonymous ()
Ответ на: комментарий от anonymous

Ошибка приложения: файл msvc80.dll не найден"

За многие годы пользования бывало такое очень редко, встречалось обычно в наколеночно/студенческом софте во времена win98-XP. Решалось обычно не сложнее поиска зависимостей - «Google/msvc80.dll не найден»

anonymous ()
Ответ на: комментарий от true_admin

Я верю что можно придумать сценарий с циклическими зависимостями, диапазонами версий итд итп, но в реальной жизни при прямых руках конфликты и неоднозначности бывают очень редко.

Как раз в реальной жизни, при КРИВЫХ руках, конфликты, неоднозначности и циклические зависимости - сплошь и рядом.

Ты же не будешь утверждать что когда я набираю apt-get install nginx я получаю не то что хочу?

А это не обязательно говорит о корректных зависимостях. Нужное ПО у тебя чаще всего, уже установлено.

lenin386 ★★★ ()
Ответ на: комментарий от glibych

Считай как хочешь,

Пока что я считаю, что ты не предоставил ровно никаких доказательств своего утверждения.

только не приписывай мне свои выводы пожалуйста

Это был вопрос. На который ты не ответил, кстати.

tailgunner ★★★★★ ()
Ответ на: комментарий от lenin386

А это не обязательно говорит о корректных зависимостях. Нужное ПО у тебя чаще всего, уже установлено.

с некорректными зависимостями ни один пакетный менеджер не справится.

true_admin ★★★★★ ()
Ответ на: комментарий от anonymous

для маугли, выращенного дятлами в деревне под Улан-Удэ, где до сих пор нет интернета, венда в самом деле лучший выбор :D

Ты путаешь понятия возможность выбора и свои личные предпочтения. Под возможностью выбора имеется ввиду установка программ онлайн/оффлайн, даже когда гроза наебнет твой подъездный роутер, а твой провайдер будет неделю его чинить.

anonymous ()
Ответ на: комментарий от anonymous

Я бы заменил вот таких вот «кандидатов» на что-то более полезное. Когда я первый раз
попробовал Ubuntu, то ничего сложного в APT не нашел.

Сложность не в том, чтобы man прочитать. Сложность в разборе зависимостей. В общем, пользователю не понять, он верхушку видит.

AS ★★★★★ ()
Ответ на: комментарий от glibych

«В ALT Linux сборка пакетов осуществляется в изолированной chroot-среде, обслуживанием которой
занимается Hasher».. Мда.. Помню как-то пробовал что-то примитивное скомпилировать в альте,
так тут весь лор укатывался от предлагаемых ими костылей и дельных советов.

Не осилил что ли ? А костыли, чтобы что-то в ALT собрать, нужны только для быдлокода.

AS ★★★★★ ()
Ответ на: комментарий от true_admin

Ты же не будешь утверждать что когда я набираю apt-get install nginx я получаю не то что хочу? Может быть не все зависимости ставятся? Может быть лишний мусор прилетает? Да нет, всё работает как надо, apt обходит граф зависимостей, сравнивает с тем что уже стоит в системе и доставляет нужное.

А что сделает APT, если устанавливаемая программа по зависимостям требует более старую версию библиотеки, чем та, которая уже установлена в системе и от которой зависят другие программы? Или если надо обновить библиотеку до новой версии, а другие установленные в системе программы требуют текущую версию библиотеки?

vold ★★★★★ ()
Ответ на: комментарий от raorn

(но мы-то с вами знаем, что на самом деле проблема в окаменелом ALT-rpm).

Но ты-то (ничё, что так ? ;-) ) должен знать, с чего он окаменелый... Глядишь, будет-таки rpm5 какой-нибудь...

AS ★★★★★ ()
Ответ на: комментарий от Hertz

На крайняк есть Синаптик.

Что-то мне сдаётся, что лучшеб не было...

AS ★★★★★ ()
Ответ на: комментарий от vold

А что сделает APT

Тут или даунгрейдить либу и сносить всё что не работает со старой либо, либо ничего не делать. Это apt и предложит. А какие ещё есть варианты?

Или если надо обновить библиотеку до новой версии, а другие установленные в системе программы требуют текущую версию библиотеки?

если в репозитории есть новые версии установленных программ которые работают с новой либой то всё пучком. Иначе что-то придётся снести. Слотов-то как в генте нету. Твой вариант решения проблемы?

true_admin ★★★★★ ()
Ответ на: комментарий от AS

Причем тут неосилил. Так можно разогнаться и вообще любого пользователя назвать неосилятором. Просто хочу, чтобы у вас тоже все по-человечески пошло.

glibych ★★ ()
Ответ на: комментарий от raorn

у них значительный опыт работы с apt для RPM

С каких пор «не трогать» стало «значительным опытом»?

А он не тронут ? :-)

AS ★★★★★ ()
Ответ на: комментарий от raorn

Этот самый apt уже несколько раз патчили в области размеров кеша чтобы туда поместились
индексы от «третьего в мире по количеству пакетов репозит[ао]рия».

Ага. /etc/apt/apt.conf: APT::Cache-Limit 63554432;
Мегапатч. ;-)

AS ★★★★★ ()
Ответ на: комментарий от anonymous

плакать и мазохистски продолжать пользоваться услугами такого говнопровайдера - это так по-вендузятнически

anonymous ()

а где для Ъ? что предлагают то? отказаться от зависимостей совсем? линковать статически? виндовый ад?

anonymous ()
Ответ на: комментарий от anonymous

Это наверное для программистов полезно, обычному пользователю для чего это знать?

Чтобы не бредить системой с отсутствием зависимостей. Хочется ? Mac OS и Windows пожалуйста. :-)

AS ★★★★★ ()
Ответ на: комментарий от tailgunner

Зачем меня в парсеры записывать? Поводов для этого не давал.

glibych ★★ ()
Ответ на: комментарий от true_admin

Тут или даунгрейдить либу и сносить всё что не работает со старой либо, либо ничего не делать. Это apt и предложит. А какие ещё есть варианты?

Есть ещё не очень популярный вариант «ставить одновременно разные версии одной либы».

Ramen ★★★★ ()
Ответ на: комментарий от true_admin

Тут или даунгрейдить либу и сносить всё что не работает со старой либо, либо ничего не делать. Это apt и предложит. А какие ещё есть варианты?

Нет, это понятно. Я спросил, что будет делать apt. А он в этом случае потребует удалить библиотеку и всё что от неё зависит. Вот такие случаи и приводят к желанию apt'а удалить пол-системы.

Твой вариант решения проблемы?

Надо сделать так, чтобы пакетный менеджер позволял хранить в системе разные версии одной и той же библиотеки (как это сделать на уровне файловой системы - отдельный вопрос), а каждая программа пусть вызывает ту версию библиотеки, которая прописана у неё в спеке. Ещё не надо удалять библиотеку, пока от неё зависят другие программы, даже если удаляется одна из них.

Но как альты реализуют такие ситуации в deepsolver не знаю.

vold ★★★★★ ()
Ответ на: комментарий от glibych

Причем тут неосилил. Так можно разогнаться и вообще любого пользователя назвать неосилятором.
Просто хочу, чтобы у вас тоже все по-человечески пошло.

Когда собираешь из нормального тарбола, всё хорошо. А если что-то не так, то, с вероятностью процентов 90, накосячил апстрим, и тут варианты начинаются... Можно и не осилить, что ж такого. Но при чём тут ALT ? Только из-за того, что проверки жесткие на входе ?

AS ★★★★★ ()
Ответ на: комментарий от Ramen

Есть ещё не очень популярный вариант «ставить одновременно разные версии одной либы».

Это хорошо, если разные версии рассчитаны на одновременную установку. Это к вопросу не сильно прямого кода. Или не очень правильно собранного пакета.

AS ★★★★★ ()
Последнее исправление: AS (всего исправлений: 1)
Ответ на: комментарий от rmammoth

Ага.
Ложками и вилками пользуются только идиоты.

Настоящие мозгляки жрут руками или заглатывая еду с тарелки.

grim ★★★☆ ()
Последнее исправление: grim (всего исправлений: 1)
Ответ на: комментарий от AS

Это хорошо, если разные версии рассчитаны на одновременную установку.

это хорошо если софт ещё подхватит нужную версию :)

true_admin ★★★★★ ()
Ответ на: комментарий от raorn

Вот интересно что мешало «патч» загнать в настройки. Я сторонник того чтобы как можно меньше патчей пихать. Особенно в ситуациях когда можно тупо поменять переменную в конфиге.

true_admin ★★★★★ ()
Ответ на: комментарий от true_admin

это хорошо если софт ещё подхватит нужную версию :)

Так-то он должен по soname ориентироваться... Но, бывает, не меняют, когда надо.

AS ★★★★★ ()
Ответ на: комментарий от vold

Но как альты реализуют такие ситуации в deepsolver не знаю.

А они собираются ее реализовать?

tailgunner ★★★★★ ()
Ответ на: комментарий от raorn

«Черновик политики Sisyphus»

Сдаётся, что вики просто не поправили... Хотя х.з.

всем поъцй.

Не всем. Но есть немного.

AS ★★★★★ ()
Ответ на: комментарий от rmammoth

Штаны с себя снимайте. А то дурак ими тоже пользоваться может.

anonymous ()
Ответ на: комментарий от vold

Но как альты реализуют такие ситуации в deepsolver не знаю.

В этом и поинт, альт не продемонстрировал понимание того куда надо двигаться. Была какая-то работа на малограммотную публику в духе «вот есть такая либа, libsolv называется, вот она ацтой, а мы хотели её прикрутить».

true_admin ★★★★★ ()
Ответ на: комментарий от AS

Чтобы не бредить системой с отсутствием зависимостей. Хочется ? Mac OS и Windows пожалуйста. :-)

Почему бы не сделать так в линуксе? Или это технически сложно, нужно всю о/с перекурочить?

Вопрос про обычных пользователей из заголовка темы, или преодоление 1% барьера десктопных осей не входит в грандиозные планы распространения Linux?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.