LINUX.ORG.RU

Xfce переходит на GTK+ 3

 


3

6

Разработчики Xfce представили выпуск панели Xfce 4.13, перешедшей на GTK+ 3. Работа велась с 2013 года и являлась ключевым этапом подготовки Xfce 4.14. Эта среда рабочего стола перешла на GTK+ 3 самой последней. Функциональность панели идентична той, что была у 4.12.1, ничего не удалено.

Среди ошибок остаётся отсутствие затемнения плагинов GTK+ 2, панель не всегда скрывается автоматически, могут не восприниматься старые настройки, также имеются трудности с перемещением виджетов.

>>> Подробности

Ответ на: комментарий от narkoman228

Он появится только с выпилом иксов
Уберут поддержку работающих игр

Ты упорот?

anonymous ()
Ответ на: комментарий от mittorn

xfce нужен легковесный тулкит т.к это легковесная среда.

Здраво, он не настолько нужен, чтобы быть тяжелым

SvSon ()

Самое обидное, что не собрать с «USE= -gtk3».

cyberhoffman ()
Ответ на: комментарий от cyberhoffman

Ну так допили сборку. Я обычно ебилды правлю и всё собирается с gtk2.
Если они где-то довыпендривались что оно не собирается, можно откатить

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Да наверное проще будет замаскировать, всё что выше 4.12.0, чем в ебилды залезать.

cyberhoffman ()

К сожалению, эта среда рабочего стола перешла на GTK+ 3 самой последней.

Я понимаю что сейчас модно быть чемпионами спецолимпиад, но почему „к сожалению”?

h578b1bde ★☆ ()
Ответ на: комментарий от Sunderland93

С чем связано такое долгое переписывание на GTK 3 - со сложностью GTK, с ленью разрабов, или и с тем и другим вместе?

С ненужностью GTK 3.

h578b1bde ★☆ ()
Ответ на: комментарий от Deleted

Опять старьёвщики расплакались. Никто не обязан довольствоваться DE-кастратами, которые не тормозят на 10-летних компах, ради кучки клинических жлобов.

Это не повод делать вместо DE говно.

h578b1bde ★☆ ()
Ответ на: комментарий от Deleted

И много тебе пользы от свистлок и перделок на плазме?

anonymous ()
Ответ на: комментарий от narkoman228

Ты глупый

Не экстраполируй свой уровень умственного развития на всех.

забанься

Только после narkoman228.

h578b1bde ★☆ ()
Ответ на: комментарий от mittorn

Даже с css он легче electron-параши которые некоторые тролли тут пиарят.

Всё познаётся в сравнении.

energetix_user ()
Ответ на: комментарий от energetix_user

electron-парашу я вообще не принимаю во внимание. Оно крутится в своей нише говноедов

mittorn ★★★★★ ()
Ответ на: комментарий от h578b1bde

Не экстраполируй свой уровень умственного развития на всех.

Не шлангуй. Все равно значения слова «экстраполяция» ты не знаешь, так что буду читать твое сообщение как «сам такой».

Только после narkoman228.

Давай сделку: ты банишься и никогда не приходишь на ЛОР, а ЛОР тебе за это говорит коллективное спасибо?

narkoman228 ()
Ответ на: комментарий от mittorn

Ну назови тогда другой современный тулкит где нет всякой интерпретации и таблиц стилей. у qt QML есть например. У tk tcl :D На wxWidgets я видел всего один кусок софта.

Только gtk2 и остался.

Такая себе претензия в общем к тяжеловесности.

energetix_user ()
Ответ на: комментарий от narkoman228

Все равно значения слова «экстраполяция» ты не знаешь

Зря ты советов не слушаешь, дурачок.

Давай сделку

Мамка даст.

h578b1bde ★☆ ()
Ответ на: комментарий от energetix_user

fltk, не?
Ещё vgui2 со своими компактными схемами

mittorn ★★★★★ ()
Ответ на: комментарий от narkoman228

Советы от дебилов мне не нужны.

Согласен. Советы от дебилов-наркоманов тем более не нужны.

h578b1bde ★☆ ()
Ответ на: комментарий от mittorn

выпили из него css для начала

Во-первых, css сам по себе не противоречит легковесности. Во-вторых, без css придется либо отказываться от тем как таковых, либо переизобретать тот же самый css.

dexpl ★★★★★ ()
Ответ на: комментарий от redgremlin

То есть разработчики DE говнокодеры, а виноват пользователь, что оно у него тормозит

Починил.

h578b1bde ★☆ ()
Ответ на: комментарий от thunar

XFCE до уровня гнома успел разжиреть ещё на GTK2.

Quasar ★★★★★ ()
Ответ на: комментарий от Sunderland93

Потому что опенсурс и за него не платят.

anonymous ()

это мелочи. firefox все еще требует gtk2 для сборки, gimp вообще отложил переход на gtk3 до хрензнаеткакого релиза. libreoffice, который официально собранный, тоже только libvclplug_gtklo.so, никаких тебе gtk3. так что, не дождетесь

ananas ★★★★★ ()
Ответ на: комментарий от iZEN

никто не выбрасывает - продолжай пользоваться.

anonymous ()

также имеются трудности с перемещением виджетов.

их, вроде, всегда было не просто переместить :-)

жаль, только, что GTK-3 файловый диалог такой уродский...

samy_volosaty ★★★★★ ()

Опять пришёл sudopacman и сделал текст немного хуже. Не криминал, конечно, но неприятно.
Почитал тему, хочу задать вопрос насчёт первосортного железа.

1). Имея топовый софт, можно кодировать видео в 4k. Я пользуюсь ffmpeg для этой задачи. В версии 3.2 убрали возможность сборки с libfaac и libaacplus. В пользу libfdk_aac. Зачем? В попытках найти ответ, я нашёл что это позволило собрать ffmpeg с поддержкой кодирования в aac, и при этом не включать параметр --enable-nonfree. И это всё? Стало ли лучше по качеству кодирование при помощи libfdk_aac? И собираются ли добавлять поддержку AAC+?

2). Имея топовую карточку от AMD, можно вычислять с помощью OpenCL. А что насчёт разгона? На LOR Wiki лежит статья Overclock, в которой дана инструкция по разгону. Обязателен ли Catalyst, или AMDGPU-PRO тоже можно? И если да, то как - есть ли там утилита amdconfig? Просто без разгона хотя бы на 25 МГц AMDGPU-PRO становится значительно меньше эффективен в OpenCL.

3). Имея топовый проц, не всегда необходима топовая видеокарточка - можно и вовсе обойтись без иксов! У меня есть домашний сервер, у которого всё-таки есть монитор, подключенный к «затычке для слота» - S3 Virge. Ну а что - не шумит, пассивное охлаждение... Так вот, после обновления ядра Linux сразу на 10 версий - иксовый драйвер перестал работать. В логе иксов - «ошибка сегментирования». Мне репортить баг, или засмеют?

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 5)

Оно что, еще развивается?

hibou ★★★★★ ()

Тоже мне новость, уже года два переходят. Первые ГТК3 компоненты появились кажется в 4.10 или 4.8, а сейчас, в 4.12, каким то чудом удаётся не поломать совместимости и внешнего вида.

Посмотрим, что у них в 4.13 отвалится с новой панелью и как они в 4.14 выкрутятся... И будет у них 50% переход на новую библиотеку. Ещё лет 5 работы, и можно будет запускаться в вайланде. Ведь вайланд - единственная причина переписывать всё на гтк3.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от h578b1bde

Я не скажу за все ДЕ, но четвёртокеды летают на рабочем процесоре 2009го с двумя гигами ddr2 и винтом на 80гиг. Дома у меня машинка поновее, так что там и пятая плазма летает. А какой калькулятор нужен, чтобы затормозить TDE, я вообще не представляю, первопень какой-нибудь нужен, а где под него ещё материнку найдёшь, где от старости весь электролит в кондюках не высох.

redgremlin ★★★★★ ()
Ответ на: комментарий от dexpl

в gtk2 как-то обходятся без него и пишут шикарные движки тем на сишке

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

в gtk2 как-то обходятся без него

А в gtk3 велосипед наконец-то выкинули. Впрочем, суть не в этом, а в том, повторюсь, что css не противоречит легковесности.

и пишут шикарные движки тем на сишке

Кстати, а движок css в gtk3 на чем?

dexpl ★★★★★ ()
Последнее исправление: dexpl (всего исправлений: 1)
Ответ на: комментарий от ZenitharChampion

Так вот, после обновления ядра Linux сразу на 10 версий - иксовый драйвер перестал работать. В логе иксов - «ошибка сегментирования». Мне репортить баг, или засмеют?

Я бы репортнул.

dexpl ★★★★★ ()

Лучше бы форкнули GTK+ 2 и привели в порядок, чем заниматься содомией с 3.

IPR ★★★★★ ()
Ответ на: комментарий от thunar

Эх, Qt'растов всё больше и больше...

anonymous ()
Ответ на: комментарий от IPR

что не так в импорте функций(залоловочными файлами, доками, etc) и с самим GTK3?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.