LINUX.ORG.RU

А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs

 ,


0

0

Вчерашняя новость о проблемах в KDE 4.2, вскрывающихся при переходе на новую версию Qt, вызвала много откликов по всему миру.

Тьяго Масиэйра (Thiago Macieira), сотрудник Qt Labs (бывшей Trolltech) и участник разработки KDE, заявляет в официальном блоге Qt Labs, что KDE 4.2 можно и нужно использовать с новой версией Qt.

Сокращённый перевод:

Да, разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это. Да, дистрибутивам следует быть осторожными при обновлении Qt. Но в этом — проверке на отсутствие ошибок и написании врЕменных патчей — и состоит работа дистрибутивов.

Зато в Qt Software тестировали плазму с Qt 4.5. И установили, что она лучше работает с Qt 4.5, чем 4.4.3, хотя патчи qt-copy не будут бесполезны. Наконец заработал трей. Улучшилась и работа других компонентов KDE, например, отпала необходимость задавать QT_NO_SHARED_PAINTER=1 при запуске Kontact. БОльшую часть исправлений из Qt 4.5 в ветку 4.4 не переносили. В 4.5 заметно возросла производительность, в том числе при отрисовке.

Кроме того, чем раньше начнут широко использовать Qt 4.5, тем больше будет багрепортов и тем скорее его исправят. Особенно полезна обратная связь с сообществом KDE.

И вообще, релиз-кандидат Qt 4.5 гораздо стабильнее релиз-кандидата Qt 4.4 10-месячной давности.

>>> Подробности в блоге labs.trolltech.com

★★★★★

Проверено: Shaman007 ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

А кто-нибудь в курсе, когда будет релиз? А то что-то я на их сайте не нашёл.

Black_Shadow ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Кроме того, чем раньше начнут широко использовать Qt 4.5, тем больше будет багрепортов и тем скорее его исправят. Особенно полезна обратная связь с сообществом KDE.

Кушайте наши питательные кактусы!

gaa ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Ну этот кактус повкуснее будет кактуса под названием гтк. Просто Kde/Qt Это один большой и сочный кактус, и когда прогрызешь слой колючек будет вкусно. А вот гтк и куча либ с ним связанная это сотни мелких кактусов. А у сотни мелких кактусов площадь суммарная площадь покрытая колючками выше. З.Ы. Что касается винды - это как тус с колючками в т.ч. внутри мякоти.

AiFiLTr0 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>чем раньше начнут широко использовать Qt 4.5, тем больше будет багрепортов и тем скорее его исправят

Т.е. все в курсе что оно кривое?

iRunix ★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

ну так че будем делать?

ferhiord ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Что означает фраза "разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это"?

st0ke ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Да, разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это.

а у кого достаточно? т.е., я хочу спросить, господа - ДОКОЛЕ?

доколе "программисты" будут просирать всё новые и новые ресурсы???

scaldov ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Тут одно из двух: или на LOR'е надо переименовать пункт 4.2 правил или не выпускать KDE с таким номером.

anonymous_incognito ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

я какбе и не переходил с qt4.5rc1 обратно =)

v0rbis ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Plasma team не хочет поддерживать плазму с Qt4.5, QtSoftware не хочет поддерживать Qt4.4 для KDE4.2. Победит QtSoftware.

fenris ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

подождемс, увидем.

f3ex ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Тут одно из двух: или на LOR'е надо переименовать пункт 4.2 правил или не выпускать KDE с таким номером.

+1, только что сам заметил что название новости как-то не так звучит, со скрытым смыслом.

надо тему переименовать в "А KDE все-таки 4.2"

st0ke ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Я знал что опровержение не заставит себя ждать :)

Sherak ★☆ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Теперь ждём опровержение опровержения...

Ну или новость: "А всё-таки KDE 4.2 с Qt 4.5 использовать не надо. Мнение мэинтейнера GTK"

narayan ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

слабенько что-то гномеры выступают. никак, ждут тяжелой артиллерии (той, у которой кодовое имя двухбайтовое) :)

leave ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Т.е. все в курсе что оно кривое?

Нет просто все в курсе что приложений сложнее калькулятора без багов не бывает!

Daeloce ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

эм... извиняюсь за оффтопик... а кто-нибудь располагает патчем для psi+qt4.5? или для rc1 уже не нужен?

arsi ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

юзаю 4.5 RC уже некоторое время в принципе, думаю, все "сложности перехода" во многом надуманы

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Наконец заработал трей.

а чё с треем? пользуюсь месяц, всё ок, с треем проблем не заметил

Bers ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Тьяго Масиэйра (Thiago Macieira), сотрудник Qt Labs (бывшей Trolltech)

ТРОЛЛЬТЕХ!!!
А я-то думал чего у меня такая неприязнь к сей библиотеке! )

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Но в этом — проверке на отсутствие ошибок и написании врЕменных патчей — и состоит работа дистрибутивов.

Это объясняет кривизну Qt/KDE. Оказвается, они на линупсоедах свои поделки тестируют

geek ★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

нужен, не исправлено там ничего
в Флайспрее ПСИ багу я запостила, надеюсь что исправят,

если нужно уже сейчас - ставьте Psi+

http://www.googlecode.com/p/psi-dev

кажется, если не хочется все патчи (а почему бы и нет?) то разберите индивидуально, кажется там есть qt45compat

Sylvia ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Не, я поимаю когда разработчики дебиана рекомендуют пользоваться aptitude, а пользователи, по старой привычке, используют apt-*. Это нормально. Но когда один разработчик программного продукта заявляет одно, а другой - совершенно другое, становится непонятно, что же они написать смогут без согласованной позиции по поводу версий тулкита. Может именно поэтому KDE 4.х такой какой есть ? И несуразность с треем объясняется.

u5qh ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> юзаю 4.5 RC уже некоторое время в принципе, думаю, все "сложности перехода" во многом надуманы

Сложности перехода не только из-за KDE могут быть. У меня например Psi-0.12 после перехода на qt-4.5.0_rc1 сломался - вместо русских букв - ахинея лезет. Пришлось назад откатится. :(

P.S. Конечно же я пересобирал Psi.

P.P.S. гентушнег

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Кдешники вы там уж определитесь, то можно, то нельзя использовать. Я уже задолбался кеды ставить и сносить.

lester_dev ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> когда прогрызешь слой колючек будет вкусно.

это типа - мышки плакали, кололись, но продолжали грызть кактус...

как-то не хочется быть этой мышкой

будет релиз посмотрим, а пока КДЕ 4+ это что-то с родни Висты, все ждали, но оказалось напрасно...

Mamay ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

почему-то эти "кактусики" на деле оказываются более более гибкими и стабильными. да и колючки не такие уж и острые

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>это типа - мышки плакали, кололись, но продолжали грызть кактус...

>как-то не хочется быть этой мышкой

хочется кактусом? ;)

shty ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Кдешники вы там уж определитесь, то можно, то нельзя использовать. Я уже задолбался кеды ставить и сносить.

Вот и Линус тоже... Почему с гномом такого не бывает?

shty ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>почему-то эти "кактусики" на деле оказываются более более гибкими и стабильными. да и колючки не такие уж и острые

они числом берут :)

shty ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Это объясняет кривизну Qt/KDE. Оказвается, они на линупсоедах свои поделки тестируют

Стареешь, гек. Совсем уже хватку потерял...

gaa ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>> Кдешники вы там уж определитесь, то можно, то нельзя использовать. Я уже задолбался кеды ставить и сносить.
> Вот и Линус тоже... Почему с гномом такого не бывает?


Вот и выросло поколение, не видевшее раннего гнома 2.х

gaa ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Да, дистрибутивам следует быть осторожными при обновлении Qt. Но в этом — проверке на отсутствие ошибок и написании врЕменных патчей — и состоит работа дистрибутивов.

Переводчика на мыло.

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

А знаете насколько вкусен сок кактуса? У KDE есть возможность выбрать длину и жесткость колючек кактуса. Что скажете, гномеры?

squareroot ★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>А знаете насколько вкусен сок кактуса? У KDE есть возможность выбрать длину и жесткость колючек кактуса. Что скажете, гномеры?

А почему КДЕ так пахнет?... А мы его уже 4.2-й раз едим :)

shty ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> У KDE есть возможность выбрать длину и жесткость колючек кактуса. Что скажете, гномеры?

Пожелаем приятного аппетита !

u5qh ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>А знаете насколько вкусен сок кактуса? У KDE есть возможность выбрать длину и жесткость колючек кактуса. Что скажете, гномеры?

Гномеры скажут, что им колючки похигу. Они их не видят.

lester_dev ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> А знаете насколько вкусен сок кактуса? У KDE есть возможность выбрать длину и жесткость колючек кактуса. Что скажете, гномеры?

Что мы скажем... Заканчивай ты кактусы курить...

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>а чё с треем? пользуюсь месяц, всё ок, с треем проблем не заметил

Ну а у них он не работал. А теперь работает. Вот и радуются.

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Но в этом — проверке на отсутствие ошибок и написании врЕменных патчей — и состоит работа дистрибутивов.

Сорри за оффтоп, но не могу не удержаться и спросить - а что же тогда по мнению Тьяго Масиэйра для работы?

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Тролльтек в конец обурел.

FU, We Are Not Your Beta-Testers Army!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.