LINUX.ORG.RU

А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs

 ,


0

0

Вчерашняя новость о проблемах в KDE 4.2, вскрывающихся при переходе на новую версию Qt, вызвала много откликов по всему миру.

Тьяго Масиэйра (Thiago Macieira), сотрудник Qt Labs (бывшей Trolltech) и участник разработки KDE, заявляет в официальном блоге Qt Labs, что KDE 4.2 можно и нужно использовать с новой версией Qt.

Сокращённый перевод:

Да, разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это. Да, дистрибутивам следует быть осторожными при обновлении Qt. Но в этом — проверке на отсутствие ошибок и написании врЕменных патчей — и состоит работа дистрибутивов.

Зато в Qt Software тестировали плазму с Qt 4.5. И установили, что она лучше работает с Qt 4.5, чем 4.4.3, хотя патчи qt-copy не будут бесполезны. Наконец заработал трей. Улучшилась и работа других компонентов KDE, например, отпала необходимость задавать QT_NO_SHARED_PAINTER=1 при запуске Kontact. БОльшую часть исправлений из Qt 4.5 в ветку 4.4 не переносили. В 4.5 заметно возросла производительность, в том числе при отрисовке.

Кроме того, чем раньше начнут широко использовать Qt 4.5, тем больше будет багрепортов и тем скорее его исправят. Особенно полезна обратная связь с сообществом KDE.

И вообще, релиз-кандидат Qt 4.5 гораздо стабильнее релиз-кандидата Qt 4.4 10-месячной давности.

>>> Подробности в блоге labs.trolltech.com

★★★★★

Проверено: Shaman007 ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> А я вот после долгих лет гнома на четвёртых кедах и вполне доволен. И что? Не нойте, анонимусы. :)

сначала с арча на сусю, теперь с гнома на четвёртокеды

как бы такая дорожка до макоси не довела :)

overmind88 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Умираю, но не сдаюсь. Если я таки сдохну - считайте меня кдешнегом версии 4.

Мы никогда не забудем ваш подвиг - переключалку раскладок!

ptarh ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Если я таки сдохну - считайте меня кдешнегом версии 4.

может всё-таки лучше коммунистом? :)

overmind88 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>сначала с арча на сусю, теперь с гнома на четвёртокеды

Вы за мной следите? :) А вообще, закономерно же - что ещё под сусей использовать? :)

>как бы такая дорожка до макоси не довела :)

Нет-нет, я не люблю сладких смазливых мальчиков, дорога туда мне закрыта. :)

ptarh ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Призрак коммунизма уже почти растворился в воздухе. А призрак КДЕ 4 еще только появляется...

svu ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> доколе "программисты" будут просирать всё новые и новые ресурсы???

ИМЕННО! Кризис на дворе!

eXOR ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>не смог настроить рабочий стол, чтоб ярлыки кидать?

Нет, я избавлен от этой привычки реального виндуз^W кдеешника.

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> ТРОЛЛЬТЕХ!!!
> А я-то думал чего у меня такая неприязнь к сей библиотеке! )


Давно уже Nokia. А Nokia - это огого! Они еще с Neo дружили.

eXOR ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Отставить разрушать легенду!

Гному еще переход на версию 3 светит. И обновления в переключалке языков! :)

eXOR ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Нет, я избавлен от этой привычки реального виндуз^W кдеешника.

собственно из ваших постов следует, что на более серьезные настройки вы неспособны. вам видимо стоит остаться на винхр

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Гному еще переход на версию 3 светит.

Веселье может начаться быстрее, чем многие думают :)

http://live.gnome.org/GnomeShell

>The project is still in early stages of development; the plan is to have prototype versions available for GNOME 2.26, have it be an optional feature in GNOME 2.28, and to replace the existing components for GNOME 3.0

http://www.vuntz.net/journal/2008/10/22/494-desktop-shell-from-the-user-exper...

http://live.gnome.org/Boston2008/GUIHackfest/WindowManagementAndMore

ptarh ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

кактус выделки не стоит ...

cap838383 ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>собственно из ваших постов следует, что на более серьезные настройки вы неспособны. вам видимо стоит остаться на винхр

Да меня и гента вполне устраивает, камрад.

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>С хигджеком и мигелюхами?

Я теперь всю дорогу до универа гыкать буду и меня в психушку заберут. По вашей вине!

ptarh ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Plasma team не хочет поддерживать плазму с Qt4.5, QtSoftware не хочет поддерживать Qt4.4 для KDE4.2. Победит QtSoftware.

Главное QGtkStyle - остальное пофиг :) ЗЫ Ты случайно не с mns.ru ?

fpga ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>kde 4.2 хорошо работает везде

А вот хрена.Про Кубунту уже сказали,в Генте тоже через задницу-у кого нормально,у кого всё отваливается.В Сюсе действительно они лучше прочих.Вобщем фтопку такое непредсказуемое поделие.Да и сама новость кагбэ намекает (^_~)

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Что означает фраза "разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это"?

"Не хватает ни времени, ни людей, но есть более приоритетные задачи." Какие конкретно — не уточняется.

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> QtSoftware не хочет поддерживать Qt4.4 для KDE4.2.

Они, похоже, и 4.4 считают бетой, переходным этапом.

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Переводчика на мыло.

Что не нравится? Переведи, пожалуйста, эти предложения правильно

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Не сцыте гномеры - всё будет нормально ;)! Похоже эта новость и предыдущая только вас и волнует.

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Сорри за оффтоп, но не могу не удержаться и спросить - а что же тогда по мнению Тьяго Масиэйра для работы?

Не понял вопрос. Перефразируй, пожалуйста.

Если ты спрашиваешь, что по его мнению можно использовать для работы, то он пишет, что использует КДЕ 4.2, несмотря на глюки, вроде падающего каждые 5 минут Kopete.

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Самое смешное, что пока кедерасты пытаются обос^Wдоказать всему свету что кеды самые лучшие в мире, пока разрабы KDE/Qt путаются в показаниях, гноме стоит и просто работает не нагружая меня ни клизмами, ни плазмами, ни тупизмами с пересборками...

Да! И в нём не глючит gtk. :)

А подростковая нетерпимость и пафос некоторых кедеров - это вообще смешно...

shty ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>а разве в гноме уже не надо галочку ставить, чтобы поганый наутилус не открывал х*еву тонну окон, когда по папкам ходишь?

В большинстве современных дистров, у Наутилуса, по дефолту, именно эксплорер-подобный интерфейс ("х*ева тонна окон", имхо, разве, что в федоре и совместимых с ней...)

При этом, поставить эту галочку труда не составляет :), часом не "в гномском реестре" находится :) (PS: лично знаю людей эту галочку снимающую :) )...

По поводу же 4 кед, они реально тормознее висты (хоть и грузятся быстрее Гнома, но вы, надеюсь, не путаете скорость загрузки с общей скоростью работы: это разные вещи :) ).

Весь этот спор вокруг Qt, еще одно доказательство того, что Кедам пора сказать R.I.P... Они мертвый DE... :(

>Ну я вот на гном перешел с третьих кед после того, как поюзал немного четвертые.

Мигрировал на Гном, по схожей причине. И так сделали многие кадэешники...

И сколько не глядел с тех пор на 4 Кеды (делаю я это регулярно, в надежде на изменение ситуции: трешка была шикарным DE), а глядел я под разными дистрами, в том числе и, согласно многочисленным советам, под Дебианом, этот ужас везде ужас: да, в ряде мест, он менее страшен, но ужасом, от этого, меньше не становится....

ЗЫ. Кстати говоря, если принять и понять логику Гнома, то начнешь, по настоящему, его ценить...

unihorn ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> кактус с колючками в т.ч. внутри мякоти.

Есть такой фрукт, с колючками глубоко внутри. Называется ананас. Так исторически сложилось, что поедание ананасов, в отличии от кактусов, считается нормальным и не связывается с наркоманией. Почему-то наводит на мысли о Windows.

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> Кстати говоря, если принять и понять логику Гнома, то начнешь, по настоящему, его ценить...

Где логика в отсутствии вменяемой документации на настройки GTK в .gtkrc?

Да, я тоже ушёл с KDE. На XFCE.

question4 ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Очередная методичка по накладыванию пластыря и бинтованию 4х кед :) Вы умеете повеселить после работы :)

p.s. Перешёл на гном после использования 4х кед начиная с 4.1 до 4.2 - теперь можно спокойно работать, не парясь о том, что что-то падает, тормозит, глючит - гном просто работает, и это зачетно.

MuZHiK-2 ★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

после таких тредов у меня возникает ощущение, что у меня какие-то особые десктоп и лаптоп, 90% постящих либо абсолютно глупы, либо нагло врут

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Где логика в отсутствии вменяемой документации на настройки GTK в .gtkrc?

Ну... Отсутствие вменяемой документации, или ее устарелость, это общее узкое место Линукса (в той же Виндоус (о Бзде уже не говорю), с этим много лучше (хотя тоже не идеально))... :(

И под логикой я имел в виду логику работы данного DE, его особенности как DE, и подобные вещи...

Но вот по поводу gtkrc (если я правильно понял о чем речь)..., честно говоря..., конфиг настолько прозрачный и понятный (по крайней мере, свои темы, мне, отсутствие документации на это дело, создавать не мешает (было достаточно изучить пару вариантов этого конфига))...

unihorn ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>p.s. Перешёл на гном после использования 4х кед начиная с 4.1 до 4.2 - теперь можно спокойно работать, не парясь о том, что что-то падает, тормозит, глючит - гном просто работает, и это зачетно.

А с чего ты на 4.1 перешел?

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>после таких тредов у меня возникает ощущение, что у меня какие-то особые десктоп и лаптоп, 90% постящих либо абсолютно глупы, либо нагло врут

я просто оставлю это здесь

http://www.linux.org.ru/jump-message.jsp?msgid=3494922&cid=3495568

пусть анонимус сам посмотрит на тех кто нагло врет

HighwayStar ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>Что означает фраза "разработчики плазмы не тестировали KDE 4.2.0 с Qt 4.5, у них недостаточно ресурсов на это"?

ресурсов компа не хватает, чтобы кеды запускать

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>> Или наш любимый деятель опенсорса сидит на ЛОРе из IE? :о)
> Увы. Если б Вы увидели их секурные полиси в виндах - Вы б обрыдались. Какой там огнелис, тут смд.ехе и регедит.ехе не запустить, 90% контрол-центра просто отсутствует. ВООБЩЕ ничего из софта не установить, кроме того что уже установлено.


"Изя, и эти люди агити'уют нас за gconf!"

gaa ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>>Кдешники вы там уж определитесь, то можно, то нельзя использовать. Я уже задолбался кеды ставить и сносить.

>Вот и Линус тоже... Почему с гномом такого не бывает?

дооо, гномом пользоваться нельзя... стабильно...

anonymous ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

> ЗЫ. Кстати говоря, если принять и понять логику Гнома, то начнешь, по настоящему, его ценить...

А если потом мозг для чего-нибудь понадобится? Нет уж, пока мозги требуется, логику гнома принять не получится.

gaa ★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

>FU, We Are Not Your Beta-Testers Army!

Может быть ты платишь троллтечу за их софт? Или контрибутишь патчи?

Gary ★★★★★ ()

Re: А всё-таки KDE 4.2 должен использовать Qt 4.5. Мнение сотрудника Qt Labs.

Наверно, крогда наступит вендекапец, линуксоиды начнут ожидать гномо/кедокапец.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.