LINUX.ORG.RU

Сопровождением Qt 5.15 займётся проект KDE

 ,


2

1

После того, как Qt Company объявила о прекращении доступа к репозиторию с исходным кодом LTS-веток Qt, новые исправления в ветке 5.15 смогут получить только обладатели коммерческой лицензии. Публичный доступ к ранее опубликованному коду будет сохранён, но новые изменения и исправления будут оставаться закрытыми для сообщества. Исключениями являются только Qt WebEngine и объявленный устаревшим Qt Script, которые имеют внешние зависимости под лицензией LGPL.

Для поддержки ветки Qt 5 в актуальном состоянии до момента завершения миграции сообщества на версию Qt 6, проект KDE начал формирование собственной коллекции патчей Qt5PatchCollection, в которой они взяли на себя ответственность за сопровождение патчей к Qt 5.15, включающие в себя исправления ошибок и уязвимостей. Патчи доступны в виде Git-репозиториев под названиями, соответствующими определённым Qt-модулям.

На данный момент в репозитории включены только патчи, одобренные проектом Qt, но также рассматривается возможность внесения и неутвержденных ими патчей в будущем. KDE не планирует выпускать отдельные версии своего набора патчей, а будет развивать его как непрерывно пополняемую коллекцию, началом которой будет последняя версия общедоступного кода Qt 5.15.

Сроки поддержки пока не оговариваются. Известно лишь то, что планируется осуществлять поддержку до тех пор, пока у сообщества будет запрос на использование Qt 5.15, или пока Qt 6 полностью не заменит 5 версию в разработке свободного ПО.

>>> Сообщение о закрытиии Qt 5.15

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Исключениями являются только Qt WebEngine и объявленный устаревшим Qt Script, которые имеют внешние зависимости под лицензией LGPL.

Очередная иллюстрация, почему корпоративные шавки тявкают на ГПЛ

bender ★★★★★ ()
Ответ на: комментарий от intel

The Foundation has license agreements with The Qt Company, Digia and Nokia. The agreements ensure that the Qt will continue to be available as Free Software. Should The Qt Company discontinue the development of the Qt Free Edition under the required licenses, then the Foundation has the right to release Qt under a BSD-style license or under other open source licenses. The agreements stay valid in case of a buy-out, a merger or bankruptcy.

https://kde.org/community/whatiskde/kdefreeqtfoundation/

Forgotten ()

А как это работает, объясните. Вот есть такой коммит. Судя по ревьюеру (Thiago Macieira) - от самих разработчиков Qt. Он фиксит баг в ветках 5.15, 6.0, 6.1, но он сделан 6 дней назад, т.е. после закрытия исходников 5.15. Это как он стал доступным для KDE?

me21 ()
Ответ на: комментарий от me21
  1. Он мог быть бекпортирован из открытых 6.0 и 6.1 в 5.15
  2. Вроде разработчики Qt предоставляют доступ KDE к закрытым веткам (как будто бы у них была коммерческая лицензия) и они могут брать от туда патчи. Но я не особо в курсе до чего они в итоге договорились.
anonymous ()

Всё больше убеждаюсь, что под GTK и особенно QT лучше не писать. Задолбали ломать обратную совместимость и выкидывать старые версии. Tk, iup, wxWidgets, nana, flutter, electron - что угодно, но только не GTK/Qt говнище.

InterVi ★★★ ()

Исключениями являются только Qt WebEngine и объявленный устаревшим Qt Script, которые имеют внешние зависимости под лицензией LGPL.

Так QtWebEngine был промаркирован для отправки на кладбище.

kostyarin_ ★★ ()
Ответ на: комментарий от EXL

WineLib и WinAPI – всегда стабильный API к вашим услугам и в Linux.

Забавно, конечно. Есть какие-то примеры чисто Linux'ового ПО, которое его использует? Наверное он не очень удобен в современных реалиях. Привязок к разным языкам нет, устаревшая архитектура. Даже Microsoft пытается его заменить или надстроить.

ls-h ★★★★ ()
Ответ на: комментарий от anonymous

А где сломали совместимость то?

Попробуйте запустить код для Qt 3 на Qt 5 или GTK 2 на GTK 3. Даже совместимости на уровне исходников нет, о бинарной совместимости нет и речи. У WinAPI совместимость исходников начиная с Windows 1.0 и бинарная совместимость начиная с Windows 95.

X512 ()
Последнее исправление: X512 (всего исправлений: 1)
Ответ на: комментарий от Ros

Почему не рассматривается ситуация, что Кути скоро вовсе опроприетарят?

А что значит «Опроприетарят»? Старые версии закрыть нельзя, свободная лицензия не даст. Можно только перестать выпускать новые. Но в этом случае вероятность появления форка и оттока на него сообщества приближается к 100%. И особенно удобно это сделать именно сейчас, пока Qt 6 в его нынешнем виде мало кому нужен.

Кутешники не дураки и понимают это. Вообще, не надо их демонизировать. Они вполне законно хотят кушать. Другое дело, что делают они это, скорее всего, не лучшим образом. Я уже писал, что вероятно, им бы стоило ввести более гибкий набор коммерческих лицензий, а также убрать дурацкий запрет на смешивание лицензий, который только отпугивает потенциальных покупателей. С другой стороны, они на своём месте, им, возможно, виднее :\

hobbit ★★★★★ ()
Ответ на: комментарий от anonymous

Это вряд ли. Если завтра QT Company решит не отдавать qt6 под открытой лицензией вообще, то всё, любые изменения внесённые в 6ю ветку - это уже другой продукт. KDE да, последнюю версию Qt со свободной лицензией сможет освободить ещё сильнее. Но на практике Qt5 уже сейчас под LGPL, её уже сейчас можно использовать как линкуемую библиотеку к проприетарному софту, так что единственная разница, что кто-то сможет взять Qt5 и на его основе создать свой закрытый продукт не лицензируя свои изменения. Таким образом выпуск QT5 под BSD никак не повлияет на бизнес Qt Company, он повредит самой KDE: сейчас, когда Qt5 лицензирована под GNU, любой, изменяющий её под свои нужды вынужден отдавать код, а так все будут менять у себя, а назад не выпускать.

khrundel ★★ ()
Ответ на: комментарий от ls-h

Привязок к разным языкам нет

Пфф, там же чистый Си, привязать можно к чему угодно.

Даже Microsoft пытается его заменить или надстроить.

Ага, начиная где-то с Висты. Только грамотные менеджеры всякий раз заменятелей осаживают.

Меня помимо прочего, забавляет, что под вайном я могу Shift+Ins использовать с обеими клавишами Ins, как на нумпаде, так и с традиционной. И со стрелками так же. Между тем, в нативных линуксовых приложениях такое поведение хрен настроишь (т.е. какие-то инструкции попадаются, но оказываются устаревшими либо неработающими).

hobbit ★★★★★ ()