LINUX.ORG.RU

KDE Frameworks 5

 , ,


1

3

Седьмое июля 2014.

Сообщество KDE с гордостью представляет KDE Frameworks 5.0. Frameworks 5 - это новое поколение приведённых к модульному виду библиотек KDE, оптимизированных для простоты интеграции с приложениями на Qt. Frameworks предлагают широкий спектр функциональности общего назначения в готовых рецензируемых и хорошо оттестированных библиотеках под открытой лицензией. В релиз входят более 50 различных модулей для интеграции аппаратного обеспечения, поддержки файловых форматов, предоставления дополнительных виджетов, проверки орфографии, методов отрисовки и многого другого.

KDE Frameworks представляют собой попытку переделки библиотек платформы KDE4 в набор независимых, кросс-платформенных модулей, которые будут немедленно доступны всем разработчикам на Qt для упрощения, ускорения и уменьшения цены разработки на Qt. Каждый из модулей обладает портируемостью, хорошей документацией; оттестирован и соблюдает стандарты Qt Project. Модули разработаны по доказавшей свою состоятельность модели разработки KDE со строгими сроками релизов, ясными и равными для любых третьих сторон возможностями принять участие, открытым управлением и гибким лицензированием (LGPL).

KDE Frameworks имеют чёткую структуру разделённых на категории и уровни зависимостей. Категории относятся к зависимостям времени исполнения:

  • «Функциональные» (Functional) элементы не имеют никаких сторонних зависимостей
  • «Интеграция» (Integration) определяет код, который может иметь таковые зависимости (для архитектур или ОС)
  • «Решения» (Solutions) имеют обязательные зависимости времени исполнения

Уровни относятся к зависимостям времени компиляции от других модулей:

  • Модули Уровня 1 не имеют зависимостей от других и нуждаются только в Qt или других значимых библиотеках.
  • Модули Уровня 2 могут зависеть только от Уровня 1.
  • Модули уровня 3 могут зависеть как от Уровня 2, так и от Уровня 1.

Процесс перехода от платформы KDE4 к KDE Frameworks под руководством ведущих технических сотрудников сообщества длится уже более 3-х лет.

Особенности:

На данный момент доступно более 50 модулей KDE Frameworks. Вы можете ознакомиться с полной документацией к каждому из них здесь

KArchive - предлагает поддержку многих популярных кодеков сжатия данных в самодостаточной, функциональной и простой в использовании библиотеке архивации и разархивации. Просто скормите ей файлы - не нужно больше переизобретать методы сжатия в ваших Qt-приложениях!

ThreadWeaver - предлагает высокоуровневое API для управления потоками c помощью служб (jobs). Она позволяет легко ставить в очередь исполнение потоков, используя зависимости между ними и исполняя потоки по мере выполнения этих зависимостей, значительно упрощая использование многопоточности.

KConfid - модуль для хранения и извлечения конфигурационных данных. Он предлагает API, ориентированный на группы, работает с INI-файлами и соответствующими спецификациям XDG каскадными каталогами. Генерирует код, основываясь на XML-файлах.

Solid - предоставляет определение аппаратного обеспечения и может уведомлять приложение о накопительных устройствах и томах, статистике процессора, батареи, энергопотребления, сети и Bluetooth. Для работы с зашифрованными томами, энергопотреблением и сетью, однако, требуются работающие дополнительные службы.

KI18n - добавляет поддержку Gettext к приложениям, делая проще процесс интеграции переводов приложений Qt в больших инфраструктурах крупных проектов.

>>> Подробности

★★★

Проверено: fallout4all ()

Так, а я не понял: у них теперь сроки релизов KF (библиотек) и Plasma2 (оболочка) рассинхронизированы?

carasin ★★★★★ ()

Удваиваю вопрос про плазьму

Valkeru ★★★★ ()

Модули Уровня 1 не имеют зависимостей от других и нуждаются только в Qt или других значимых библиотеках.
Модули Уровня 2 могут зависеть только от Уровня 1.
Модули уровня 3 могут зависеть как от Уровня 2, так и от Уровня 1.

Личкрафтненько

yoghurt ★★★★★ ()

что ж, попробую собрать из оверлея

anonymous ()

Я так понимаю, это всё для девов, для эндюзера никаких плюшек нет?

duott ★★★★★ ()
Ответ на: комментарий от garik_keghen

Своё мнение оставь при себе. Тому кому надо - тот пользуется, кому не надо - сидите и помалкивайте.

anonymous ()

Пишу в эпичном треде.

anonymous ()

Кстати, вот по модулям у меня такой вопрос.

GTK+, вернее, так называемый G-Stack, всегда критиковался [кутешниками/кадеешниками] за то, что там типа переплетено овер9к библиотек, которые вместе образуют жирный жирный рантайм.

Теперь вот в кделибс модули на модулях сидят и модулями погоняют. И что, рантайм в итоге не жирный всё равно?

yoghurt ★★★★★ ()
Ответ на: комментарий от carasin

Судя по всему, да, вот здесь пишут, что сама Плазма выйдет 15-го июля, то есть через ещё неделю.

Adonai ★★★ ()
Последнее исправление: Adonai (всего исправлений: 1)
Ответ на: комментарий от yoghurt

Так раньше всё это грузилось жирной кучей в память чем-нибудь вроде libkdecore, libkdeui, а теперь по кускам по требованию загружается.

Я так понимаю, они там Qt Plugin System вовсю используют.

Adonai ★★★ ()

непонимайтунг

там что теперь такая свалка что приходится все разгребать по полочкам?

splinter ★★★★★ ()
Ответ на: комментарий от carasin

Горе мейнтейнерам дистров.

Раз в 7 лет можно, был бы только в этом смысл.

haku ★★★★★ ()

Я правильно понимаю, что без plasma next это не пощупаешь?

mbr ()

Ждем новые кеды, главное что бы не такие глючные как первые версии четверки.

petyanamlt ★★★ ()

Главное, чтоб процесс миграции по-человечески описали. А то открыл список пакетов (там, практически, по одному пакету на бинарник), и глаза разбегаются, что из этого критично, а что и послать можно. Особенно, вкупе с лаконичными описаниями:

Название              : kio
Версия                : 4.100.0-1
Описание              : KIO
arcanis ★★★★ ()

Как там плазма? Падает или нет?

anonymous ()
Ответ на: комментарий от petyanamlt

Четвертые были написаны с нуля. Пятые мигрируют постепенно.

LightDiver ★★★★★ ()
Ответ на: комментарий от duott

Я думаю, для юзера это будет заключаться в том, что установка какого-нибудь окуляра (просто пример) не утянет в зависимостях все кеды.

theNamelessOne ★★★★★ ()

Файловые диалоги в KDE-шных программах теперь будут Qt-шные или как всегда?

Ostegard ()
Ответ на: комментарий от arcanis

Они решили наверстать упущенное и пойти по пути, из-за которого патрег, в своё время, отказался собирать гном в слаке? :)

h4tr3d ★★★★★ ()

ну хоть что-то развивается

kto_tama ★★★★★ ()
Ответ на: комментарий от arcanis

Как можно пользоваться кедами и не знать что такое KIO?

fenris ★★★★★ ()
Ответ на: комментарий от Ostegard

надеюсь, что останутся кдешные, ибо кутешные убоги

anonymous ()
Ответ на: комментарий от mbr

Наоборот, как раз без плазмы это щупать и можно теперь. Суть в том, что всё теперь работает независимо друг от друга. Плазма - это отдельный продукт, набор модулей KF5 - тоже.

P.S. Если я ошибся и ты о том, когда конечные пользователи это «увидят вживую», то да, с выходом новой плазмы.

Adonai ★★★ ()
Последнее исправление: Adonai (всего исправлений: 1)
Ответ на: комментарий от fenris

Как можно пользоваться кедами и не знать что такое KIO?

Я вот не знал, хотя только кеды и использовал всегда.

Я много потерял?

petyanamlt ★★★ ()
Последнее исправление: petyanamlt (всего исправлений: 1)
Ответ на: комментарий от petyanamlt

Немного потерял, но явно любопытства к тому, какие процессы в системе запущены, не проявлял.

Это общий посредник ввода-вывода в кедах. Уведомления о процессе копирования он выдаёт, например.

P.S. А ещё у него много рабов. Их можно увидеть в krunner'e, когда копируешь что-нибудь по WebDAV или самбе.

Adonai ★★★ ()
Последнее исправление: Adonai (всего исправлений: 1)
Ответ на: комментарий от fenris

я для примера, что вспомнил сразу, то и привел :)

И вообще: тыц. Что из этого нужно, что нет - я хз, и описания доставляют, хоть на каждый пакет на апстрим ходи (дык долго ж).

arcanis ★★★★ ()

Лишь бы этот kde frameworks не тянул с собой все остальное kde.

slyjoeh ★★ ()

Охренеть, внезапненько. Ну что, ждем в ~amd64. Дома на тестовой виртуалке с кубунту потыкаю. Месяц назад оно уже как-то работало, и не падало как пол года назад.

leg0las ★★★★★ ()

Толстый тормознутый комбайн. Мне кажется, что таким можно пользоваться только людям с синдромом Windows Vista, 7, 8. А нормальным лучше держаться подальше.

timuaz ()

Побежал ставить на виртуалку

overmind88 ★★★★★ ()

Как вы думаете, Qt4 теперь быстро умрет? Не хотелось бы долго иметь 2 ветки Qt4 и Qt5. Или может Qt5 обратно совместим с Qt4 и Qt4 просто не понадобится?

Rinaldus ★★★★★ ()

ухх, прочитал и аж захотелось пописать под КДЕ...

anonymous ()

Отличная новость! Возможно что-то пригодится для своих проектов.

BlackRaven86 ()
Ответ на: комментарий от Rinaldus

Когда я портировал свою программу под пятые кути, пришлось добавить толЬко 2-3 макроса для старых кутей.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.