LINUX.ORG.RU

Вышел Eclipse 3.4 «Ganymede»

 , , ,


0

0

Сегодня вышла новая версия Eclipse (3.4 "Ganymede").

Из новых возможностей отметим пакет для моделирования и работы с UML (Eclipse Modeling Tools) и интеграцию с BIRT (Eclipse IDE for Java and Report Developers). Также значительно улучшен редактор кода, появилась возможность навигации с помощью панели BreadCrumb, сделано множество других исправлений и улучшений.

Скачать: http://ftp.heanet.ie/pub/eclipse//tec...

>>> Подробности

Re: Вышел Eclipse 3.4 "Ganymede"

PS: пока официально раздается только спонсорам, поэтому качайте с зеркала :)

Kardinal ()

Re: Вышел Eclipse 3.4 "Ganymede"

Это хорошо!

ПС: /me боится что плагины от 3.3 опять потеряли совместимость с новой средой.

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

eclispe не нужен

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

JDT нинужен, вот CDT 5.0 - это да :)

tailgunner ★★★★★ ()

Re: Вышел Eclipse 3.4 "Ganymede"

Бесконечно рад этой новости. Хотя 3.3 мне более чем хватало.

anonymous ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

Так а что качать? я раньше классик едишн тянул, а здесь его нет. Поясните пожалуйста.

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

эм. я наверное не в теме и в танке, но зачем нужен Эклипс?
подсветка синтаксиса?
сам пишу в vim, и как там было "бородат, неженат, девственник.."

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

Только вчера скачал 3.3
> появилась возможность навигации с помощью панели BreadCrumb
что это такое?
> Также значительно улучшен редактор кода
Как?
Есть смысл качать? CDT, PyDev работают?

snizovtsev ★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

>ПС: /me боится что плагины от 3.3 опять потеряли совместимость с новой средой.

ну учитывая их привычку менять апи с версии к версии всё так и будет

ПС. идея наше всё. эклипс не нужен

Tails ()

Re: Вышел Eclipse 3.4 "Ganymede"

Ого, сам эклипс сейчас стартует гораздо шустрее чем 3.3, в работе летает, а CDT 5.0 просто супер!

Joe_Bishop ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

>эм. я наверное не в теме и в танке, но зачем нужен Эклипс? подсветка синтаксиса? сам пишу в vim, и как там было "бородат, неженат, девственник.."

Я наверное тоже не в теме и в танке, но зачем нужен вим(nono|jedit|emacs|joe|etc...)? подсветка синтаксиса? Сам пишу в еклипсе(nono|jedit|emacs|joe|etc...), и как там было...

З.Ы. надеюсь показал всю идиотичность твоего вопроса?

anonymous ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от Tails

Re: Вышел Eclipse 3.4 "Ganymede"

Как бывший разработчик плагинов для Eclipse, заявляю - API там очень стабильное и достаточно удобное для разработчиков.

Если какой-то из плагинов отваливается - это, обычно означает, что он использовал внутреннее API, не предназначенное для использования сторонними плагинами и ССЗБ.

З.Ы.: сам использую vim и счастлив 

anonymous ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

> Так а что качать? я раньше классик едишн тянул, а здесь его нет. Поясните пожалуйста.

А для чего тебе классик? Если нужно на жабе писать - тяни Eclipse Java, если J2EE/EJB - тяни Eclipse JEE. А классик - это " Eclipse Platform, Java Development Tools, and Plug-in Development Environment, including source". Неужто тебе нужен PDE с сорцами?

Kardinal ()

Re: Вышел Eclipse 3.4 "Ganymede"

Eclipse не нужен.

Хотя нет, нужен конечно для таких удобных технологий, как Java, но для реальных задач, с которыми приходится иметь дело в OpenSource - сомнительно. Я уже не первый раз пробую, впечатления отрицательные. Юзабилити сосет не по детски - я не смог прокрутить панель вкладок, не смог добавить уже существующий файл в проект. Дальше смотреть уже отпадает желание. Может все это и можно сделать, но тогда мне проще юзать emacs, чем искать что-то в этом "интуитивном" интерфейсе. Убогая VisualStudio и то удобнее в этом плане.

Плюс плагины. Их как-бы много, а на самом деле 98% - это все Enterprise, Java и подобное. Нормальных плагинов для обычных задач либо нет, либо они в убогом состоянии (тот же CUSP поддерживает только SBCL - это только при поверхностном рассмотрении. "It runs SBCL and hooks into the Swank half of Slime").

Все это - ИМХО.

xTERM ★★ ()

Re: Вышел Eclipse 3.4 "Ganymede"

Со времён появления Netbeans 6.0, Eclipse 3.3 как-то мрачно сливал... Ну ладно, дадим Eclipse ещё один шанс...

localstorm ()

Re: Вышел Eclipse 3.4 "Ganymede"

Эклипс пропихивают проприеритаршики, однако учитывая тормоза на больших проектах, и бесполезность на малых он просто не нужен.

Yurand ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

>Как бывший разработчик плагинов для Eclipse, заявляю - API там очень стабильное и достаточно удобное для разработчиков.

как бывший разработчик плагина под эклипс заявляю что при переводе нашего плагина с 3.1.2->3.2 проблемы есть. в другой конторе мой друг переводил другой плагин с 3.2->3.3 тоже самое. вообще эти клоуны любят метод в другой класс перенести, один класс на 2 разбить, просто перенести класс в другой метод иногда даже ничего не меняя

Tails ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от Tails

Re: Вышел Eclipse 3.4 "Ganymede"

>просто перенести класс в другой метод иногда даже ничего не меняя

имел в виду в другой package.

Tails ()

Re: Вышел Eclipse 3.4 "Ganymede"

Ну и названия они придумывают... БрэдКрамб - конешно, боковая панель, сразу ясно, ктобы сомневался. А GingerHouse у них нету случаем? И чем жабистей технология, тем изобретательнее названия...

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

>появилась возможность навигации с помощью панели BreadCrumb

интересно с идеи слизали или со свисты. лучше бы оптимизацией своего поделия занялись бы

Tails ()

Re: Вышел Eclipse 3.4 "Ganymede"

Надо давать линк на нормальный ченжлог.

Bohtvaroh ★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

> но зачем нужен Эклипс?

> но зачем нужен вим(nono|jedit|emacs|joe|etc...)?

eclim рулит! :P

naryl ★★★★★ ()

Re: Вышел Eclipse 3.4 "Ganymede"

Попробовать что-ли?
CDT в 3.3 не понравился, по сравнению с нетбинсом сосал со свистом.
Там даже автодополнение толком не работало :[
Вот если бы в идее поддержка C нормальная была бы.

WatchCat ★★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от Midael

Re: Вышел Eclipse 3.4 "Ganymede"

> А он там есть?

Есть. Для каждого майлстоуна был полноценный список изменений со скриншотами и многбуквенными пояснениями.

Bohtvaroh ★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4

> эм. я наверное не в теме и в танке, но зачем нужен Эклипс?
> Я наверное тоже не в теме и в танке, но зачем нужен вим(nono|jedit|emacs|joe|etc...)?

вы меня извините, но если взять ряд: "nono, jedit, eclipse, emacs, vim, joe", то эклипс выглядит несколько нелогичным хотя бы по той простой причине что это "среда разработки". некий монстр раздутой функциональности (я пробовал в нём работать).
поэтому не могли бы вы всё же ответить, зачем нужен Эклипс?
точно так же не понимаю зачем нужен винамп если есть mplayer.

anonymous ()
Ответ на: Re: Вышел Eclipse 3.4 от anonymous

Re: Вышел Eclipse 3.4

> вы меня извините, но если взять ряд: "nono, jedit, eclipse, emacs, vim, joe"

Из всего этого ряда только eclipse умеет нормальный автокомплит и рефакторинг для явы (не знаю, что там с другими языками). Так что вопрос вообще-то звучит глупо.

Bohtvaroh ★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 от Bohtvaroh

Re: Вышел Eclipse 3.4

спасибо. "а ларчик просто открывался" :-)

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

Народ, а чего-то флейма маловато!

Хотелось бы поболее "Eclipse лажа" и в ответ "да ты дурень, поставь плагин xxx". Авось чего-нибудь полезное и скажут :-)

anonymous ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от snizovtsev

Re: Вышел Eclipse 3.4 "Ganymede"

> Есть смысл качать? CDT, PyDev работают?

CDT работает лучше, чем всегда (версия 5.0), PyDev тоже работает.

tailgunner ★★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от Tails

Re: Вышел Eclipse 3.4 "Ganymede"

нормально поддерживаемые плагины параллельно разрабатываются на девелоперской ветке, так что и с новым релизом тоже будут работать

Yupiter ()
Ответ на: Re: Вышел Eclipse 3.4 от anonymous

Re: Вышел Eclipse 3.4

> поэтому не могли бы вы всё же ответить, зачем нужен Эклипс?
> точно так же не понимаю зачем нужен винамп если есть mplayer.

Вопрос достаточно философский "зачем вообще что-то нужно". Вам так не кажется?
Иногда бывают моменты когда важно задать вопрос без надежды получить ответ, но это ваш случай.
Кстати, зачем вам вообще нужно задавать подобные вопросы? ;)

wwarlock ()
Ответ на: Re: Вышел Eclipse 3.4 от wwarlock

Re: Вышел Eclipse 3.4

виноват, поправка:

> без надежды получить ответ, но это ваш случай.

следует читать:

без надежды получить ответ, но это НЕ ваш случай.

wwarlock ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от anonymous

Re: Вышел Eclipse 3.4 "Ganymede"

Eclipse круто! ставь своей команде Jazz (see jazz.net) и будет тебе счастье. :)

//SunSunich

anonymous ()

Re: Вышел Eclipse 3.4 "Ganymede"

Это, конечно, хорошо... Скажите, а только у меня не завёлся плагин Sbuclipse (для свна) с руганью на не найденные репозитарии?

voronaam ★★ ()
Ответ на: Re: Вышел Eclipse 3.4 "Ganymede" от xTERM

Re: Вышел Eclipse 3.4 "Ganymede"

> Юзабилити сосет не по детски - я не смог прокрутить панель вкладок,

Что значит "прокрутить панель вкладок"?

> не смог добавить уже существующий файл в проект

Очень просто. Скопировать файл в файловой системе в нужное место, а потом в Eclipse на проекте сделать F5.

kda ★★★★★ ()

Re: Вышел Eclipse 3.4 "Ganymede"

Eclipse, IMHO - отличная IDE, сделанная инженерами, а не всякими теоретиками. Веду большой java-проект в этой среде. Выбрал именно eclipse после того, как посмотрел, насколько удобно и быстро будет работаться в сравнении с другими (JBuilder, IDEA, Netbeans).

Droid790 ()
Ответ на: Re: Вышел Eclipse 3.4 от Bohtvaroh

Re: Вышел Eclipse 3.4

> автокомплит и рефакторинг для явы (

А так же подсветку синтаксиса (именно лучшую), инкрементальный компилятор, дебаггер.

kda ★★★★★ ()
Ответ на: Re: Вышел Eclipse 3.4 от anonymous

Re: Вышел Eclipse 3.4

>вы меня извините, но если взять ряд: "nono, jedit, eclipse, emacs, vim, joe", то эклипс выглядит несколько нелогичным хотя бы по той простой причине что это "среда разработки". некий монстр раздутой функциональности (я пробовал в нём работать). поэтому не могли бы вы всё же ответить, зачем нужен Эклипс? точно так же не понимаю зачем нужен винамп если есть mplayer.

Да низачто не извиню =) Эклипс вкупе с аптаной и epic-ом для меня вполне удобный и освоенный инструмент. Вот за этим он мне и нужен. Вы довольны? А верещать про альтернативы не надо, я про них знаю и юзать их не собираюсь =)

З.Ы. Маяковского послушайте, чтоле.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.