LINUX.ORG.RU

Обновление 319.23 проприетарного видеодрайвера NVIDIA

 , ,


0

1

Произошло обновление ветки R319 проприетарного драйвера для видеокарт NVIDIA. В нём поддерживается работа с последними версиями ядра Linux и графического X-сервера. Кроме того, драйвер доступен для других UNIX-подобных ОС.

Выпуск за номером 319.23 является корректирующим и включает следующие изменения:

  • добавлена поддержка карты GeForce GTX 780;
  • исправлена регрессия, которая могла вызывать крах X-сервера при запросе информации о графическом процессоре через NV-CONTROL на системах с несколькими видео-картами в случае, если некоторые карты не были инициализированы X-сервером;
  • исправлена ошибка, которая могла вызывать крах X-сервера при использовании объектов вершинного буфера (Vertex Buffer Objects, VBOs);
  • исправлена ошибка, мешавшая нормальной работе некоторых выпадающих меню в утилите nvidia-settings при использовании устаревших версий библиотеки GTK+;
  • улучшен механизм панорамирования RandR в случае, если текущий видео-режим меньше по размеру, чем экран X-сервера;
  • исправлена регрессия, из-за которой утилита nvidia-installer пыталась произвести пост-обработку неустанавливаемых файлов;
  • добавлены опции мета-режима (MetaMode) ForceCompositionPipeline и ForceFullCompositionPipeline;
  • добавлена поддержка разрешения 4k для HDMI (требуется графический процессор семейства Kepler или более нового);
  • в реализацию VDPAU добавлена поддержка разрешения 4k для форматов MPEG-1/2 и H.264: до 4032x4048 для MPEG-1/2 и до 4032x4080 для H.264, а также до 65536 макроблоков для обоих.

Дополнительно отмечается, что ветка R319 станет длительно поддерживаемой, а также, что она станет последней, в которой сохранится поддержка ядра Linux версий 2.4.X. В последующих мажорных выпусках драйвера будут поддерживаться ядра 2.6.X и более новые. В предыдущих ветках с длительной поддержкой (R173 и R304) поддержка ядра версий 2.4.X сохранится.

Загрузить для x86

Загрузить для x86_64

Загрузить для x86_64 (без 32-разрядных библиотек)

>>> Подробности

★★★★★

Проверено: tazhate ()

Нвидия, спасибо, что ты есть.

в реализацию VDPAU добавлена поддержка разрешения 4k для форматов MPEG-1/2 и H.264: до 4032x4048 для MPEG-1/2 и до 4032x4080 для H.264

А уже есть киношки в таком разрешении?

jitterbug ()

добавлена поддержка разрешения 4k

Точности ради - добавлена поддержка академического и кашетированного 4K, поддержки полнокадрового и широкоэкранного 4K нет. Подробности. Тем не менее это движение в верном направлении. С такими мощностями декодер справился бы с 1080p Hi10P одной левой, жаль только, что не добавляют поддержку.

добавлена поддержка разрешения 4k для HDMI (требуется графический процессор семейства Kepler или более нового)

Кто-нибудь подскажет модели мониторов, которые умеют забирать больше 1080p именно по HDMI? (А не DP или DVI-D.)

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от jitterbug

А ХЗ :) Но если прогресс пошёл по пути наращивания разрешения, то хорошо, что в драйверах реализуют его поддержку. А киношки сделают — вопрос времени.

carasin ★★★★★ ()
Ответ на: комментарий от jitterbug

А уже есть киношки в таком разрешении?

Есть например такое, но вряд ли удастся воспроизвести, так как превышает указанный лимит (см. сообщение выше).

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Точности ради - добавлена поддержка академического и кашетированного 4K, поддержки полнокадрового и широкоэкранного 4K нет.

Честно говоря, я только что узнал, что оно бывает каким-то разным :)

carasin ★★★★★ ()
Ответ на: комментарий от carasin

А киношки сделают — вопрос времени.

Киношки давно снимают и реставрируют в 4K (и больших разрешениях) но не издают, т.к. Blu-ray такое разрешение не поддерживает. По этой же причине не выпущена 48 fps версия Хоббита на дисках, стандарт Blu-ray такое не предусматривает. 4K-телевизоры начали продавать, теперь ждём, пока для них родят какой-нибудь стандарт издания фильмов.

RussianNeuroMancer ★★★★★ ()

в которой сохранится поддержка ядра Linux версий 2.4.X

Какие актуальные ветки используют эти экскременты мамонтов?

Valkeru ★★★★ ()

Кстати, как у них со сборкой из рана в кубунте сейчас? Что-то в 12-й ветке совсем не взлетало.

Valkeru ★★★★ ()

Сейчас прибегут малолетние либерасты и будут кричать про швабодку.

chromium ()
Ответ на: комментарий от chromium

Надо будет им предложить выкинуть своё железо на помойку, оно же проприетарное!

Valkeru ★★★★ ()

Средний палец линуса творит чудеса))
Пускай покажет его микрософту, адобу, аппле, амд, гигабайт, гуглу, самсунг, имаге-лайн(fl stuido - орешек для музыки), debian.org, каноникал, новелл, archlinux.org и всяким проприетарным корпорациям, а так же моей училке по информатике(я школник - да)

ubuntuawp ★★ ()
Ответ на: комментарий от ubuntuawp

Микрософту и адобу надо атомную бомбу показать, непосредственно перед её взрывом.

Valkeru ★★★★ ()
Ответ на: комментарий от Valkeru

не, пуска йвенду пилят, токо перестанут монополизировать рынок
фифти-фифти кароч)
а адоб свою хрень портирует под лялих, бзду и хурд)

ubuntuawp ★★ ()

Другие UNIX-подобные ОС это например какие?

leave ★★★★★ ()
Ответ на: комментарий от ubuntuawp

токо перестанут монополизировать рынок

Эти не умеют.

а адоб свою хрень портирует под лялих, бзду и хурд)

Щаз, ага. И исходники откроют спецом для Столлмана.

Valkeru ★★★★ ()
Ответ на: комментарий от ubuntuawp

fl stuido - орешек для музыки

Ты не шути так больше.

olibjerd ★★★★★ ()
Ответ на: комментарий от carasin

солярис таки юникс :) и что - нвидия правда под него дрова пилит? Не знал, спасибо

leave ★★★★★ ()
Ответ на: комментарий от ubuntuawp

1) Хорошо работает под wine. 2) Не орешек. 3) Ненужно.

anonymous ()
Ответ на: комментарий от anonymous

1) НЕНУЖНО
2) ЖЕЛУДЬ!!!!111АДИН
3) дай прогу, шоб дабстепчик писать, а то /dev/dsp deprecated

ubuntuawp ★★ ()
Ответ на: комментарий от ubuntuawp

Дабстеп не нужен. А хорошее музыкальное ПО под Linux уже есть, но школоте всё фрукты подавай. Мало плагинов, да, но FL Studio эту проблему не решит.

Видео специально для тебя: https://www.youtube.com/watch?v=2j8qWAz24do

anonymous ()

В предыдущих ветках с длительной поддержкой (R173 и R304) поддержка ядра версий 2.4.X сохранится.

Владельцы игро-, кинороутеров и аналогичных систем управления кофемашинами могут спать спокойно?

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Valkeru

А она считается не актуальной? Просто я за дебианом не слежу и особо не в курсе.

Behem0th ★★★★★ ()

Ни слова нет про Optimus. Интересно через сколько лет наконец появится официальная и полная поддержка Optimus для Linux.

anonymous ()

Хотя 4К телики ещё очень дорогие, радует, что поддержка уже есть. Хоть у кого-нибудь с ЛОРа есть такой?

sT331h0rs3 ★★★★★ ()

Зависоны gnome shell 3.4 еще не исправили?

zevilz ★★★ ()
Ответ на: комментарий от zevilz

Зависоны gnome shell 3.4 еще не исправили?

На наувью всё работает.

chromium ()
Ответ на: комментарий от anonymous

так пилят вроде. Но, чисто по наблюдениям, кажется они методично вставляют палки в колеса bumblebee, т.к. с каждым релизом nvidia у меня появляются новые приколы при отключении карточки.

fang90 ★★★★★ ()
Ответ на: комментарий от alex-w

на 319.17 регулярно виснет, на дровах из репов дебиана нет (304.88)

zevilz ★★★ ()
Ответ на: комментарий от kernelpanic

Что там с Optimus'ом?

Тоже это заинтересовало, ну чую реализуют они его хрен знаетъ когда

fallout4all ★★★★★ ()
Ответ на: комментарий от kernelpanic

Мне кажется, глупо ожидать таких фишек, как полная реализация Optimus'а, в рамках корректирующих выпусков блоба. Вероятно, улучшения будут в следующих мажорных обновлениях.

carasin ★★★★★ ()
Ответ на: комментарий от kernelpanic

В прошлом релизе была имитация бурной деятельности в виде заявления о официальной поддержки Optimus, а на деле это оказалось фикцией.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.