LINUX.ORG.RU

Вышел Catalyst 10.7

 , ,


0

0

Основные изменения:

  • Добавлена поддержка OpenGL ES 2.0
  • Реализована полная поддержка для Ubuntu 10.04 LTS
  • Добавлена начальная поддержка для OpenSUSE 11.3
  • Устранено аварийное завершение X-сервера в Ubuntu 10.04 LTS для систем multi-ASIC
  • Множество мелких исправлений

Скачать драйвер можно, воспользовавшись данной ссылкой.

>>> Подробности

★★★★★

Проверено: JB ()

так как Убунту 10.04 не юзает 1.8 х-сервер, то разрабы АТИ со всей мудростью решили воздержаться в ближайшие года три от поддержки оного. я правильно понял?

Kompilainenn ★★★★★ ()

OpenGL ES 2.0 для windows-only, про linux ничего не изветсно, так как официального релиза еще не было. Про новые версии X и ядра также ничего не известно, так как анонса еще официального не было.

daemonpnz ★★★★★ ()

при использовании дистрибов линукса только с одной железкой в ноуте возникали проблемы - карточка от ати. когда буду покупать следующий ноут на эти грабли уже не наступлю.

X-сервер 1.8 в текущий момент не поддерживается

Добавлена начальная поддержка для OpenSUSE 11.3

это ж как ? в сузе ж 1.8.

anonymous ()

Счастье.

Починили Half-Life под вайном (сломали ещё в 9.х) и Quake III (сломали в 10.5).

Сейчас протестим игрушки покруче.

PolarFox ★★★★★ ()

>К сожалению, X-сервер 1.8 в текущий момент не поддерживается и, скорее всего, не будет поддерживаться в ближайшем будущем.


http://www.phoronix.com/forums/showpost.php?p=138907&postcount=2

Also this driver supports Linux 2.6.34/2.6.35 and Xserver 1.8 (haven't tried 1.9).

Врут ? ))
ps: лень проверять ...

elipse ★★★ ()

*лять, эти индусы до сих пор багу с артефактами в 2D не пофиксили, а мега-команда с ForceXAA тормозит шо ппц... чорт, когда уже 2.6.35 зарелизится с powersaving'ом >_<

Andru ★★★★ ()

>X-сервер 1.8 в текущий момент официально не поддерживается

а у меня работает

anonymous ()

> OpenSUSE 11.3

Хрен там, а не поддержка. Только исталлер и пашет. Благо хоть свободные дрова radeonhd пашут.

[ 76.541] (EE) fglrx(0): Hasn't established DRM connection
[ 76.542] (II) Loading sub module «vbe»
[ 76.542] (II) LoadModule: «vbe»
[ 76.543] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[ 76.543] (II) Module vbe: vendor=«X.Org Foundation»
[ 76.543]    compiled for 1.8.0, module version = 1.1.0
[ 76.543]    ABI class: X.Org Video Driver, version 7.0
[ 76.543] (II) fglrx(0): VESA BIOS detected
[ 76.543] (II) fglrx(0): VESA VBE Version 3.0
[ 76.543] (II) fglrx(0): VESA VBE Total Mem: 16384 kB
[ 76.543] (II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
[ 76.543] (II) fglrx(0): VESA VBE OEM Software Rev: 11.10
[ 76.543] (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
[ 76.543] (II) fglrx(0): VESA VBE OEM Product: RV770
[ 76.543] (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
[ 76.585] (II) fglrx(0): ATI Video BIOS revision 9 or later detected
[ 76.585] (--) fglrx(0): Video RAM: 524288 kByte, Type: GDDR3
[ 76.585] (II) fglrx(0): PCIE card detected
[ 76.585] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[ 76.585] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[ 76.585] (EE) fglrx(0): Hasn't established DRM connection
[ 76.585] (WW) fglrx(0): Hasn't establisted DRM connection

...

[ 77.556] (II) LoadModule: «glesx»
[ 77.558] (II) Loading /usr/lib64/xorg/modules/glesx.so
[ 77.558] (II) Module glesx: vendor=«X.Org Foundation»
[ 77.558]    compiled for 1.7.1, module version = 1.0.0
[ 77.558] (II) Loading extension GLESX
[ 77.558] (II) fglrx(0): GLESX enableFlags = 512
[ 77.558] (II) fglrx(0): Acceleration enabled
[ 77.558] (II) LoadModule: «amdxmm»
[ 77.560] (II) Loading /usr/lib64/xorg/modules/amdxmm.so
[ 77.560] (II) Module amdxmm: vendor=«X.Org Foundation»
[ 77.560]    compiled for 1.7.1, module version = 1.0.0
[ 77.560] (EE) fglrx(0): XMM failed to open CMMQS connection.

....

[ 77.593] 12: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7effdc127b7d]
[ 77.593] 13: X (0x400000+0x25af9) [0x425af9]
[ 77.593] Segmentation fault at address 0x3c
[ 77.593]
Fatal server error:
[ 77.593] Caught signal 11 (Segmentation fault). Server aborting
[ 77.593]
[ 77.593]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
for help.
[ 77.593] Please also check the log file at «/var/log/Xorg.0.log» for additional information.
[ 77.593]
[ 78.101] (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.

anonymous ()
Ответ на: комментарий от anonymous

> >X-сервер 1.8 в текущий момент официально не поддерживается

а у меня работает

Патчил X? Патченные X вроде как работают.

anonymous ()

такое впечатление, что катаклизм пишет такой же бот, как автор новости

registrant ★★★★★ ()

У меня и предыдущие на 1.8 работали...

поставил сусю 11.3 - со свободными дровами не работал UFO:AI, что очень разочаровало... но нашел мануал - и все запахало со старыми дровами... наверное они просто этот минипатч включили - и все...

ссылка на мануал: http://lizards.opensuse.org/2010/07/15/ati-hd57xxx-flgrx-drivers-under-11-3/

Fragster ()
Ответ на: комментарий от Andru

>*лять, эти индусы до сих пор багу с артефактами в 2D не пофиксили, а мега-команда с ForceXAA тормозит шо ппц... чорт, когда уже 2.6.35 зарелизится с powersaving'ом >_<

{$ifdef по_секрету} А ты не тащи в дистр какие попало версии ядра и будет тебе счастье; Явно кто-то не успевает за этой гонкой; {$endif по_секрету}

Napilnik ★★★★★ ()

интересно зачем им эта затея, дровишки то как я понял нормальными не будут никогда.

anonymous ()
Ответ на: комментарий от Andru

>чорт, когда уже 2.6.35 зарелизится с powersaving'ом

А что мешает использовать релиз-кандидат? echo low > /sys/class/drm/card0/device/power_profile и вперед. Динамическое изменение частоты(dynpm) допилят в 2.6.36, в .35 дерганье от него.

TheMixa ★★★ ()

странно, у меня на арче и 10.6 работают с xorg-server~1.8
$ yaourt -S xorg catalyst

snoopcat ★★★★★ ()
Ответ на: комментарий от TheMixa

А что мешает использовать релиз-кандидат?

лень ставить ядро из aur'а )

Andru ★★★★ ()

Проверил с 2.6.34 работает хорошо. Наконец-то у меня заработал ждущий режим на ноуте.

pavstyuk ()

>Реализована полная поддержка для Ubuntu 10.04 LTS

Лучше не стало. Честно говоря, вообще изменений не заметил.

fang90 ★★★★★ ()

А в репозиториях суси появится, кто знает?

alix ★★★★ ()

> К сожалению, X-сервер 1.8 в текущий момент официально не поддерживается и, скорее всего, не будет поддерживаться в ближайшем будущем.
В каждую новость это вставлять будете? Вбросы такие вбросы.

PayableOnDeath ()

К сожалению, X-сервер 1.8 в текущий момент официально не поддерживается и, скорее всего, не будет поддерживаться в ближайшем будущем.

Так с этого и надо было новость начинать

ostin ★★★★★ ()

..

Лорчую холифагов в тред.

Кактус, да. Я лично задолбался и перелез на GTS250. Весной глядишь и 460 прикуплю, когда ажиотаж сойдет. Караул устал, теперь от АМД только камни.

Зато можно невозбранно шпилиться в BG:T :lol:

wherecat ()

А теперь проходим по ссылке http://www.phoronix.com/scan.php?page=news_item&px=ODQ0OA и читаем-AMD Catalyst 10.7 For Linux Has Eyefinity Support.

А дальше-On the Windows side, their Catalyst 10.7 rolls out support for OpenGL ES 2.0. ATI Radeon HD 2000/3000/4000/5000 series graphics cards (along with the FirePro hardware) running Windows can now take advantage of OpenGL ES 2.0 support with HTML5 for in-browser graphics rendering. However, that support hasn't yet made its way to the Catalyst Linux driver, but there are other changes packed away in this month's update.Из чего следует что автор даже не удосужился прочесть линуксовый changelog.

Исправте хоть

Fulgrim ()

[quote]К сожалению, X-сервер 1.8 в текущий момент официально не поддерживается и, скорее всего, не будет поддерживаться в ближайшем будущем.[/quote]

Вот уже 5-ая новость про выход каталиста с этой фразой. Причем повторяется слово в слово. Вы где её берёте, товарищи?

Od1n ()

Почему у меня от чтения новостей про катаклизм всегда лыба до ушей?

lester_dev ★★★★★ ()
Ответ на: комментарий от anonymous

>>X-сервер 1.8 в текущий момент не поддерживается

Добавлена начальная поддержка для OpenSUSE 11.3

это ж как ? в сузе ж 1.8.

Ну дык начальная же - распаковываться его научили, а вот работать еще нет.

lester_dev ★★★★★ ()
Ответ на: комментарий от snoopcat

>странно, у меня на арче и 10.6 работают с xorg-server~1.8

Тс-с-с! Никому не говори, а то криворукие от зависти помрут.

Но скажу по секрету: в генту тоже работают. Только смысла в 1.8 особого нет, когда 1.7 хорошо пашет.

GluckMan ★★★ ()

ubuntu 10.04 + xorg edgers - сервер 1.8.x, все работает с 10.7

B084 ★★ ()

Похоже из-за этих драйверов не судьба мне заюзать rolling release дистр на ноуте. Подсуетились бы уже, неужели в 1.8 так много изменилось? Или все-таки он поддерживается и Без Костылей?

DreamDragon ()

с выходом последних версий xf86-video-ati отказался от катаклизма. Артефактов нет, 3d работает прекрасно. Единственный минус - через вайн пресловутое 3D не пашет.

Oyster ()
Ответ на: комментарий от Oyster

> Единственный минус - через вайн пресловутое 3D не пашет.
оно и с проприетарным не особо пашет. К примеру на днях пробовал поиграться на ноуте в dawn of war - soulstorm, который на десктопе с gentoo & nvidia всегда шел просто замечательно, получил кучу глюков. Или, может, у gentoo wine лучше чем у debian?

DreamDragon ()
Ответ на: комментарий от B084

>ubuntu 10.04 + xorg edgers - сервер 1.8.x, все работает с 10.7

Дык, об том-то и речь - всё работает, было бы желание и совсем чуточку умения. Зачем ждать унылого индуса, когда как в хорге от версии к версии по сути ничего значимого не меняется? Весь хорг давно пора менять, перенося часть функционала в ядро (что медленно, но делают) а не чужих костылей ждать.

GluckMan ★★★ ()
Ответ на: комментарий от deity

Ололо, wine непредсказуем как сортировка рэндомом!!!=)

Oyster ()

vaapi на 5ххх не заработало?

anonymous ()
Ответ на: комментарий от anonymous

> при использовании дистрибов линукса только с одной железкой в ноуте возникали проблемы - карточка от ати. когда буду покупать следующий ноут на эти грабли уже не наступлю.

После покупки ноута и установки на него линукса возникли проблемы с:

  • ethernet адаптером JMicron,
  • тачпадом Elantech,
  • звуковушкой на чипе Conexant 5069,
  • вебкамерой,
  • карточкой от ати :)

Проблема с карточкой от ати решилась через 1.5 месяца после покупки (через где-то 3 месяца после выхода карточки) с выходом официально поддерживающего ее драйвера. До этого проблема заключалась только в том, что в углу показывалась шняга «Unsupported hardware».

Так что установка линукса на старый ноут и покупка нового ноута имеют разные грабли, и не надо так категорично.

zzo ()
Ответ на: комментарий от zzo

Ну если уж на то пошло, то установка _разных_ дистрибутивов линукса на старые/новые ноутбуки имеет разные грабли.

P.S. У самого с ubuntu/mint/opensuse/fedora/sabayon не возникло никаких проблем, кроме кривовато работающего блютуза.

Oyster ()

ктото исчо юзает их УГ?

tazhate ★★★★★ ()

Модеры, уберити уже эту вызывающе неверную информацию про X 1.8 и не работающий на них fglrx.

http://pastebin.org/422515 Ставится без патчей и прочей ахинеи.

daemonpnz ★★★★★ ()
Ответ на: комментарий от registrant

>такое впечатление, что катаклизм пишет такой же бот, как автор новости

Не такой же, а он и есть. Инфа 100%.

amorpher ★★★★★ ()
Ответ на: комментарий от daemonpnz

Да не переживай, это уже традиция тролей: рассуждать о драйвере которым они не пользуются. Тем кому надо даже предыдущая версия работала, кто-то патчил меняя в configure версию, кто посообразительнее догадались как в xorg-server-1.8 задать ignoreabi. В этой версии ограничения сняты, но проблема из-за которой заблочен был 1.8 осталась не решенной, хотя без компиза она вообще никак не проявляется.

TheMixa ★★★ ()

Баг с текстурами на id Tech 3 исправили?

Quasar ★★★★★ ()
Ответ на: комментарий от daemonpnz

Ну тогда всё довольно неплохо. Ждёмс следующих релизов.

Quasar ★★★★★ ()
Ответ на: комментарий от anonymous

Мсье неосилятор? Читайте мануалы по установке. У меня все поставилось без половой ебли на сусе 11.3 (630й чип).

X10Dead ★★★★★ ()

Люди, а здесъ есть владельцы ATI'шек 5000 серии??? У меня HD5770 и начиная с версии 10.6 у меня артефакты(черные или белые квадраты) в 2D!!! Причем в 3D не замечал и видео нормально играет, масштабируется, а вот в 2D просто ПЦ!!! Это как-нибудь исправить можно или это только у меня проблемы???

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.