LINUX.ORG.RU

NVidia прекращает поддержку старых видеокарт

 ,


0

0

Компания NVidia решила прекратить поддержку драйверов для видеокарт GeForce 3, GeForce 256, TNT / TNT2, Riva 128, Vanta и Quadro 2 Pro. Драйверы для этих видеокарт не будут поддерживать X-сервер 1.8, который уже входит в состав недавно вышедших OpenSUSE 11.3 и Fedora 13. В Ubuntu 10.04 LTS используется X-сервер 1.7, поэтому данные видеокарты будут поддерживаться в полном объёме. Стоит заметить, что Nv драйвер не поддерживает 3D-ускорение, а в драйвере Nouveau для данных видеокарт поддержка 3D-ускорения ещё не реализована (Nouveau имеет базовую поддержку 3D начиная с NV30 [это GeForce 5 или старше]).

>>> Подробности

★★★★★

Проверено: JB ()

Хоть бы хоть код раскрыли, сволочи...

darkshvein ☆☆ ()
Ответ на: комментарий от overmind88

Меня время поддержки nv40 поражает, уже 5 лет прошло.

KPSS ()

Кто так пишет новости? Нвидия поддерживает три (!) драйвера - nvidia, nvidia-legacy и открытый (но обфусцированный) nv.

Перечисленные видеокарты поддерживаются двумя из них. О каком драйвере речь?

Также предлагаю вынести упоминание Nouveau в отдельный абзац, с целью повышения читаемости. Например, так:

«Открытые драйвера для этих видеокарт (nv и Nouveau) поддерживают на них только 2D-режим»

Или

«Открытый драйвер для этих видеокарт (Nouveau) поддерживает на них только 2D-режим», если речь в новости таки про nv.

Alan_Steel ★★ ()
Ответ на: комментарий от Alan_Steel

> Перечисленные видеокарты поддерживаются двумя из них. О каком драйвере речь?

Legacy из ветки 71.хх

anonymous ()

Ну и правильно. Нечего держаться за устаревшие какашки мамонта. Итак вон, под оффтопиком дистрибутив драйвера 150 мегабайт весит. Рассказал бы мне кто 10 лет назад - я бы послал в нехорошее место.

ist76 ★★★★★ ()
Ответ на: комментарий от ist76

дистрибутив драйвера 150 мегабайт весит

что будет еще через 10 лет ? )))))))) даешь драйвер полтора гига!!!!

Serhio79 ()

а что насчет Geforce 2 MX (которая ближе к 4 серии чем к 3) и Geforce 4 MX ?

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

сама себе и отвечу -
Those with GeForce 2 Go, GeForce 4 MX, GeForce 4 Go, and GeForce 4 Ti graphics cards still should be getting this new support within the 96.xx.xx driver, but you may have to wait a while.

пока будут поддерживаться

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

Geforce 4 MX вроде как планируется поддерживать. По крайней мере здесь так написано.

vadik ★★ ()
Ответ на: комментарий от Sylvia

вообщем проще было написать что прекращена поддержка драйверов 71.x

те кто , пользовались 96.x пока могут жить спокойно

Sylvia ★★★★★ ()
Ответ на: комментарий от overmind88

у меня 6600, пока живём :)

+1

З.Ы.: MX440 не трогают, и то хорошо :)

AlexVR ★★★★★ ()
Ответ на: комментарий от darkshvein

>Хоть бы хоть код раскрыли, сволочи...

А что было бы? Вот Интел раскрыл код и чего? Производительность все равно ниже, при смене X.org сервера могут быть проблемы (вспоминаем Убунту 8.10). Какой смысл несет открытие кода?

anonymous ()

>В Ubuntu 10.04 LTS используется X-сервер 1.7, поэтому данные видеокарты будут поддерживаться в полном объёме.

Ну Ubuntu 10.04 LTS будет поддерживаться еще 2 года, тем более всегда есть Нуво, думаю врятли кто то еще во что то играет на таких карточках.

Lucky1 ★★★ ()
Ответ на: комментарий от anonymous

Глупый анонимус. Интел лентяй. Просто код мало раскрыть, надо его отдавать в таком виде чтобы хоть другим удобно было его адаптировать.
И да, производительность нормальная, что за толстота?

darkshvein ☆☆ ()
Ответ на: комментарий от Lucky1

> Ну Ubuntu 10.04 LTS будет поддерживаться еще 2 года

Ну Ubuntu 10.04 LTS будет поддерживаться еще 3 года

fxd.

Root-msk ★★★★★ ()
Ответ на: комментарий от anonymous

Не развивает, но поддерживает. Цитирую:

Корпорация NVIDIA объявила, что развитие драйвера nv прекращено. В частности, этот драйвер не будет поддерживать новые поколения GPU и DisplayPort. Существующий уровень функциональности на уже поддерживаемых видеокартах сохранится.

Перевожу: «новых плюшек добавлять не будем, оставим только багфикс».

Да, баги они тоже чинят сильно неохотно, согласен.

Alan_Steel ★★ ()
Ответ на: комментарий от anonymous

2D не тормозит, XV работает, lightsmark 2008 запускается.

KPSS ()

>GeForce 3, GeForce 256, TNT / TNT2, Riva 128, Vanta и Quadro 2

У кого-то это ещё сохранилось и живо? не верю.

Tails ()
Ответ на: комментарий от darkshvein

>Глупый анонимус. Интел лентяй. Просто код мало раскрыть, надо его отдавать в таком виде чтобы хоть другим удобно было его адаптировать. И да, производительность нормальная, что за толстота?

Глупый регистрант. Если код мало раскрыть, то так и пиши: хоть бы код раскрыли и работали над ним как сейчас. Хм, а если работать как сейчас, то зачем раскрывать? И я уже написал: даже открытый Интеловский код адаптируется плохо. Так в чем профит для Нвидии?

И я не сказал, что производительность Интела плохая. Я сказал, что она ниже. Сравни хотя бы работу Celestia на Linux и Windows. А виноваты, конечно, Интел, да. Вам код раскрыли, адаптировать его никто нормально не может, но виноваты Интел, да.

В общем извиняюсь, если кому-то это покажется грубыми и толстыми наездами, но уже задолбало это: откройте код. На кой его открывать? вы лично будете его пилить? Или что, откроют и сразу все по волшебству станет работать лучше и быстрее? По примеру Интела видно, что ничего это не даст, чудес не бывает, так что пусть лучше Нвидия делают все как сейчас есть. И да, лучшее - враг хорошего.

anonymous ()
Ответ на: комментарий от anonymous

>А что было бы? Вот Интел раскрыл код и чего? Производительность все равно ниже

вот странно. А я думал, что сам факт публикации кода делает его быстрее. Надо же, какое разочарование...

AVL2 ★★★★★ ()
Ответ на: комментарий от AVL2

И то хорошо. ATI/AMD уже пару лет назад убило x1xxx в своих драйверах.

fdd2 ()
Ответ на: комментарий от Alan_Steel

>Не развивает, но поддерживает.

Ок, но тогда не надо было упоминать рядом с поддержкой ветки nvidia, она-то развивается.

anonymous ()
Ответ на: комментарий от anonymous

>И я не сказал, что производительность Интела плохая. Я сказал, что она ниже. Сравни хотя бы работу Celestia на Linux и Windows. А виноваты, конечно, Интел, да. Вам код раскрыли, адаптировать его никто нормально не может, но виноваты Интел, да.

Ты продолжаешь открывать мне глаза.

Я ведь и не подозревал, что на свете нет никаких других критериев, кроме скорости. Работа из коробки, поддержка всех фич в xrandr, kms и прочие шняжки - все ерунда и ничто.

В свое оправдание скажу, что не один я такой. Сони тоже зачем-то ставит в ноуты две видеокарты - интел и нвидию, хотя нвидия по любому быстрее.

Скорей поди и открой им глаза тоже...

AVL2 ★★★★★ ()

Слава Богу пронесло пока: моя GeForce 2 MX/MX400 в 96.48.xx.

anonymous ()
Ответ на: комментарий от Tails

/me покосился на Nvidia Vanta, лежащую в коробке

Да, вполне себе живая )

YAR ★★★★★ ()

как говорят пользователи нвидиа в таких случаях : «не нужно»

registrant ★★★★★ ()

>NVidia прекращает поддержку старых видеокарт

Давно бы пора.

zibert ★★★ ()

Вот также недавно поломали поддержку старых ATI карт (r290 и др.): нормального 3D до сих пор нет, а в openSUSE 11.1 было.

GladAlex ★★★★★ ()
Ответ на: комментарий от zibert

>Давно бы пора.

Ага, только теперь старый лозунг о том, что MS со своим Windows-ом заставляет покупать новое железо не работает: в Линуксе тоже самое: или сиди на старых дистрибутивах или покупай новое железо.

GladAlex ★★★★★ ()

Сначала ATI, потом NVidia :(

Ждем, пока Intel забьет на i740.

AEP ★★★★★ ()
Ответ на: комментарий от Viglim

>> Хоть бы хоть код раскрыли, сволочи...

Это их код, а не твой. Не хотят — не открывают.


Всё сходится. Имеют право не открывать - и не открывают, сволочи. Ещё один пример того, что если производитель не открывает драйвера сразу - то ему насрать на пользователей.

naryl ★★★★★ ()
Ответ на: комментарий от GladAlex

> или сиди на старых дистрибутивах или покупай новое железо.

Или используй нормальные дистрибутивы, например, Gentoo.

naryl ★★★★★ ()

Вспоминается пропагандический ролик Линакса, где тот ну просто летает на старом железе. Да оно хотя бы там запускалось, не то что летало!

Mrxrrr ()
Ответ на: комментарий от GladAlex

> Ага, только теперь старый лозунг о том, что MS со своим Windows-ом заставляет покупать новое железо не работает: в Линуксе тоже самое: или сиди на старых дистрибутивах или покупай новое железо.

Даёшь поддержку CGA и ридеров перфокарт в Linux!

Данные карты просто уже не актуальны. Поддержка 2D в них есть, т.е. для простенького файл-сервера на старом железе проблем не будет. Хочешь гонять полноценное 3D - задумайся о новой, более производительной карточке, вне зависимости от того, какая ОС.

cruxish ★★★★ ()
Ответ на: комментарий от Mrxrrr

> Вспоминается пропагандический ролик Линакса, где тот ну просто летает на старом железе. Да оно хотя бы там запускалось, не то что летало!

Ещё один. nv работал, работает и будет работать. Ещё есть nouveau.

cruxish ★★★★ ()
Ответ на: комментарий от GladAlex

>Ага, только теперь старый лозунг о том, что MS со своим Windows-ом заставляет покупать новое железо не работает: в Линуксе тоже самое: или сиди на старых дистрибутивах или покупай новое железо.

Проприетарный нвидиевский блоб ближе к МС, чем к линуксу.

anonymous ()
Ответ на: комментарий от Tails

У меня TNT2. Правда, думаю ненадолго. Но всё же.

queen3 ★★★★★ ()
Ответ на: комментарий от anonymous

> Проприетарный нвидиевский блоб ближе к МС, чем к линуксу.

Это каким же местом он относится к MS?..

cruxish ★★★★ ()

Жаль. На своей TNT2 я еще иногда могу третью кваку побегать..

mamantoha ()

а где теги [Phoronix],[Британские ученые]?

bad_zombi ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.