LINUX.ORG.RU

NVidia прекращает поддержку старых видеокарт

 ,


0

0

Компания NVidia решила прекратить поддержку драйверов для видеокарт GeForce 3, GeForce 256, TNT / TNT2, Riva 128, Vanta и Quadro 2 Pro. Драйверы для этих видеокарт не будут поддерживать X-сервер 1.8, который уже входит в состав недавно вышедших OpenSUSE 11.3 и Fedora 13. В Ubuntu 10.04 LTS используется X-сервер 1.7, поэтому данные видеокарты будут поддерживаться в полном объёме. Стоит заметить, что Nv драйвер не поддерживает 3D-ускорение, а в драйвере Nouveau для данных видеокарт поддержка 3D-ускорения ещё не реализована (Nouveau имеет базовую поддержку 3D начиная с NV30 [это GeForce 5 или старше]).

>>> Подробности

★★★★★

Проверено: JB ()

Ответ на: комментарий от Quasar

>ждём полноценного 3D в свободных дровах, несильно отстающего по производительности от fglrx

это будет легко сделать, если принять во внимание, что и в fglrx 3D работает через анальное отверстие

Fracta1L ()
Ответ на: комментарий от GladAlex

Да. Какую соберешь, такую и поставишь. Вот только на старых компах получим обогреватель :), так что выход давно ясен - не юзать проприетарь.

Deleted ()
Ответ на: комментарий от anonymous

>Глупый регистрант. Если код мало раскрыть, то так и пиши: хоть бы код раскрыли и работали над ним как сейчас. Хм, а если работать как сейчас, то зачем раскрывать? И я уже написал: даже открытый Интеловский код адаптируется плохо.

Гюльчатай, а Гюльчатай милая, открой личико?
ААА!
Ну нах нах нах, лучше назад закрой!

darkshvein ☆☆ ()
Ответ на: комментарий от Alan_Steel

>Ты что, никогда индусокода не видел? Он тоже бывает нечитаемым. Это не делает его закрытым.

Главное, что индусокод пишут непосредственно люди и при необходимости модификации они сами же в нём будут разбираться. А нечитаем он потому, что по-другому индусы писать просто не умеют. А в случае с nv у nvidia есть более читаемый вариант, но они нам его не дают, а дают версию, в которой понимаемость того, что делает этот код, специально ухудшена. В
этом и проявляется закрытость данного кода.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от anon_666

Это на какой карточке у тебя

OpenGL version string: 3.3.0 ... OpenGL shading language version string: 3.30 ...

?

daemonpnz ★★★★★ ()
Ответ на: комментарий от AVL2

Сони тоже зачем-то ставит в ноуты две видеокарты - интел и нвидию, хотя нвидия по любому быстрее.

Для энергосберегающих режимов ващета.

Creed ()
Ответ на: комментарий от queen3

Улыбнулся

«Ненадолго» и ты это говоришь спустя 10-12 лет с момента её выпуска ?

Creed ()
Ответ на: Улыбнулся от Creed

Да я старый компьютер из чулана вытащил недавно, как вынужденная мера, не думаю что долго буду ТАК мучаться ;-)

queen3 ★★★★★ ()
Ответ на: комментарий от darkshvein

> Просто код мало раскрыть, надо его отдавать в таком виде чтобы хоть другим удобно было его адаптировать.

Ох лол, да вы же зажрались.

mix_mix ★★★★★ ()
Ответ на: комментарий от mix_mix

You are moron.
Я тебе дам кривой ява код , а ты потом е*ись с ним. И раскрыли не код, а спеки.

darkshvein ☆☆ ()
Ответ на: комментарий от Quasar

а когда атишный блоб будет поддерживать х11 1.8?

uju ★★ ()
Ответ на: комментарий от GladAlex

Ну может и пора когда-то выйти с анабиоза и обновить железо..

zibert ★★★ ()
Ответ на: комментарий от zibert

Ну может и пора когда-то выйти с анабиоза и посмотреть куда катится, а местами идёт мир, и увидеть, что выгоднее деньги вложить в себя, а не в железо.

GladAlex ★★★★★ ()
Ответ на: комментарий от zibert

А зачем обновлять, если старое ещё не сломалось и устраивает в техническом плане?

Ttt ☆☆☆☆☆ ()

звериный оскал nvidia :(

anonymous ()
Ответ на: комментарий от zibert

на твои деньги — с удовольствием!

anonymous ()
Ответ на: комментарий от navrocky

>Тем более что под линупсом полно игр для которых такие карточки за глаза.

Поставь туда MS DOS, качественных игр будет в десятки раз больше :3

anonymous ()

Любителям срача ATI vs NVidia - итоги:
* закрытый блоб ATI поддерживает карты последних трех лет, и только на старых иксах
* закрытый блоб NVidia поддерживает карты, выпущенные последний десяток лет, и большинство - на последних иксах
* декодирование H.264 на ATI под линухи появилось пол года назад
* декодирование H.264 на NVidia под линухи работает уже полтора года
* библиотека для вычислений на NVidia GPU (CUDA) доступна года три
* библиотека для вычислений на ATI GPU (CUDA) доступна... когда?
* открытые дрова ATI пишутся по открытым спекам с пафосом и пиаром по всем форумам
* открытые дрова NVidia пишут несколько человек без спеков и пафоса, а работают они не хуже
* пользователи NVidia живут надеждой, что открытые драйвера когда-нибудь допишут, а тем временем пользуются закрытыми
* пользователи ATI просто живут надеждой, что открытые драйвера когда-нибудь допишут, спеки же есть

Какие еще аргументы не названы?

PS: NVidia-вцы не откроют код никогда - они не могут открывать чужой код, а по слухам в драйверах использовался код, написанный сторонними компаниями

anonymous ()
Ответ на: комментарий от daemonpnz

>R300-500 работают нормально, не?

Нормально это в 10 раз медленнее, чем аналогичные карточки от nvidia на блобе?

anonymous ()
Ответ на: комментарий от GladAlex

1.6 вроде ещё в стабильной ветке крепко сидит :) Но 1.7 придётся замаскировать

anonymous ()
Ответ на: комментарий от anonymous

> * библиотека для вычислений на ATI GPU

называется FireStream и должна уже почти год работать

anonymous ()
Ответ на: комментарий от darkshvein

Хоть бы хоть код раскрыли, сволочи...

Зачем тебе код говномамонта? Лучше б код последних дров открыли, это да.

the_warlick ()
Ответ на: комментарий от anonymous

Любителям срача ATI vs NVidia - итоги:

Спасибо, анончик. В момериз на случай видушко-срача и для выбора ноутбука. Хотя и так понятно, что брать нужно с Нвидией.

the_warlick ()
Ответ на: комментарий от the_warlick

>Зачем тебе код говномамонта?
Надо же будет старое железо как то поддерживать, к новому ядру готовить.

darkshvein ☆☆ ()

Так может у ati не так уж и плохо всё? Последний драйвер от ati вроде неплох, еще немного и нвидию догонят.

anonymous ()
Ответ на: комментарий от darkshvein

Согласный! Либо спеки открыть, что не будут, но так было бы лучше. Или код в читаемом виде.

trueshell ★★★★★ ()
Ответ на: комментарий от anonymous

> закрытый блоб ATI поддерживает карты последних трех лет, и только на старых иксах

Странно, у меня работает. xorg 7.5

Достаточно новый? каталист 10.5 если чего.

trueshell ★★★★★ ()
Ответ на: комментарий от GladAlex

Все можно себе позволить, дабы захотеть, и правильно обращаться с деньгами )) А то как у теперешней молодежи, на пиво и сиги деньги есть, на видяху - нет. Для таких анабиоз продлится. Не соглашусь, что копейку нужно на себя тратить, но и в старье жить тоже не годиться.У меня был шкаф 70-го года выпуска, и всем устраивал, но Я обновил на новый, и ничего, стало лучше жить, корона не спала.

zibert ★★★ ()
Ответ на: комментарий от GladAlex

Много чего может больше 10 лет работать, а ты на нем сможешь 10 лет работать? Я точно не смогу ибо привык к быстрому современному железу.

Reset ★★★★★ ()

Я уж думал как на АТИ все закроют. Так обидно было когда год видюха ati -x550-x1650 перестали поддерживать,а на нвидиа пока живем на 8600GT и 6200 в коробке

aybegramotnuy ()
Ответ на: комментарий от Reset

Ноут служит не больше 3х лет.

/me покосился на ThinkPad 1999 года выпуска и напечатал на нем этот пост...

Sith ★★★★★ ()
Ответ на: комментарий от note173

нормально, в отличие от АТИ, которые выкинули поддержку еще не устаревших карт

AMD в отличие от nvidia сначала спеки дала, а ЭТИ положили на вас большой и толстый - жрите что дают

Sith ★★★★★ ()
Ответ на: комментарий от anonymous

Нормально это в 10 раз медленнее, чем аналогичные карточки от nvidia на блобе?

толсто...

Sith ★★★★★ ()
Ответ на: комментарий от Reset

Много чего может больше 10 лет работать, а ты на нем сможешь 10 лет работать? Я точно не смогу ибо привык к быстрому современному железу.

что Семка не тормозит теперь?

Sith ★★★★★ ()
Ответ на: комментарий от trueshell

В 7.5 входит сервер 1.7, который в общем-то стабильный, но уже можно считать его старым, т.к. в марте 2010 состоялся релиз 1.8 с главной плюшкой - заменой hal на udev

anonymous ()
Ответ на: комментарий от the_warlick

Хотя и так понятно, что брать нужно с Нвидией.

Помаду сначала стери у Че Гевары и тогда поймешь какую видюшку лучше брать :)

Sith ★★★★★ ()
Ответ на: комментарий от anonymous

Или там всё ложь и у Вас под 800 кадров в секунду? :)

доколе будем тупить и сравнивать холодное с горячим:

Нормально это в 10 раз медленнее, чем аналогичные карточки от nvidia на блобе?

и еще раз:

открытый vs блоб = толсто

ЗЫ: по ссылке Gallium3D ...

Sith ★★★★★ ()
Ответ на: комментарий от Ttt

>А зачем обновлять, если старое ещё не сломалось и устраивает в техническом плане?

Не обновляйтесь, Я ж вас не заставляю. Большинство компаниям всегда выгодней держать вектор движения на будущее, а не зацикливаться на старом, поэтому и прекращают поддержку старого оборудования, нечего удивляться.

zibert ★★★ ()
Ответ на: комментарий от Sith

>AMD в отличие от nvidia сначала спеки дала

...шумная толпа не собиралась расходиться. Все давно уже привыкли, что почти ничего не работает. И даже когда было официально заявлено, что никогда уже работать не будет, никто не удивился.

На трибуне появился один из представителей ATI с ведром. Выплеснув содержимое ведра в толпу, он тут же бросился бежать - но толпе было не до него. С детским восторгом толпа ревела и собирала содержимое ведра, отдирая от подошв и срывая с себя вместе с клочьями одежды, а монотонный гул «Спеки!.. Это же Спеки...» наполнил площадь.

anonymous ()
Ответ на: комментарий от Sith

>открытый vs блоб = толсто

будто блоб ати хорошо работает :)

anonymous ()
Ответ на: комментарий от zibert

Большинство компаниям всегда выгодней держать вектор движения на будущее, а не зацикливаться на старом, поэтому и прекращают поддержку старого оборудования, нечего удивляться.

а как фанбои Нвидии волосы на жопе рвали, когда АМД выкинула поддержку устаревших карт из блоба! зато сейчас у них это «вектор движения на будущее» - двуличные бесстыжие ваши рожи ;)

Sith ★★★★★ ()
Ответ на: комментарий от anonymous

будто блоб ати хорошо работает :)

это другой вопрос, но сравнивать надо корректней на будущее

ЗЫ: у меня всегда хорошо работал :) (9600-9250-3650-4670 + не мои 1950-4650-47хх)

Sith ★★★★★ ()
Ответ на: комментарий от zibert

>Не обновляйтесь, Я ж вас не заставляю.

А если в новых иксах или новом ядре, с которыми не работает старый драйвер, устранены критические баги или добавлены новые нужные мне фичи? Почему я из-за них должен весь компьютер менять, хотя по производительности старый вполне подходит?

Большинство компаниям всегда выгодней держать вектор движения на будущее, а не зацикливаться на старом, поэтому и прекращают поддержку старого оборудования, нечего удивляться.


Пусть дадут возможность заниматься поддержкой другим людям. Даже если не хотят показывать пользователю, как работает его видеокарта и открывать код, то всё равно проблему при желании можно решить. Пусть отделят логику от интерфейса взаимодействия с Х-сервером и предоставят этот секретный модуль в виде объектного кода. Или в виде обфусцированного кода на языке высокого уровня.

Ttt ☆☆☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.