LINUX.ORG.RU

Вышел xserver-1.8.0

 ,


0

0

Самое важное нововведение: udev пришел на замену HAL. Устройства ввода теперь используют HAL-подобные конфигурационные файлы xorg.conf.d. Реализована поддержка DRI2.2, а также swap-событий.

Впервые xserver-1.8.0 появится в дистрибутивах Fedora 13 и OpenSUSE 11.3, Ubuntu 10.04 будет базироваться на 1.7. Поддержка в проприетарных драйверах есть пока только у Nvidia.

скачать исходники

>>> Подробности

★★★★★

Проверено: Dimez ()

Ответ на: комментарий от anonizmus

У меня
1) lcd-монитор, не элт. Все хорошо.
2) терминус вполне даже эталон для любых шревтов, имхо
//скриншот скриншота как-то странно звучит.

NekoExMachina ()
Ответ на: комментарий от anonizmus

Шрифты в убунте - это фееричный 3.14зд2.71ц. Дефолтно еще более-менее, но когда начинаешь крутить - ужас.

tensai_cirno ★★★★★ ()
Ответ на: комментарий от tensai_cirno

Дефолтно еще более-менее, но когда начинаешь крутить - ужас.


Не крути, ибо «с дуру можно и йенг сломать» (с)

anonizmus ()
Ответ на: комментарий от tensai_cirno

...
Мне так и не пояснили, хотплаг ЧЕГО и КУДА.
новоподключенные джойстики по usb еще в ubuntu 7.10 работали.

NekoExMachina ()

Поддержка в проприетарных драйверах есть пока только у Nvidia.

Да уж поди попереписывай под иксы дрова, постоянно ломают совместимоть и с каждым разом не смотря на увеличивающиеся мощности машин, иксы тупят все больше и больше, тьфу мля.

erfea ★★★★★ ()
Ответ на: комментарий от NekoExMachina

http://en.wikipedia.org/wiki/VDPAU#cite_note-9
VDPAU can be described as the X Window System equivalent of the Microsoft's DxVA (DirectX Video Acceleration) API for Windows.[4]
..
И
...
Later cards based on the G9x series cores eg the 8400GS and the 8800GTS 512mb (G92 core) are supported. Nvidia currently has no plans to introduce support for the unsupported hardware.[8] All supported graphic devices are listed in Nvidia PureVideo.
..
а теперь смотрим тут:
http://nvworld.ru/kb/pregf8gpus/gf6600/
да, нас дурили просто раньше доблестные писаки дров,
а потом, «разрешили» использовать «пятую передачу» на «не всех» машинах.

elipse ★★★ ()

Поставил из git, работает нормально.

dark_lord ()
Ответ на: комментарий от morbo

> Да уж ладно, всё-таки скрины своей фри он на ЛОР выкладывал.

В следующий раз буду ставить тег <irony>.

Igron ★★★★★ ()

Кроме Убунту, Федоры и Сюса у нас дистрибутивов вообще нет, и в последних уж точно раньше, чем в Арче и Генту появляются новинки.

silvanus ()

Gentoo

[1] «x11» /var/lib/layman/x11

Уже появился ебилд xorg-server'а, xorg-driver'ов еще нет :)

ezoteric ()
Ответ на: Gentoo от ezoteric

Re: Gentoo

странный ты гентушник. в оверлее сто лет позавчера в обед как есть 1.8RC ксорг-сервер. и драйвер под него сто лет в четверг назад как собирался. дай угадаю, у тебя проприетарщина?

v0rbis ★★ ()
Ответ на: Re: Gentoo от v0rbis

> в оверлее сто лет позавчера в обед как есть 1.8RC ксорг-сервер

В каком

ezoteric ()
Ответ на: комментарий от ezoteric

x11 не?

// я кстати собрал с USE="-udev" и словил море позитива, ибо опыт после xorg+hal хоть и дал пользу с xorg+udev да не много....

v0rbis ★★ ()
Ответ на: комментарий от v0rbis

x11-base/xorg-drivers

Available versions: 1.6 (~)1.7 [M](~)9999[1]

//hal уже давно выкинул

ezoteric ()
Ответ на: комментарий от ezoteric

конкретно что не собирается? у меня xf86-video-ati живет и радуется тому что не nvidia (в т.ч. xf86-input-synaptics) , примерно с xorg-server-1.4 =)

может я не читал весь тред и фанатично вторгся :D

v0rbis ★★ ()
Ответ на: комментарий от v0rbis

конкретно что не собирается?

x11-base/xorg-server:0

!!! All ebuilds that could satisfy ">=x11-base/xorg-drivers-1.8" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/xorg-drivers-9999 (masked by: package.mask)
/var/lib/layman/x11/profiles/package.mask:
# Don't let people install these accidentally


(dependency required by "x11-base/xorg-server-1.8.0" [ebuild])
ezoteric ()
Ответ на: комментарий от ezoteric

размаскируй?

/etc/portage/package.unmask

добавь keyword из layout'a x11 и будь счастлив, если гентушник, а не ССЗБ-на-вольную-голову.

просто я не знаю на сколько у тебя опыт общения с гентой. и насколько уровень использования текущего ебилда xorg. я давно уже сижу на -9999 версиях.

v0rbis ★★ ()
Ответ на: комментарий от v0rbis

> Уже появился ебилд xorg-server'а (1.8), xorg-driver'ов (1.8 еще нет, есть только 1.7) еще нет :)

fixed для непонятливых

я давно уже сижу на -9999 версиях.

Иксы не держу принципиально на 9999, ибо проприетарная nvidia (nouveau убог)

просто я не знаю на сколько у тебя опыт общения с гентой

xD

ezoteric ()
Ответ на: комментарий от ezoteric

хамишь? =)

// на работе я давно уже предложил страйкбол либо ринг с полным контактом... бояться =)) 113кг лифтера хе-хе. в общем не знаю что у тебя такого невозомжоного, размаскируй все что надо и смотри дальше.

v0rbis ★★ ()
Ответ на: комментарий от v0rbis

> хамишь? =)

Не привык хамить, просто не люблю когда не читают сообщения и начинают чему-то учить

в общем не знаю что у тебя такого невозомжоного, размаскируй все что надо и смотри дальше.

Размаскировывать ничего, нет просто xorg-driver'ов 1.8 версии еще, 9999 размаскировывать не вариант

ezoteric ()
Ответ на: комментарий от ezoteric

учить

да нет.. по умолчанию - кругом одни гентушники =).

у нас нет более варианта, нежели -9999 =) забыл, что гентушник?

мне даже интересно.. что в итоге получится. но нежели не вариант "-9999", то даже и не знаю.

v0rbis ★★ ()
Ответ на: комментарий от Deleted

>>А когда там nvidia научится KMS?

Сказано с таким пафосом, словно это OpenGL 5 какой-то :}

По правде говоря, пора бы уже...

AVL2 ★★★★★ ()
Ответ на: комментарий от PayableOnDeath

>А ведь хомячкам что xorg.conf, что XML пофиг

а, ну эту песню я уже слышал. хомячки пожинают плоды пофигизма: раз им пофиг - все решат разработчики.

теперь еще год будут отлаживать

я специально в новости написал, кто будет отлаживать, а кто - нет. ну, список на полноту не претендует.

им нужен был просто front-end (CLI, а лучше GUI) к настройкам, а никто не почесался.

когда из сусе выбросили sax2 (тот самый гуй к настройкам), я даже и не заметил.

registrant ★★★★★ ()
Ответ на: комментарий от madcore

>где ты фреебсд с иксами видел?

толсто

bohm ★★★★★ ()
Ответ на: комментарий от anonizmus

> Херово смотрятся на моем мониторе, например в названиях закладок консоли некий «ореол» вокруг букв, не знаю как это обьяснить, а у тебя ЭЛТ с его аппаратным сглаживанием ? Ну и еще в консоли буквы как то... «слипаются» что ли

Ура! Наконец-то кто-то кроме меня понял, что дефолт-шрифты в убунте — жуткое радужное и зубчатое ШГ, на которое смотреть неприятно. Кстати, раньше (до 9.04 вроде) шрифты были отличные, а потом их заменили на вот это.

pevzi ★★★★★ ()
Ответ на: комментарий от NekoExMachina

> Что удобнее-то?

Очевидно, что жуткие xml-конфиги, в которых нормальный адекватный человек без бутылки не разберется (:

pevzi ★★★★★ ()
Ответ на: комментарий от anonizmus

А, или ты про фрибсдшные шрифты? Тогда я ошибся :(

pevzi ★★★★★ ()
Ответ на: комментарий от pevzi

Гламурненько, а что за шрифты ? Боюсь если я на темном фоне их поставлю будет уже не то (мне темный фон нужен, на белом тяжко глазам)

anonizmus ()
Ответ на: комментарий от anonizmus

> а что за шрифты ?
От убунтового дефолта отличается только тем что установлен полный хинтинг.

Боюсь если я на темном фоне их поставлю будет уже не то (мне темный фон нужен, на белом тяжко глазам)

А вот насчет темного фона не гарантирую (: если контраст между текстом и фоном не слишком резкий, то думаю все нормально будет.

pevzi ★★★★★ ()
Ответ на: комментарий от PayableOnDeath

какой велосипед? просто убрали лишнюю абстракцию и зависимость в лице HAL.

anonymous ()

Устройства ввода теперь используют HAL-подобные конфигурационные файлы xorg.conf.d

$ rpm -q xorg-x11-server-Xorg
xorg-x11-server-Xorg-1.7.99.902-3.20100319.fc13.x86_64
$ man xorg.conf
<...>
       The  xorg.conf and xorg.conf.d files are composed of a number of
       sections which may be present in any order, or  omitted  to  use
       default configuration values.  Each section has the form:

           Section  "SectionName"
               SectionEntry
               ...
           EndSection

       The section names are:
<...>
Ruth ★★ ()
Ответ на: комментарий от NekoExMachina

> Есть еще опенок с кедами, но он далеко, лень показывать. :)

Дык любой скрин с третьими кедами подойдет, Kubuntu например, что есть разница?

Buy ★★★★★ ()

никакого xml в конфигах нет, просто дополнительно к xorg.conf будут считываться все *.conf файлы из xorg.conf.d . Если всё вписано в xorg.conf, то xorg.conf.d можно и не использовать.

Поддержка в проприетарных драйверах есть пока только у Nvidia.

195.36.15 с 1.8.0 отказалась работать. что подразумевается под «поддержкой»?

anonymous ()
Ответ на: комментарий от Buy

'uname -a'
ага. можно алиас зафигачить, не спорю.
Я тащемто к тому, что bsd вполне себе десктоп:)

NekoExMachina ()
Ответ на: комментарий от shutty

>> World of Warcraft

Аааааа!!!!!

Ну что испугался? Да, игрушка такая есть. И в неё играют даже взрослые дяди и тёти (у нас на работе лично знаю минимум троих).

hobbit ★★★★★ ()

> Поддержка в проприетарных драйверах есть пока только у Nvidia.

4.2

//На 195.36.15 не заводится

ezoteric ()
Ответ на: комментарий от nvbn

Cобрал вчера по этой «методе» новые пакеты для Debian Lenny i386.
На fglrx 10.2 & HD 2400 воспроизведение любого mkv файла занимает 7... 10 % на CPU 2x2.3 (и под compiz-ом все аналогично)

выложил пакетики (если кому надо):
ftp://h0.org.ua/pub/elipse/debian/mplayer-vaapi-lenny/i386/

elipse ★★★ ()
Ответ на: комментарий от hobbit

> Ну что испугался? Да, игрушка такая есть. И в неё играют даже взрослые дяди и тёти (у нас на работе лично знаю минимум троих).

У меня нездоровые ассоциации с такими дядями и тетями.

shutty ()
Ответ на: комментарий от shutty

Те, с кем я общался - вполне нормальные. В том числе одна мать семейства. Естественно, она не «шпилит» по 5-6 часов в день, как школота...

hobbit ★★★★★ ()
Ответ на: комментарий от ezoteric

У меня завелось с x.org 1.8.0 на ядре 2.6.30 и драйверах 190.53. Опцию IgnoreABI включал. Более-менее работает. Если же выкинуть поддержку GL, то заводится подо всем.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.