LINUX.ORG.RU

Вышел Debian 7.0 «Wheezy»

 


5

6

Сегодня, 5 мая 2013 года, вышел новый стабильный выпуск Debian 7.0 «Wheezy». Ему предшествовал довольно долгий период разработки (2 года и 3 месяца с момента выпуска «Squeeze») и заморозки (10 месяцев). Дистрибутив включает в себя 12800 новых пакетов, всего их стало более 37000. Обновлено 70 % всех пакетов, 14 % удалено по тем либо иным причинам.

Основные изменения в структуре ОС:

  • Мультиархитектура, одна из главных целей выпуска, позволяет пользователям устанавливать пакеты с разных архитектур на одной и той же системе, при этом все зависимости будут автоматически удовлетворены.
  • Поддержка UEFI на 64-битных (amd64) системах. Тем не менее, Secure Boot всё ещё не поддерживается.
  • Две новые архитектуры: s390x (64-битный перенос для машин IBM System z), и armhf (альтернатива armel для машин ARMV7, поддерживающих аппаратные вычисления с плавающей точкой).
  • wheezy-backports теперь является частью основного репозитория.
  • Опционально доступен systemd.
  • Многие пакеты собраны компилятором gcc с установленными флагами усиления безопасности (по умолчанию в gcc эти флаги выключены, поэтому при локальной сборке ПО они не применяются).

Система установки:

  • Использование синтезатора речи в процессе установки для слепых людей.
  • Debian теперь может быть установлен на 73 языках, более дюжины из них доступно для синтезатора речи.
  • Поддержка установки в сетях, работающих только с IPv6.
  • Теперь возможна установка по WPA-защищённой беспроводной сети.
  • При новой установке по умолчанию используется файловая система ext4 (ранее использовалась ext3).
  • В качестве технологической пробы включена файловая система btrfs.

Рабочее окружение:

  • Пакет ffmpeg заменён на ответвление libav (libav-tools), который более ответственно подходит к выпуску новых версий.
  • OpenOffice.org заменён на LibreOffice, а KOffice — на Calligra.
  • В качестве графического пакетного менеджера для GNOME используется PackageKit, для KDE — Apper.

Популярное ПО, включённое в выпуск:

  • Apache 2.2.22.
  • GIMP 2.8.2.
  • GNOME 3.4.
  • GCC 4.7.2.
  • Iceweasel 10.
  • KDE 4.8.4.
  • LibreOffice 3.5.4.
  • Linux 3.2.
  • MySQL 5.5.30.
  • Perl 5.14.2.
  • PHP 5.4.4.
  • PostgreSQL 9.1.
  • Python 2.7.3 (по умолчанию) и 3.2.3.
  • Xfce 4.8.
  • X.Org 7.7.

>>> Подробности

★★★★★

Проверено: JB ()

Ответ на: комментарий от Pavval

Насколько я знаю, она основана именно на Glibc 2.11 и версия ABI у нее тоже 2.11.

tailgunner ★★★★★ ()

Отлично, скоро ставить восьмёрочку.

Deleted ()
Ответ на: комментарий от PaulCarroty

Прочитай ещё раз, возможно до тебя дойдёт сарказм написанного.

Deleted ()

Отличный новости. Пойду обновлять!

partyzan ★★★ ()
Ответ на: комментарий от Reset

Пакет, если по зависимостям (в том числе и по libc) подходит, то работать будет. Так всегда было. Ничего нового тут нет.

Programmist11180 ★★★ ()

Отлично! На будущей неделе обновлюсь.
Поздравляю с релизом всех сопричастных.

darv ()
Ответ на: комментарий от Programmist11180

А почему он должен подходить по зависимостям?

Reset ★★★★★ ()
Ответ на: комментарий от PaulCarroty

Железо новое, никаких UEFI нет, ЧЯДНТ? Тут, походу, кто-то просто дрочит на секурбут :}

Deleted ()

Хех, теперь когда мне скажут «Поставь Семерочку» я задумаюсь :)

darv ()

Приятно посмотреть на хорошо оформленную новость.

По теме: ура!

JackYF ★★★★ ()

wheezy-backports теперь является частью основного репозитория.

А как его теперь подключать?

rezedent12 ☆☆☆ ()
Ответ на: комментарий от Reset

Стабильность в дебиане ничего общего с безглючностью не имеет. Он на столько же стабилен на сколько и LTS, только софт протух на два года.

Это по сравнению с Ubuntu LTS протух ? Debian 7 по пакетам ближе к Ubuntu 12.10. На сегодня он получается неплохой альтернативой Ubuntu 12.04 - софт примерно один и по срокам поддержки до 2017 получаются оба ...

AlexLorovitch ()
Ответ на: комментарий от rezedent12

Например,

deb http://mirror.yandex.ru/debian wheezy-backports main contrib non-free

Ну или какие там в нём секции есть.

Deleted ()
Ответ на: комментарий от AlexLorovitch

Это по сравнению с Ubuntu LTS протух ? Debian 7 по пакетам ближе к Ubuntu 12.10.

ога, особенно по libc

На сегодня он получается неплохой альтернативой Ubuntu 12.04 - софт примерно один и по срокам поддержки до 2017 получаются оба ...

только вот 12.04 уже _год_ _работает_ и про него всё известно

Reset ★★★★★ ()
Ответ на: комментарий от rezedent12

А как его теперь подключать?

Как-то так:

deb http://ftp.ru.debian.org/debian wheezy-backports main
eugeno ★★★★★ ()

Отлично, пора обновляться

router ★★★★★ ()
Ответ на: комментарий от Deleted

Железо новое, никаких UEFI нет, ЧЯДНТ?

Тут походу кто-то не понимает, что такого железа очень скоро будет очень мало и задрачивает на принцип «у меня все хорошо - значит везде все хорошо».

PaulCarroty ★★★★ ()

даешь синтезатор речи не только для слепых, но и для зрячих !

kto_tama ★★★★★ ()
Ответ на: комментарий от Reset

Это по сравнению с Ubuntu LTS протух ? Debian 7 по пакетам ближе к Ubuntu 12.10.
ога, особенно по libc

Ну так и прекрасно - поэтому собранный под Debian 7 бинарник успешно будет крутиться на Ubuntu 12.04

AlexLorovitch ()
Ответ на: комментарий от vitalif

И зочем ты это сделал? :)

Срочно нужен был линукс для тестирования специфичного софта, а ловить глюки тестинга как-то неохота.

wintrolls ☆☆ ()
Последнее исправление: wintrolls (всего исправлений: 1)

заморозки (10 месяцев)

Не прошло и года. Это они поспешили, конечно.

Citramonum ★★ ()

Кстати, вопрос тем, у кого Wheezy в пределах доступности - там в ядре есть SMACK?

tailgunner ★★★★★ ()
Ответ на: комментарий от PaulCarroty

Так будет или уже? А то ты только что вещал, что уже всё.

Deleted ()
Ответ на: комментарий от AlexLorovitch

Это не интересно, так как все разработчики сейчас ориентируются на 12.04 LTS.

Reset ★★★★★ ()
Ответ на: комментарий от Deleted

Слава Сварогу, что не юзаю гноме и тем более не опущусь на кеды.
Единственная беда для меня - поломка тем, при обнолении гтк.
Но авторы тем обычно достаточно быстро упдатях их. Мне норм.

paran0id ★★★★★ ()
Ответ на: комментарий от tailgunner

Кстати, вопрос тем, у кого Wheezy в пределах доступности - там в ядре есть SMACK?

Как проверить?

grep -i SMACK /boot/config-3.2.0-4-amd64
ничего не возвращает

router ★★★★★ ()
Ответ на: комментарий от paran0id

поломка тем
Но авторы тем обычно достаточно быстро упдатях

Вот поэтому в стейбле и нет мажорных апдейтов. Одно дело, когда есть баги, которые можно подпереть костылём и забыть про них на несколько лет. Совсем другое, когда постоянно новые баги, которые нужно лечить прямо сейчас на месте. Разный подход.

Deleted ()
Ответ на: комментарий от Polugnom

Умные люди говорят, что можно вообще вместо имени релиза просто прописать testing и больше sources.list никогда не трогать.

Дураки твои «умные люди». В testing никто не обещает security update'ов

router ★★★★★ ()
Ответ на: комментарий от tailgunner

Висит переписка по этому поводу, сказано что утилит управления SMACK у них нет, а для SELinux полно, посему SMACK отсутствует.

chupasaurus ()
Ответ на: комментарий от Deleted

Часто они есть, но их никто не обещает. И часто - с задержкой. Мейнтейнер может выпустить обновление для testing, но часто на это нет времени.

router ★★★★★ ()

ДЕБИАН УМЕР

Ну вот для чего нужна поддержка мультиарча ? конечно же кроме как для проприетарных игр, драйверов винды для всякого вонючего вайфая прикрученных через костыли, недоделанных кодеков, унылого флеша, скайпа и прочих закрытых поделок ? Я уже на 6.0.7 почуял неладное когда вместо перезагрузки машины с лайва получил подгрузку ядра и так по кругу... В итоге имеем просто очередную Убанту, только сильно отсталую. Спасибо новому лидеру дебиана за это.

anonymous ()

Побойтесь бога. Не надо обсирать православный Debian, для этого есть Ubuntu треды. Что бы вы убунтоводы делали без Debian?

anonymous ()

Мультиархитектура, одна из главных целей выпуска, позволяет пользователям устанавливать пакеты с разных архитектур на одной и той же системе, при этом все зависимости будут автоматически удовлетворены.

Т.е. можно, например, на i386 удовлетворить какие-то зависимости и запускать программы для s390? Или это банальный 32-битный мультилиб для 64-битной системы появился в Дебайене с таким пафосом?

Citramonum ★★ ()
Ответ на: комментарий от Reset

Потому что не подходящий по зависимостям софт скорее всего работать не будет.

Programmist11180 ★★★ ()

Ура-ура!

P.S. Когда ждать разморозки тестинга?

sad_but_true1 ()
Ответ на: комментарий от Programmist11180

Пакет, если по зависимостям (в том числе и по libc) подходит, то работать будет. Так всегда было. Ничего нового тут нет.

Вендотролль прав, пакеты с текущего LTS на Wheezy не встанут, т.к. зависят от более новой libc. Халява закончилась.
Почему в этом у него виноват Debian а не Ubuntu, вопрос другой.

aidaho ★★★★★ ()

Пошёл переписывать соурс с тестинга на стабле....

anonymous ()
Ответ на: комментарий от Programmist11180

ага, а это почти весь софт кроме питоноподелок

Reset ★★★★★ ()
Ответ на: комментарий от sad_but_true1

P.S. Когда ждать разморозки тестинга?

Вообще-то релиз == разморозка тестинга. Сейчас тестинг (jessie) — копия wheezy, только теперь он начнёт наполняться пакетами из sid'а.

eugeno ★★★★★ ()
Ответ на: комментарий от aidaho

Если libc из experimental, то работать будет. Другое дело что не все могут себе это позволить.

Programmist11180 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.