LINUX.ORG.RU

Вышел Debian 7.0 «Wheezy»

 


5

6

Сегодня, 5 мая 2013 года, вышел новый стабильный выпуск Debian 7.0 «Wheezy». Ему предшествовал довольно долгий период разработки (2 года и 3 месяца с момента выпуска «Squeeze») и заморозки (10 месяцев). Дистрибутив включает в себя 12800 новых пакетов, всего их стало более 37000. Обновлено 70 % всех пакетов, 14 % удалено по тем либо иным причинам.

Основные изменения в структуре ОС:

  • Мультиархитектура, одна из главных целей выпуска, позволяет пользователям устанавливать пакеты с разных архитектур на одной и той же системе, при этом все зависимости будут автоматически удовлетворены.
  • Поддержка UEFI на 64-битных (amd64) системах. Тем не менее, Secure Boot всё ещё не поддерживается.
  • Две новые архитектуры: s390x (64-битный перенос для машин IBM System z), и armhf (альтернатива armel для машин ARMV7, поддерживающих аппаратные вычисления с плавающей точкой).
  • wheezy-backports теперь является частью основного репозитория.
  • Опционально доступен systemd.
  • Многие пакеты собраны компилятором gcc с установленными флагами усиления безопасности (по умолчанию в gcc эти флаги выключены, поэтому при локальной сборке ПО они не применяются).

Система установки:

  • Использование синтезатора речи в процессе установки для слепых людей.
  • Debian теперь может быть установлен на 73 языках, более дюжины из них доступно для синтезатора речи.
  • Поддержка установки в сетях, работающих только с IPv6.
  • Теперь возможна установка по WPA-защищённой беспроводной сети.
  • При новой установке по умолчанию используется файловая система ext4 (ранее использовалась ext3).
  • В качестве технологической пробы включена файловая система btrfs.

Рабочее окружение:

  • Пакет ffmpeg заменён на ответвление libav (libav-tools), который более ответственно подходит к выпуску новых версий.
  • OpenOffice.org заменён на LibreOffice, а KOffice — на Calligra.
  • В качестве графического пакетного менеджера для GNOME используется PackageKit, для KDE — Apper.

Популярное ПО, включённое в выпуск:

  • Apache 2.2.22.
  • GIMP 2.8.2.
  • GNOME 3.4.
  • GCC 4.7.2.
  • Iceweasel 10.
  • KDE 4.8.4.
  • LibreOffice 3.5.4.
  • Linux 3.2.
  • MySQL 5.5.30.
  • Perl 5.14.2.
  • PHP 5.4.4.
  • PostgreSQL 9.1.
  • Python 2.7.3 (по умолчанию) и 3.2.3.
  • Xfce 4.8.
  • X.Org 7.7.

>>> Подробности

★★★★★

Проверено: JB ()

Ответ на: комментарий от anonymous

Ладно бы Гном 3 вышел пару дней назад - подобный бред ещё можно было бы понять. Но как-бы два года уже прошло. Так что тянет на жиденький и крайне унылый вбросец. Жиденький как детская неожиданность.

Polugnom ★★★★★ ()
Ответ на: комментарий от Reset

Хуже: простой юзер. Ну чуток админю одну сеть по удалёнке. Но не более того. Зато всё работает, и железо не виновато :D Серверок у сетки на дебиане, кстати..

anonymous ()
Ответ на: комментарий от Polugnom

Обожаю Гном-3. Временно пришлось юзать стабле дебиана (6) с второгномом - так я был просто в шоке: как наши предки могли жить и работать в таком окружении?!!

anonymous ()
Ответ на: комментарий от Polugnom

Вероятно, пользователт второгнома точно так-же офигевают от третьего, как я от второго. Интерфейс другой, приходится перестраиваться, что далеко не всем комфортно. Но ты верно приметил.

anonymous ()
Ответ на: комментарий от Polugnom

Ладно бы Гном 3 вышел пару дней назад - подобный бред ещё можно было бы понять.

типа, эти косяки уже настолько родные, что обсуждать их моветон :D

anonymous ()
Ответ на: комментарий от Polugnom

крайне унылый вбросец.

БУГАГА! Дебианщик гнобит кого-то за слоупочность! Это пять!

anonymous ()
Ответ на: комментарий от anonymous

Так обсуждать и нечего. Но если хочется пообсуждать это самому с собой, я не против.

Polugnom ★★★★★ ()

GNOME 3.4. был бы второй прямо сейчас слез бы с федоры.

deity ★★★ ()
Ответ на: комментарий от Programmist11180

XFCE легко настраивается до внешнего вида Gnome 2.

А девятка легко тюнингуется до мазды.

Alsvartr ★★★★★ ()
Ответ на: комментарий от FiXer

Обанта тырит с Debian 93% пакетов

Ну а как же это... right to modify, share and redistribute и всякое такое? =)

является хомячко-ориентированным Debian с пересборкой 7% пакетов и мощным маркетингом.

Просто отлично. Когда нам не нравится что-то популярное мы используем магическое слово «маркетинг» и всем все сразу должно стать понятно. Только забываем, что маркетинг - это часть игры и просто кто-то занимается им лучше =)

Alsvartr ★★★★★ ()
Ответ на: комментарий от t500s

что можно доказать человеку, который искренне считает, что на сервере проще снести систему и поставить заново, чем обновить ее?

Где-то я читал что-то похожее про гуглосерверы. В любом случае такой подход может быть действительно проще.

Alsvartr ★★★★★ ()
Ответ на: Re: Какая гадость от anonymous

снизойду до ответа анунусу

Как ты можешь рассуждать что нужно нормальным людям? Мне плевать на твои познания виндузятников с восьмерочками, мои пристрастия к интерфейсу формировались еще до выхода 3.1 (даже не 3.11). Поверь у меня со времен MS-DOS (DR-DOS, PC-DOS), TR-DOS, опыта поболее будет. OS/2 WARP к примеру я не то, чтобы видел - использовал в продакшене. Так что попу прикройте школота. GNOME 2 - супер DE, не идеал, но твердохорошая. Стройная, без излишнего жира, и фантастичых глупостей. Мне позволяет пользоваться эффективно, быстро и радостно.

via4e ()
Ответ на: комментарий от Programmist11180

Так ведь вы обновляетесь, а не устанавливаете систему с нуля. Вот адблок уже и стоит.

Получив неадекватное поведение гнома, я сделал, скопировав в другое место, rm -rfv /home/user и пересоздал девственно чистый каталог пользователя.

Так что там ничего не было. Зуб даю.

record ★★★★★ ()
Ответ на: комментарий от eugeno

Я ставил с нуля, и у меня адблок тоже. Так что он там действительно пришит.

А вот: среди установленных пакетов есть xul-ext-adblock-plus.

Я думаю, это уже не хорошо ставить расширения за пользователя.

record ★★★★★ ()
Последнее исправление: record (всего исправлений: 1)
Ответ на: комментарий от tazhate

Почему?

Потому что
1. Почему именно адблок, чем другие расширения и авторы хуже?
2. Следующий раз вам поставят другие расширения (sponsored by the US government) - чтоб жизнь мёдом не казалась.
3. Свобода выбора хромает.
4. Браузер - внезапно - можно использовать не только для серфинга по нету, но и для того, чтобы открыть специально изготовленную страничку (презентации чего-либо и т.п.). Адблок может напортачить с отображением.
5. Мало ли еще.

record ★★★★★ ()
Последнее исправление: record (всего исправлений: 2)
Ответ на: комментарий от record

Т.е. доставлять левые пакеты по бредовым зависимостям - это норм, а условно полезные расширения браузера - нет? Чем они хуже? Назвался дебайновцем, хавай, что дают.

Citramonum ★★ ()
Ответ на: комментарий от Citramonum

Тем что пакетные зависимости - они общесистемные, а расширения браузера - персональные.
(не берем тривиальные случаи, когда система по факту однопользовательская, да?)

record ★★★★★ ()
Последнее исправление: record (всего исправлений: 2)
Ответ на: комментарий от record

пакетные зависимости - они общесистемные, а расширения браузера - персональные

Кто такую классификацию утвердил? Глупости. Расширение - модификация браузера. В Дебайне решили, что теперь браузер будет вот такой. Несогласные диссиденты могут отключить расширение галочкой в настройках.

Citramonum ★★ ()
Ответ на: комментарий от Citramonum

а еще тем кде всяких понапихано такого не позволяет себе даже суся

anonymous ()
Ответ на: комментарий от FiXer

Обанта ... Debian с пересборкой 7% пакетов

Человека от шимпанзе отличает как раз ~7% генов ;)

special-k ★★★ ()
Ответ на: комментарий от t500s

Поставил mate по инструкции http://wiki.mate-desktop.org/download

В обновлении программ (и дистров ОС) мне всегда нравилась постепенная эволюция. Mate вроде продолжает традиции вторгнома. :-)
Когда же новые версии строятся на отрицании предыдущих и меняются до неузноваемости, имхо, это не правильно.

record ★★★★★ ()
Ответ на: комментарий от Reset

Так какой смысл вообще в непредсказуемом, негарантированном, медленном обновлении? Например, RHEL _официально_ не поддерживает обновление, его конечно можно сделать на свой страх и риск, но в саппорт с проблемами на такой системе можно не обращаться — найух пошлют.

4.2. Ты хоть в RHN заходил под своей учеткой хоть раз? Походу ты даже не знаешь что это и зачем. Все прекрасно обновляется. И вообще пруф в студию.

http://www.redhat.com/solutions/migration/upgrade-red-hat-enterprise-linux-re...

gh0stwizard ★★★★★ ()
Ответ на: комментарий от Reset

виртуализация тебе в помощь и отказоустойчивые системы... и кстати без обновлений безопасности чакать тебя и твои сервера будут на раз ;)

ЗЫ счастья тебе! надеюсь работу ты найдешь не скоро...

perchibald ()
Ответ на: комментарий от perchibald

виртуализация тебе в помощь и отказоустойчивые системы... и кстати без обновлений безопасности чакать тебя и твои сервера будут на раз ;)

Ты несколько не в теме. Он же из яндекса, а у них судя по их видеокурсам, админы должны управлять 20 тыс. серверами (хотя в гугле 1 админ на 1 тыс), конечно, они рано или поздно вылетят. Хотя бы из-за сбоя диска/контроллера/перегрева моста.

Только вот непонятно зачем им вообще что-то чинить, когда есть ресурсы на содержание парка запасных и уже подготовленных серваков: вытащил сломанный, поставил новый, запустил, победил.

И виртуализация это круто, но не всегда спасет. Системный диск это обычный диск, который может слететь вместе с dom.

gh0stwizard ★★★★★ ()
Ответ на: комментарий от gh0stwizard

хотспайр и автоматическая балансировка нагрузки помогают ;)... проверенно же

perchibald ()
Ответ на: комментарий от perchibald

хотспайр и автоматическая балансировка нагрузки помогают ;)... проверенно же

Видимо в яндексе не настолько богаты. И если они копируют во всем гугл, то у них этого нет: дешевые мат. платы, по два сервера в одном корпусе и по два диска на каждый.

gh0stwizard ★★★★★ ()

что-то боязно обновляться

iLoveoOz ★★★★ ()

поменял репозитории на wheeze, менеджер обновлении виснет наглухо.

apt-get update - обновилось несколько пакетов.

apt-get dist-upgrade - нашлось 400 с чем то пакетов на полтора гига. Обновление встало на openjdk. Снес пакет, обновлениe шло около получаса и зависло, вылезла ошибка что-то там с dpkg. Повторил обновлениe - sudo уже не работает, нет файла sudoers. Перезагрузил. В груб осталось то же ядро, попал в терминал, где уже версия системы 7. Sudo так же не работает. Загрузился в recovery mode для прав рута. Обновлениe шло еще минут 20. Во время обновления промелькивали фейлы и варнинги. Обновлениe встало на mysql из за зависимостей. Плюнул и снес нафиг squeeze. Поставлю wheeze с нуля, а то не известно, что там еще меня ожидает.

zevilz ★★★ ()

О синтезаторе речи вопрос. Как пакет называется и как его использовать?

rezedent12 ☆☆☆ ()
Ответ на: комментарий от int13h

А чего его ждать-то было? У меня Wheezy уже больше года крутится. А ура надо кричать только из-за того, что этот релиз от сида отвязали! Терь сид в горку пойдет.

terraslav ()
Ответ на: комментарий от perchibald

При чем тут виртуализация и обновления безопасности? Ты похоже вообще не понял о чем я

Reset ★★★★★ ()
Ответ на: комментарий от gh0stwizard

А под какой проект должна быть настроена запасная машина? Держать под все не рационально, поэтому машинки чистые.

Reset ★★★★★ ()
Последнее исправление: Reset (всего исправлений: 1)
Ответ на: комментарий от Reset

А под какой проект должна быть настроена западная машина?

Что значит западная? :) Все зависит от задач, которые должен решать проект. И ради машины обычно не ищут проекты.

Держать под все не рационально, поэтому машинки чистые.

Опять же все зависит от постановки задач, а также выделенных ресурсов, требований и условий. То что у ВАС так принято не значит, что это идеальное решение.

Здравомыслящих людей все меньше и меньше...

gh0stwizard ★★★★★ ()
Последнее исправление: gh0stwizard (всего исправлений: 1)
Ответ на: комментарий от perchibald

Конечно помогают, но не исключают вылета машин

Reset ★★★★★ ()
Ответ на: комментарий от Reset

Держать под все не рационально, поэтому машинки чистые.

Если говорить конкретно, то представим себе проект, состоящий из 100 различных частей. Для каждой части выделяется разное кол-во машин из всего 100 тыс. При этом каждая составная часть имеет разный набор утилит, настроек и т.п. Усложним задачу тем, что каждая группа должна иметь свой спефичный набор версий (одна на java 6, другая на java 5, третья на java 7 и т.п.). А теперь еще надо всегда вовремя все это обновлять. Раз в год часть младшей группы (java 5) должна апгрейдится на более старшую версию (java 6), а средняя на следующую и т.д.

Что ты будешь делать в таком случае?
Наймешь сто людей?
Пошлешь нафиг таких проектировщиков и пограмистов?

gh0stwizard ★★★★★ ()
Ответ на: комментарий от perchibald

Я об обновлении системы на следующий релиз. Кстати, вот и первый пострадавший.

Reset ★★★★★ ()
Ответ на: комментарий от zevilz

Проще всего обновляться в два захода: сначала aptitude safe-upgrade, а потом в aptitude руками разрулить проблемы с зависимостями, их после safe-upgrade остаётся совсем немного.

i-rinat ★★★★★ ()
Ответ на: снизойду до ответа анунусу от via4e

=) Улыбнул, дядь. os2 - Мерлина в студию!!!

Пристрастия к фейсу =)) Небось как плюс выполз к 95 - сразу ставить начал?..

Ох уж мне эти ребятки. А фейс - с тех радостных времен кваки и даггера 2, фидо да BBC - КонСоль да NC, DN commanders. Вот, блина, весь шелл. Тоже мне... Олд...

Как ты писал, накатило.

dodevich ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.