LINUX.ORG.RU
ФорумTalks

Steam For Linux

 


1

9

Steam for Linux limited beta has begun! The first wave of welcome emails has been sent out! If you've filled out the survey but haven't received an email don't despair. We will be expanding the beta in the future with more participants from the survey.

Thanks for all your support in getting this out the door, the Valve Linux team

пруф
Кому имеил пришёл?

Кому имеил пришёл?

Стим тебя поимеил.

FiXer ★★☆☆☆ ()

Нет, но уже есть в AUR.

Axon ★★★★★ ()

Не пришло. Надо было наверное юнити выбирать, а не гном. Да и по смыслу ближе, так как у меня компиз в качестве оконного менеджера.

PolarFox ★★★★★ ()
Последнее исправление: PolarFox (всего исправлений: 1)

Не запускается:

$ steam
Setting up steam platform in /home/user/Steam
cp: не удалось выполнить stat для «/usr/share/applications/steam.desktop»: Нет такого файла или каталога
chmod: невозможно получить доступ к «/home/dreamsoul//steam.desktop»: Нет такого файла или каталога
/usr/local/bin/steam: line 17: [: jockey-common: ожидается использование унарного оператора
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  12
  Current serial number in output stream:  13

bsdfun ★★★★★ ()
Ответ на: комментарий от bsdfun

У меня запустилось, поставилось и написало, что эта версия Steam в данный момент закрытая бета.

Artificial_Thought ★★★★ ()

Ну что, 64 бита не осилили?

Deleted ()

Заапдейтился, но не теперь не запускается...

Axon ★★★★★ ()

Пришел. Пакет steam.deb потребовал i386 зависимостей, которых в убунте нет и я его снес.

urandom ()

Проверил - на 32битной убунте тоже не работает. Мдё.

Axon ★★★★★ ()
sudo dpkg -i steam.deb 
[sudo] password for roman: 
Выбор ранее не выбранного пакета steam.
(Чтение базы данных … на данный момент установлен 106281 файл и каталог.)
Распаковывается пакет steam (из файла steam.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет steam:
 steam зависит от multiarch-support (>= 2.15-0ubuntu10.2), однако:
  Версия multiarch-support в системе 2.13-36.
 steam зависит от libjpeg-turbo8, однако:
 steam зависит от libcurl3-gnutls (>= 7.16.2-1), однако:
 steam зависит от libpixman-1-0 (>= 0.24.4-1), однако:
  Пакет libpixman-1-0 не установлен.
 steam зависит от libsdl1.2debian (>= 1.2.10-1), однако:
 steam зависит от libvorbisfile3 (>= 1.1.2), однако:
 steam зависит от libc6 (>= 2.15), однако:
  Версия libc6:i386 в системе 2.13-36.
 steam зависит от libcairo2 (>= 1.6.0), однако:
  Пакет libcairo2 не установлен.
 steam зависит от libgdk-pixbuf2.0-0 (>= 2.22.0), однако:
  Пакет libgdk-pixbuf2.0-0 не установлен.
 steam зависит от libgtk
dpkg: ошибка при обработке параметра steam (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db …
Обрабатываются триггеры для hicolor-icon-theme …
При обработке следующих пакетов произошли ошибки:
 steam
[roman@debian ~]$ sudo apt-get -f install 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  steam:i386
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 332 MB.
Хотите продолжить [Д/н]? 

332 MB, интересно.

roman77 ★★★★★ ()
Ответ на: комментарий от flareguner

А я особенно и не удивился. Это же AUR. :-)

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Пробовал через dpkg -i, не прокатило, помог Ubuntu Software Center (Xubuntu 12.04). Он подхватит зависимости.

PaRuSoft ★★★★ ()
Ответ на: комментарий от PaRuSoft

http://storage3.static.itmages.ru/i/12/1107/h_1352232843_7722646_80c1f0e1b5.png

Похоже, что это окошко можно игнорировать, но игрушка (у меня почему-то только limbo) не ставится (вернее делает вид что ставится, но при этом ничего не грузит и затем не запускается). А так интерфейс стима целиком работает, гораздо лучше, чем под вайном.

PolarFox ★★★★★ ()
Ответ на: комментарий от PolarFox

У меня даже значек в трее не появляется, а окошко это не дает ничего нажать. Видимо Xfceпроблемы

PaRuSoft ★★★★ ()

Мда, поставился. Короче похоже из сорсовских игр только TF2. Не из сорс, из того что у меня еще есть: Serious Sam 3 (откуда он у меня?!), Psychonauts, Killing Floor и куча инди-шлака вроде пенумбр и дефкона, которые и так были под линукс.

urandom ()

А в какой каталог разворачивается стим и где он хранит игры?

static_lab ★★★★★ ()
Ответ на: комментарий от PolarFox

Похоже, что это окошко можно игнорировать

У меня не получается. Даже двигать его не даёт, при этом интерфейс стима не отзывается.

Axon ★★★★★ ()

Писем не получал. На Ubuntu 12.04 выложенный выше deb-пакет поставился через dpkg -i, дополнительно ничего не притянул, в процессе загрузки хвоста продермонстрировал шг. После логина отпинывает в связи с состоянием беты и закрывается. В хомяке создал директорию Steam:

timon@timon-laptop:~/Steam$ ls
appcache             frameworks  package       resource                 steam      tenfoot
bin                  friends     public        servers                  SteamApps  thirdpartylegalnotices.doc
ClientRegistry.blob  graphics    registry.vdf  skins                    steam.log  ubuntu12_32
config               logs        reslists      ssfn6424384868541609887  steam.sh   userdata

Разворачивать приложения похоже будет в ней же.

timon-ltv ()

Попробовал поставить на убунту в виртуалке - не получилось, зато нашел в ~/Steam/ubuntu12_32

mssdsp.flt    mssmixer.mix  mssmp3.asi    mssogg.asi    mssvoice.asi

$ file mssmixer.mix 
mssmixer.mix: PE32 executable (DLL) (GUI) Intel 80386, for MS Windows

bsdfun ★★★★★ ()
Ответ на: комментарий от Axon

Черт, после скачки обновления он пишет;

steam 
Installing breakpad exception handler for appid(steam)/version(1352224866_client)
flareguner ()
Ответ на: комментарий от Axon

У меня не получается. Даже двигать его не даёт, при этом интерфейс стима не отзывается.

Откройте ссылку steam://open/friends но игры поставить всё равно не получится.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от bsdfun

Там внутри бинарник стима, запускается, но требует подключения к интернетам.

gatsu% ./steam 
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
SteamUpdater: Error: Couldn't create cache directory /home/gatsu/Steam/package, got error 20
SteamUpdater: Error: Steam needs to be online to update.  Please confirm your network connection and try again.

Это без запущенного NetworkManager'а. А с запущенным NM у меня интернет не работает :(

gatsu ()

Умудрился поставить World of Goo и успешно её запустить. Правда это единственное, что пустилось. =(

Artificial_Thought ★★★★ ()
Ответ на: комментарий от Artificial_Thought

Не успел появиться, как умелые лоровцы его расхакали :)

flareguner ()
Ответ на: комментарий от RussianNeuroMancer

Откройте ссылку steam://open/friends

Где?

Axon ★★★★★ ()
Ответ на: комментарий от Axon

в консоли блин бинарю стима передай этот параметр, линуксоиды блина

bhfq ★★★★★ ()
Ответ на: комментарий от whiskydotjar

«Я что-то нажал и оно само...»
Оно выкидывает модальное окно, что мол хрен тебе, а не бета, а чуть позже другое, где говорится, что ваш видеодрайвер устарел. Вот там жмём cancel и первое окно чудесным образом становится не модальным и его можно игнорировать.

Artificial_Thought ★★★★ ()

От безысходности и из интереса добавил Non-steam игру — Hedgewars. Добавилось и запускается, даже вроде какая-то статистика запусков ведется. Удалось запустить по методу рекомендованному выше bhfq.

timon-ltv ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.