LINUX.ORG.RU
ФорумTalks

[qt-4.8] счастье


0

3
  • 1. qt-curve стала в 2 раза быстрей:
    с 4.7.4 выдавала в qtperf 0.14*
    с 4.8 - 0.06*
    а оксиген как было 0.20* так и осталось - муахаха :3
    для сравнения - Motif - 0.04*
  • 2. appmenu теперь искаропки работает - никаких патчей не надо
    на один ебилд меньше ковырять )
  • 3. естественным следствием пункта 1 стал мгновенный запуск qt-софта


/me налил кружку зелёного чая и тащицо

★★★★

немного оффтоп, но ты кмикс юзаешь? Они кажется клизмоид сломали. Громкость регулируется, а ползунок не ездит...

pekmop1024 ★★★★★ ()
Ответ на: комментарий от pekmop1024

неа - не пользуюсь
у меня хоткеи же овер xbindkeys

"amixer set Master 1+"
Alt + b:4

"amixer set Master 1-"
Alt + b:5

megabaks ★★★★ ()
Ответ на: комментарий от seed_stil

я давно уже пересобрал
ещё несколько часов назад )

[ root@desktop ] megabaks # for i in `qlist -ICv x11-libs/qt-`;do genlop -t ${i};done
 * x11-libs/qt-core

     Mon Jan 30 01:30:07 2012 >>> x11-libs/qt-core-4.8.0-r1
       merge time: 7 minutes and 16 seconds.

 * x11-libs/qt-dbus

     Mon Jan 30 01:32:40 2012 >>> x11-libs/qt-dbus-4.8.0
       merge time: 37 seconds.

 * x11-libs/qt-declarative

     Mon Jan 30 02:23:06 2012 >>> x11-libs/qt-declarative-4.8.0-r1
       merge time: 2 minutes and 58 seconds.

 * x11-libs/qt-gui

     Mon Jan 30 01:43:01 2012 >>> x11-libs/qt-gui-4.8.0-r1
       merge time: 10 minutes and 21 seconds.

 * x11-libs/qt-opengl

     Mon Jan 30 01:45:19 2012 >>> x11-libs/qt-opengl-4.8.0-r1
       merge time: 1 minute and 40 seconds.

 * x11-libs/qt-qt3support

     Mon Jan 30 01:48:25 2012 >>> x11-libs/qt-qt3support-4.8.0
       merge time: 3 minutes and 27 seconds.

 * x11-libs/qt-script

     Mon Jan 30 01:32:03 2012 >>> x11-libs/qt-script-4.8.0
       merge time: 1 minute and 56 seconds.

 * x11-libs/qt-sql

     Mon Jan 30 01:44:58 2012 >>> x11-libs/qt-sql-4.8.0
       merge time: 50 seconds.

 * x11-libs/qt-svg

     Mon Jan 30 01:44:12 2012 >>> x11-libs/qt-svg-4.8.0
       merge time: 1 minute and 10 seconds.

 * x11-libs/qt-test

     Mon Jan 30 01:43:52 2012 >>> x11-libs/qt-test-4.8.0
       merge time: 50 seconds.

 * x11-libs/qt-webkit

     Mon Jan 30 02:20:08 2012 >>> x11-libs/qt-webkit-4.8.0
       merge time: 30 minutes and 13 seconds.

 * x11-libs/qt-xmlpatterns

     Mon Jan 30 01:49:55 2012 >>> x11-libs/qt-xmlpatterns-4.8.0
       merge time: 6 minutes and 53 seconds.

[ root@desktop ] megabaks #
только вебкит и собирался долго

megabaks ★★★★ ()

ну круто же! жду обновления SDK.

dib2 ★★★★★ ()
Ответ на: комментарий от megabaks

Класс! Будет чем вечером посинеглазить. :D

imul ★★★★★ ()
Ответ на: комментарий от uniqwert

нигода такого не замечал
сейчас лень ставить konsole чтобы посмотреть

megabaks ★★★★ ()
Ответ на: комментарий от seed_stil

Шел 2012 год, а КДЕ все никак не могло починить переключалку

lester_dev ★★★★★ ()

Что за?

# emerge qt-core -avb
...
[blocks B      ] <x11-libs/cairo-1.10.2-r2 ("<x11-libs/cairo-1.10.2-r2" is blocking x11-libs/qt-core-4.8.0-r1)

Total: 9 packages (9 new), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/cairo-1.10.2-r1::gentoo, installed) pulled in by
    >=x11-libs/cairo-1.2 required by (gnome-base/librsvg-2.34.2::gentoo, installed)
    >=x11-libs/cairo-1.6[X,svg] required by (x11-libs/gtk+-2.24.8-r1::gentoo, installed)
    >=x11-libs/cairo-1.8[X] required by (app-office/abiword-2.8.6-r2::gentoo, installed)
    >=x11-libs/cairo-1.7.6[X] required by (x11-libs/pango-1.29.4::gentoo, installed)
    x11-libs/cairo[glib] required by (dev-libs/gobject-introspection-1.30.0-r2::gentoo, installed)

  (x11-libs/qt-core-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.8.0[-aqua,-c++0x,-qpa,-debug,qt3support] required by (x11-libs/qt-qt3support-4.8.0::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.8.0[-aqua,-c++0x,-qpa,-debug,qt3support] required by (x11-libs/qt-sql-4.8.0::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.8.0[-aqua,-c++0x,-qpa,-debug] required by (x11-libs/qt-dbus-4.8.0::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.8.0[-aqua,-c++0x,-qpa,-debug,glib,qt3support] required by (x11-libs/qt-gui-4.8.0-r1::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.8.0[-aqua,-c++0x,-qpa,-debug] required by (x11-libs/qt-script-4.8.0::gentoo, ebuild scheduled for merge)
    qt-core


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
# cat /usr/portage/x11-libs/qt-core/qt-core-4.8.0-r1.ebuild | grep  cairo
	!<x11-libs/cairo-1.10.2-r2"

Замаскировать x11-libs/cairo-1.10.2-r2 ?

ymuv ★★★★ ()

Не обновляется

localhost joker # emerge -av qt-core

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-libs/qt-core-4.7.4-r1  USE="exceptions glib iconv jit optimized-qmake private-headers qt3support ssl (-aqua) -debug -pch" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.8.0-r1::gentoo, ebuild scheduled for merge) conflicts with
    ~x11-libs/qt-gui-4.7.4[-aqua,-debug] required by (x11-libs/qt-multimedia-4.7.4::gentoo, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/qt-core:4

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-libs/qt-core-4.7.4-r1
^C

Exiting on signal 2
 * qt-everywhere-opensource-src-4.7.4.tar.gz RMD160 SHA1 SHA256 size ;-) ...    [ ok ]
localhost joker # 
fragment ()

счастье?

с 4.7.4 выдавала в qtperf 0.14*
с 4.8 - 0.06*

как мало некоторым для счастья -то надо:3

snoopcat ★★★★★ ()
Ответ на: комментарий от Kosyak

ок, надо будет как-то обновить и посмотреть, что они там натворили.

uniqwert ()
Ответ на: комментарий от pekmop1024

немного оффтоп, но ты кмикс юзаешь? Они кажется клизмоид сломали. Громкость регулируется, а ползунок не ездит...

При клике на иконку в трее - показывает ползунок с нулевой громкостью. Если открыть полностью - все нормально.

bsdfun ★★★★★ ()

естественным следствием пункта 1 стал мгновенный запуск qt-софта

Кстати да, отрисовка стала намного быстрее. :)

bsdfun ★★★★★ ()
Ответ на: комментарий от bsdfun

лол. у меня ползунок стал горизонтальным. и да, не ездит.

ass ★★★★ ()
Ответ на: комментарий от bsdfun

да, хватит некрофильничать - давно есть 0.15 с вебкитом и другими шлюхами

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

Обновлял, не помогло. Кайро нужно было собрать с юзом qt4

ymuv ★★★★ ()

У кого-то получилось собрать с флагом -cups? Оно все равно очень хочет cups/cups.h, которго естесственно нет :(

Yuriy ()
Ответ на: комментарий от Yuriy
[ megabaks@desktop ] ~ $ qlist -IUv x11-libs/qt-
x11-libs/qt-core-4.8.0-r1 (exceptions glib iconv qt3support ssl)
x11-libs/qt-dbus-4.8.0 (exceptions)
x11-libs/qt-declarative-4.8.0-r1 (accessibility exceptions qt3support webkit)
x11-libs/qt-gui-4.8.0-r1 (accessibility dbus exceptions gif glib mng nas qt3support tiff)
x11-libs/qt-opengl-4.8.0-r1 (exceptions qt3support)
x11-libs/qt-qt3support-4.8.0 (accessibility exceptions kde)
x11-libs/qt-script-4.8.0 (exceptions iconv jit)
x11-libs/qt-sql-4.8.0 (exceptions iconv mysql qt3support sqlite)
x11-libs/qt-svg-4.8.0 (accessibility exceptions iconv)
x11-libs/qt-test-4.8.0 (exceptions iconv)
x11-libs/qt-webkit-4.8.0 (dbus exceptions jit kde)
x11-libs/qt-xmlpatterns-4.8.0
[ megabaks@desktop ] ~ $
megabaks ★★★★ ()

Тогда ждем абилдов и собранных пакетиков. И да, УМ не qtcurve, а gtk, ведь с ним тоже повысится скорость, да?

uju ★★ ()
Ответ на: комментарий от Yuriy

Yuriy

Но cups у тебя стоит-же. Флаги флагами, а без него оно не собирается.

кто тебе такую херь сказал? о_О

[ megabaks@desktop ] ~ $ qlist -Iv cups
[ megabaks@desktop ] ~ $

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>> Замаскировать x11-libs/cairo-1.10.2-r2 ?

> cairo обнови и всё

Не помогло.

[ebuild     U  ] x11-libs/qt-core-4.8.1-r2 [4.7.1-r1] USE="exceptions glib iconv pch* ssl (-aqua) (-c++0x) -debug -optimized-qmake (-qpa) -qt3support (-jit%*) (-private-headers%)" 233,991 kB
[blocks B      ] >x11-libs/qt-core-4.7.1-r9999 (">x11-libs/qt-core-4.7.1-r9999" is blocking x11-libs/qt-gui-4.7.1-r1, x11-libs/qt-script-4.7.1-r1, x11-libs/qt-dbus-4.7.1)
[blocks B      ] <x11-libs/qt-script-4.8.1 ("<x11-libs/qt-script-4.8.1" is blocking x11-libs/qt-core-4.8.1-r2)
[blocks B      ] <x11-libs/qt-dbus-4.8.1 ("<x11-libs/qt-dbus-4.8.1" is blocking x11-libs/qt-core-4.8.1-r2)
[blocks B      ] <x11-libs/qt-gui-4.8.1 ("<x11-libs/qt-gui-4.8.1" is blocking x11-libs/qt-core-4.8.1-r2)

Total: 1 package (1 upgrade), Size of downloads: 233,991 kB
Conflict: 4 blocks (4 unsatisfied)
ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.